Advertisement:

Author Topic: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared  (Read 5082 times)

Offline assemblytube

  • Semi-Newbie
  • *
  • Posts: 27
Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« on: September 28, 2016, 02:48:32 PM »
Just did an upgrade from SMF 2.0.11 to 2.1.12 by clicking on the link that appeared in the admin centre.

It said all the tests were successful so I went ahead.

As soon as the update completed, all of the menus at the top of my forum disappeared completely.

I uninstalled and they all came back.

Any ideas on where I should look for a solution?

Thanks

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,769
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #1 on: September 28, 2016, 03:13:18 PM »
What theme are you using?
What is your site URL?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Online d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,125
  • Gender: Male
    • frandominguez03 on GitHub
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #2 on: September 28, 2016, 04:40:00 PM »
Hello!

Were you using any Mods for the menu?

Regards :)

"Greeting Death as an old friend, they departed this life as equals."

Offline Matthew K.

  • SMF Super Hero
  • *******
  • Posts: 12,430
  • Gender: Male
    • matthew.kerle on Facebook
    • @matthew_kerle on Twitter
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #3 on: September 28, 2016, 05:19:22 PM »
This actually happened to me last night as well. The site had about 20 modifications and I couldn't isolate very quickly which one was causing it and I didn't have the time necessary to full figure it out. Definitely looks like a commonly installed modification is breaking the navigation.

Offline swordsman1

  • Semi-Newbie
  • *
  • Posts: 27
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #4 on: September 28, 2016, 08:00:30 PM »
Happens here also.


Theme: SMF Default Theme - Curve

Mods:
Regbar Warning 1.0.5
Ad Managment   3.0.1
Anti-Spam Links   1.0.1
CloudFlare   1.1
Recent Topics On Board Index   1.03
Global Headers Footers   2.0.1

Offline assemblytube

  • Semi-Newbie
  • *
  • Posts: 27
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #5 on: September 29, 2016, 07:38:01 AM »
Hi Kindred,
My theme is Dark Modern and my site is http://assemblytube.com/forum/index.php

I have a very large number of mods installed (70+) and have done for a long time without problems.

2 mods in common with swordsman1 are
Ad Managment   3.2
Global Headers Footers   2.0

A mod that I use that directly works with the menu is
6 Custom buttons / tabs with Sub Menus (4) 0.5

Thanks for any clues to a fix.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,986
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #6 on: September 29, 2016, 07:39:55 AM »
can you try to uninstall that custom buttons mod and see if the menu works?

Offline Matthew K.

  • SMF Super Hero
  • *******
  • Posts: 12,430
  • Gender: Male
    • matthew.kerle on Facebook
    • @matthew_kerle on Twitter
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #7 on: September 29, 2016, 10:16:25 AM »
It happens on two sites of mine with no custom menu mod. Do you have caching on, by chance? Check Admin -> Configuration -> Server -> Caching

Offline Matthew K.

  • SMF Super Hero
  • *******
  • Posts: 12,430
  • Gender: Male
    • matthew.kerle on Facebook
    • @matthew_kerle on Twitter
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #8 on: September 29, 2016, 10:20:15 AM »
One of the forums I manage that was having this issue had caching on. I turned it off and now the menu doesn't disappear. Seems to be a bug with the new serialise method and the length.

Offline aegersz

  • SMF Hero
  • ******
  • Posts: 1,543
  • Gender: Male
  • the "mods and tweaks" junkie
    • dopetalk
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #9 on: September 30, 2016, 03:32:37 AM »
... which maybe why SimplePortal's Shoutbox doesn't load shouts (see http://simpleportal.net/index.php?topic=14380) !

can i assume that the bug lies with SMF and that is affecting the Shoutbox, too ?

perhaps with the change: Fixed vulnerable unserialize() code by converting all instances to safe_unserialize() ?
« Last Edit: September 30, 2016, 04:32:01 AM by aegersz »
The configuration of my Linux VPS (SMF 2.0 with 145 mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Offline assemblytube

  • Semi-Newbie
  • *
  • Posts: 27
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #10 on: September 30, 2016, 05:59:21 AM »
Thanks Matthew K.
I turned off server caching and the update worked fine. My top menus did not disappear.

Offline aegersz

  • SMF Hero
  • ******
  • Posts: 1,543
  • Gender: Male
  • the "mods and tweaks" junkie
    • dopetalk
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #11 on: September 30, 2016, 06:09:38 AM »
yeah BUT you want caching on, don't you ?

I backed off the Upgrade thinking that it will be updated.
The configuration of my Linux VPS (SMF 2.0 with 145 mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Offline assemblytube

  • Semi-Newbie
  • *
  • Posts: 27
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #12 on: September 30, 2016, 06:45:16 AM »
Hi aegerszm
I upgraded because there is something in the upgrade about PayPal compatibility and I was concerned that my paid subscriptions might not go through if I did not upgrade.
I have no idea if the upgrade would have an effect there because I do not understand it enough, but I know something in PayPal changes today 30th September 2016.

I agree that a fix that allows the cache to work with the upgrade would be the best option. I guess it will be affecting a lot of SMF websites if it is not fixed.

Best wishes.

Online shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,736
    • sbulen on GitHub
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #13 on: October 01, 2016, 11:32:51 AM »

I was nervous about the patch due to these threads.

After applying the 2.0.12 patch in my test environment, my top menus disappeared.  But they returned after a while as I logged off my admin account & logged back on as a regular user to take a look around. 

So, for me, the issue was fleeting. 

I applied the patch to my prod site, and there were no issues whatsoever.   

Notes on my caching setting & notifications, in case folks are exploring the idea it may be a caching issue:
     Both my test & prod site have caching set to Level 1.
     Both sites do, however, report this: "SMF has not been able to detect a compatible accelerator on your server."

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,980
    • StoryBB/StoryBB on GitHub
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #14 on: October 01, 2016, 12:55:53 PM »
If you have no compatible accelerator, it will fall back to the file cache. Which is where the problem is due to the serialise routine used by the cache and specifically the (new) unserialise routine deciding that there's too much data and just dropping it.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,730
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #15 on: October 01, 2016, 01:10:34 PM »
I am not using those mods; however, I have custom menus.  I was able to see the menus as a regular user using another browser but when I logged in they disappeared.  I removed upgrade for now by adding "action=admin" to the end of the string.

I have cache and I do not disagree that may be the issue.  But I want to  review the code before reinstalling.

I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline butchs

  • SMF Hero
  • ******
  • Posts: 1,730
  • Lost 7GB bandwidth!
    • EastCoastRollingThunder
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #16 on: October 01, 2016, 01:27:41 PM »
It appears to be the editor.js changes are affecting the menu script via cache.  I will try again during off hours and reset the cache.
 
I have been truly inspired by the SUGGESTIONS as I sit on my throne and contemplate the wisdom imposed upon me.

Offline aegersz

  • SMF Hero
  • ******
  • Posts: 1,543
  • Gender: Male
  • the "mods and tweaks" junkie
    • dopetalk
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #17 on: October 01, 2016, 07:02:48 PM »
it was reported in another post to remove the length test for exceeding 4096 in Subs. php (search: 'exceeds') but despite this, my issues with Simple Portal still persist.
The configuration of my Linux VPS (SMF 2.0 with 145 mods & some assorted manual tweaks) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum). My (House) music DJ dedication page is here

Offline Burt

  • Semi-Newbie
  • *
  • Posts: 97
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #18 on: October 02, 2016, 07:53:45 AM »
I'm also not able to upgrade to 2.0.12 as the entire menu disappear after upgrading. I do however use Menu Editor Lite...


Regards




If you Sig. line is longer or higher than two line, you are just an attention seeker. Grow up!

Offline 4LP3RUZ1

  • SMF Hero
  • ******
  • Posts: 3,438
  • Gender: Male
  • Frozen frogs are gone!
Re: Upgraded from 2.0.11 to 2.0.12 and top menus disappeared
« Reply #19 on: October 05, 2016, 12:37:06 PM »
same problem on my site: http://www.toyotaclubtr.com/

had to revert back to 2.0.11
Frozen frogs are back :(