• Welcome to Simple Machines Community Forum. Please login or sign up.

Sorry, SMF was unable to connect to the database

Started by _opeth, October 13, 2016, 09:27:24 AM

Previous topic - Next topic

_opeth

I know in the forum we have bunch of topics like this but this time it is different.

First we build the forum on root directory then we add WordPress on the root directory the move the forum to /forum directory.

On some topic some user quoted answers or quick answers have this error

Connection Problems

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.
Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 346

Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 347

Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 348

Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 351

Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 352

Warning: Cannot modify header information - headers already sent by (output started at /home/jdm/public_html/forum/Sources/Errors.php:415) in /home/jdm/public_html/forum/Sources/Errors.php on line 353
Connection Problems

Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


But the sended message is saved to the topic.

Wordpress an SMF are not sychronized but also i uninstalled the akismet, i did the repair settings tool many times but nothing fixed.

on smf side we have these modifications

1.   Stop Spammer   2.3.9 
2.   Tapatalk SMF 2.0 Plugin   4.4.1 
3.   Simple Audio Video Embedder   3.5.1 
4.   Global Headers Footers   2.0.1        
5.   SMF 2.0.12 Update   1.0     
6.   SEO Sitemap   2.2.1     
7.   ResizeImagesToFitScreen   0.1.6 
8.   Like Posts

also uninstalled mods WYSIWYG Quick Reply    2.3 and SMF2WPBridge 1.1.2

thanks for the support

d3vcho

"Greeting Death as an old friend, they departed this life as equals"


Illori

then you need to contact your host and see if they can tell you more information.

_opeth

i cantact with the hosting but they said on our side we have no problem. any help?

_opeth


d3vcho

Hello!

Please check that your data in your Settings.php file are all correct. There might be a mistake.

Regards :)
"Greeting Death as an old friend, they departed this life as equals"

DarkAngel612

I too am plagued with this error, here is what I posted myself

QuoteI just upgraded all forums to 2.012 and from not having this error message now 2 (different hosts) now have this error_log file.

I have looked for duplicate entries in the files for the different mods installed and none are found, of course when I update I also place fresh files in each template so the mods need to add their edits and not get duplicates.

I am also getting the SMF can not connect to database PHP Warning:  Cannot modify header information - headers already sent in /home/path/Sources/Errors.php on line 347, yet the sites are running flawlessly.

I also have run the repair_settings.php file numerously, deleted sessions from sessions table in DB. optimized, repaired DB's. My host is hostdime, bluehost is for the other site and both say the same thing, there is nothing wrong on their end so it must be the SMF end acting up.

Hostdime is dedicated server
bluehost is shared

Before the upgrade I did not have any issues. No new mods, same mods that I had prior to upgrading and all template files that might have gotten edited by mods were fresh clean original files.

I can get the errors every 3 minutes or not for a span of 20+minutes
Fantasy Attic ::  Fantasies Realm Market :: SMF 2.0+ with various mods and TinyPortal

Illori

please open a separate topic for your issue. this topic belongs to someone else.

_opeth if your host will not help you resolve the issue then i would start looking for a new host. really this is a server/host issue and the host should have no problem working with you to get the issue resolved.

_opeth

only some topics and sections did this error which has interact on 18th of October. we will dig in to sql db

Advertisement: