Advertisement:

Author Topic: 2.0.7 to 2.0.12 upgrading trouble  (Read 2127 times)

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
2.0.7 to 2.0.12 upgrading trouble
« on: October 25, 2016, 08:55:05 AM »
Hi Guys/Ladies,

I've just installed SMF on my host and wondered why it has only loaded the 2.0.7 version of the platform?

I've uploaded the new 2.0.12 version after compressing it on the mac after download, tho once it's loaded it give me an error saying the file is empty .. any ideas to give us a hand please.

(sorry to start a new post, but i couldn't seem to find any details in relation to 2.0.7 > 2.0.12)

Cheers in advance

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,748
  • Gender: Male
    • Kindred-999 on GitHub
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #1 on: October 25, 2016, 09:39:59 AM »
you can't use the package manager to upgrade from 2.0.7 directly to 2.0.12

You have to use the patch files to go from .7 to .8, then to .9, etc...
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #2 on: October 25, 2016, 09:42:55 AM »
you can't use the package manager to upgrade from 2.0.7 directly to 2.0.12

You have to use the patch files to go from .7 to .8, then to .9, etc...


AAHHH.. Cheers for that. any explanation as to why it's saying the file is empty? .. I've tried to upload the 2.7>2.8 and again it's empty

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,748
  • Gender: Male
    • Kindred-999 on GitHub
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #3 on: October 25, 2016, 09:45:11 AM »
well, you are not using the patch file... you would seem to be trying to use the large upgrade or the install archives...

and why would you download and then "after compressing it on the mac after download"??

the patch files (and, indeed the full install and large upgrade archives) are already compressed
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,963
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #4 on: October 25, 2016, 09:50:16 AM »
Safari tends to unarchive the archive on download. Disable that and try downloading again.

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #5 on: October 25, 2016, 09:54:00 AM »
well, you are not using the patch file... you would seem to be trying to use the large upgrade or the install archives...

and why would you download and then "after compressing it on the mac after download"??

the patch files (and, indeed the full install and large upgrade archives) are already compressed

When i down load it, it turns to a file and them you need to compress it to make it a zip file again....Just how it work on the Mac

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,748
  • Gender: Male
    • Kindred-999 on GitHub
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #6 on: October 25, 2016, 09:58:32 AM »
well, I would say "get a real computer" :P    but that wouldn't be useful... :D  (just kidding)

So, do as Illori says and disable the auto-decompress

and make sure that you are downloading the PATCH files....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #7 on: October 25, 2016, 10:04:53 AM »
well, I would say "get a real computer" :P    but that wouldn't be useful... :D  (just kidding)

So, do as Illori says and disable the auto-decompress

and make sure that you are downloading the PATCH files....

Cheers Guys, All fixed .. appreciated.

And just a note.. that Verification Process is a bit of a pita for someone with bad eye sight ;)..lol, thanks again

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,748
  • Gender: Male
    • Kindred-999 on GitHub
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #8 on: October 25, 2016, 10:25:01 AM »
yeah, we know...  it goes away after 10 posts...   and we're working on a better option
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #9 on: October 25, 2016, 10:25:32 AM »
So continuing on from that... from 9>10 I'm getting this message


Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF.


im not concerned about loosing any previous work .... moving to the .12 to upload new theme..

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,748
  • Gender: Male
    • Kindred-999 on GitHub
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aodio

  • Semi-Newbie
  • *
  • Posts: 54
Re: 2.0.7 to 2.0.12 upgrading trouble
« Reply #11 on: October 25, 2016, 10:50:28 AM »
http://wiki.simplemachines.org/smf/Error_in_mod_installation


So sorry i missed that Kindred.. i was reading your sig and thought ..ooook.. lol. Cheers