Advertisement:

Author Topic: Issue with SSI login  (Read 1654 times)

Offline maxwl

  • Newbie
  • *
  • Posts: 4
Issue with SSI login
« on: December 01, 2016, 05:52:12 AM »
Sorry if this question is already asked, I did a search for SSI but did not find a related question.

I have a local forum setup with the following: SMF 2.1, Maria DB 10, PHP 7.0. (Linux Mint 18)
The forum is configured to use global cookies.
I have integrated the forum with a website running on the same domain. Website is located at /var/www/html/site and the forum is installed in a subdirectory at /var/www/html/site/forum.

I am using the SSI.php located in the root of the forum folder for the integration. Problem is, I can login normally on the website, but if I try logging on through the website I am getting this error: Your session timed out while posting. Please go back and try again.

The log files are showing the following session_regenerate_id(): Session write failed. ID: user (path: /var/lib/php/sessions)
Write permission is correctly setup at /var/lib/php/sessions because when I login from the forum itself, a file is created in the folder. There is only a problem when using SSI.

I have been battling this issue for the past two days without resolve and is wondering if anyone can give some suggestions how to solve.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,498
  • Gender: Male
    • Kindred-999 on GitHub
Re: Issue with SSI login
« Reply #1 on: December 01, 2016, 09:05:21 AM »
what are your other settings for cookies and sessions?
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline maxwl

  • Newbie
  • *
  • Posts: 4
Re: Issue with SSI login
« Reply #2 on: December 01, 2016, 01:01:02 PM »
Here are the settings for the cookies and sessions
Cookie Name: SMFCookie735
Default login cookies length:  60  minutes
Enable local storage of cookies: off
Use subdomain independent cookies: on
Main domain used for subdomain independent cookies: blank
Force cookies to be secure: Disabled
Force cookies to be made accessible only through the HTTP protocol: On

Use database driven sessions: On
Allow browsers to go back to cached pages: On
Seconds before an unused session timeout: 2880 seconds

Two-Factor Authentication: Disabled

I also have a valid database username and password set for the SSI mode

Offline albertlast

  • Development Contributor
  • Full Member
  • *
  • Posts: 589
Re: Issue with SSI login
« Reply #3 on: December 02, 2016, 12:02:18 AM »
Which version of smf 2.1 you use? (source / Beta?)
Similiar issue are fixed in the github version some time ago.