Advertisement:

Author Topic: Upgrading issues from 2.0 to 2.1  (Read 2166 times)

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Upgrading issues from 2.0 to 2.1
« on: December 24, 2016, 01:07:45 PM »
Hello everyone,

We are ready for the move from 2.0.12 to 2.1 but having issues implementing it.

I followed directions, unzipped the files and copied the upgrade.php, upgrade_2-1_mysql.sql and upgrade_2-1_postgresql.sql files from Other to the main folder and also copied Settings.php here renaming it to Settings_bak.php. I then uploaded all to the root directory, separate from our live forum (permissions are set to 777). Fortunately we have a test forum so if we mess up at any time it's no problem. So after all these were done I tried running upgrade.php from the browser but says 'No input file specified'. Looks like missing a step?

Another question is since we have two forums a live and test forum (in two separate folders under root), does the upgrade searches for all instances and asks which to upgrade?

Any help is appreciated!
Blade~

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Re: Upgrading issues from 2.0 to 2.1
« Reply #1 on: December 24, 2016, 01:12:53 PM »
Hold on with this question, I am getting somewhere now ... sorry ...
Blade~

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Re: Upgrading issues from 2.0 to 2.1
« Reply #2 on: December 24, 2016, 01:21:20 PM »
All right so I got as far as I figuring out that it needed the Settings.php file, even thought the instructions says to rename it as Settings_bak.php. So I created both, ran it again and went this far:

Parse error: syntax error, unexpected T_FUNCTION in D:\Hosting\2138779\html\SMF2.1-release-2.1\Sources\Class-Package.php on line 621

Blade~

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,700
Re: Upgrading issues from 2.0 to 2.1
« Reply #3 on: December 24, 2016, 02:38:37 PM »
why are you trying to upgrade to SMF 2.1? it should not be used in production and if you are using it you should be using what is on github and report any issues on github so the developers can track the issues.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,123
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgrading issues from 2.0 to 2.1
« Reply #4 on: December 24, 2016, 03:00:48 PM »
To do upgrade, you do not use the settings.php in the other folder... you use the settings.php fro your original 2.0 installation

But also, as Illori has mentioned..,  do not use 2.1 beta in a production site.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Antes

  • Evil Black Cat
  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,920
  • Gender: Male
  • Black cat rulz!
    • Antes on GitHub
    • merta on LinkedIn
    • @XinYenFon on Twitter
    • Patreon
Re: Upgrading issues from 2.0 to 2.1
« Reply #5 on: December 24, 2016, 03:05:34 PM »
Another question is since we have two forums a live and test forum (in two separate folders under root), does the upgrade searches for all instances and asks which to upgrade?

No our upgrade file only works with the dir its in. As long as your databases are also separated you don't have anything to worry.

If you took files here, they are probably dated for some time, use these files; https://github.com/SimpleMachines/SMF2.1/archive/release-2.1.zip
You can support me directly via Patreon

In Catnip We Trust.
The solution is Catnip!
Vote for Catnip!

Current Project(s): [ WoWSnips ] # [ Lunarfall ] # [ RDD (HTML5) ] # [ ResponsiveCurve_Extras(SoonTM) ]
Past Project(s): [ ezPortal ]

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Re: Upgrading issues from 2.0 to 2.1
« Reply #6 on: December 26, 2016, 08:51:59 PM »
Thanks for the advice so far, I'm back at it again after X-mas.

I am not using the upgrade on a live forum, I am trying to get it working on our test forum.

I copied the 'Settings' file from my test forum over to the SMF2.1-release-2.1 folder and tried running the upgrade again, it did take me one step further but hanging again (see screen cap below).

Let me recap what I did, again, I followed the instructions: after unzipping the downloaded files I moved the files mentioned in the instructions to the main folder (upgrade.php, upgrade_2.1_sql files), then I uploaded everything on our server under root and is called 'SMF2.1-release-2.1'. As kindred suggested I copied the Settings file from our Test Forum over to the upgrade folder. The I ran the upgrade again from the SMF2.1 folder, again getting the error shown below.
Blade~

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,123
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgrading issues from 2.0 to 2.1
« Reply #7 on: December 26, 2016, 09:21:07 PM »
You have missed the point

In order to properly upgrade, you need to have a fully working 2.0.x installation alreayd installed.
If the 2.0.x forum is not working in that exact location, then the upgrade will fail

I don't know what instructions you are following that tell you to make an installation in a separate directory... but that will not work.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Re: Upgrading issues from 2.0 to 2.1
« Reply #8 on: December 26, 2016, 10:00:55 PM »
Kindred:

Our test forum is a fully functional forum but only us Admins have access to it, it's not visible to public.

Which instructions? LOL ... yours: http://www.simplemachines.org/community/index.php?topic=530252.0 . Right under step 6 says make sure the uploaded files are in a folder separate from any live installs. Are you saying all the upgrade files need to be copied to the forum we're upgrading?
Blade~

Offline Colin

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 7,869
  • Gender: Male
  • SMF Developer
    • colinschoen on GitHub
Re: Upgrading issues from 2.0 to 2.1
« Reply #9 on: December 26, 2016, 10:04:27 PM »
Hi Blade~,

Thanks for trying to help test out SMF 2.1. Make a copy of your live file structure to another directory then add the upgrade files to that copied directory. Let us know if you have any other questions.
"If everybody is thinking alike, then somebody is not thinking." - Gen. George S. Patton Jr.

Colin

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,123
  • Gender: Male
    • Kindred-999 on GitHub
Re: Upgrading issues from 2.0 to 2.1
« Reply #10 on: December 26, 2016, 11:01:39 PM »
Colin, that is wrong..,  if you are making a copy, then there is another critical step that is missing..

As I said above, in order for the upgrade to complete, you ***MUST*** have a WORKING installation of smf...    so, making a copy of your forum can only be done if you make a copy AND THEN configure that copy to run in the new location BEFORE doing the upgrade

Blade, I apologize, those instructions are incorrect...   and you are the first person to report a trip up on them (which implies that most folks have ignored them to start with)

Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Blade~

  • Semi-Newbie
  • *
  • Posts: 37
  • Gender: Male
    • FilmWorkshop.net
Re: Upgrading issues from 2.0 to 2.1
« Reply #11 on: December 26, 2016, 11:26:20 PM »
Understood, thanks guys for the clarification! It's getting a little too late where I am so I'll get at it again tomorrow.

Again, thanks for sticking with us on this!
Blade~