Advertisement:

Author Topic: Passage en HTTPS de mon forum  (Read 13165 times)

Online alexetgus

  • Sr. Member
  • ****
  • Posts: 706
  • Gender: Male
    • alexetgus on Facebook
    • alexetgus on GitHub
    • @alexetgus on Twitter
    • Chez oim, forum libre !
Re: Passage en HTTPS de mon forum
« Reply #80 on: December 18, 2017, 04:45:27 AM »
Merci pour votre aide :)

Bonsoir,

Sur le thème Reseller c'était encore une vieille version de bootstrap qui avait des redirections internes en http.

Donc pour ceux qui ont ce thème il faut impérativement le mettre à jour pour le passage en https.

:)

Je comprend pourquoi ca ne fonctionner pas :/

mais en fait je m habitue à ce nouveaux template et il est beaucoup plus fluide en version mobile

Bon par contre je ne sais pas si chez vous cela fonctionne mais sous chrome je n'ai toujours pas mon cadenas... :(

Vous avez une autre idée ???
Salut,

Tu as encore un élément chargé en HTTP. Ta barre de recherche Google est en HTTP.


Offline Hotcmel

  • Sr. Member
  • ****
  • Posts: 789
    • Planete Kawasaki
Re: Passage en HTTPS de mon forum
« Reply #81 on: December 18, 2017, 05:28:05 AM »
Excellent ! merci beaucoup  !  8)

Tu as trouvé ca comment ?

Online alexetgus

  • Sr. Member
  • ****
  • Posts: 706
  • Gender: Male
    • alexetgus on Facebook
    • alexetgus on GitHub
    • @alexetgus on Twitter
    • Chez oim, forum libre !
Re: Passage en HTTPS de mon forum
« Reply #82 on: December 18, 2017, 08:59:33 AM »
Avec les outils développeur, tout simplement.
Clic droit sur la page ou un élément suivi de "Examiner/Inspecter l'élément". ;)

Il est joli ce cadenas SSL ! :)

Offline Hotcmel

  • Sr. Member
  • ****
  • Posts: 789
    • Planete Kawasaki
Re: Passage en HTTPS de mon forum
« Reply #83 on: December 19, 2017, 03:10:00 AM »
Ah ben je l avais fait mais je n ai rien trouvé :/ en tout cas ca marche maintenant :)

Online alexetgus

  • Sr. Member
  • ****
  • Posts: 706
  • Gender: Male
    • alexetgus on Facebook
    • alexetgus on GitHub
    • @alexetgus on Twitter
    • Chez oim, forum libre !
Re: Passage en HTTPS de mon forum
« Reply #84 on: December 19, 2017, 02:40:30 PM »
Il faut cliquer sur la croix rouge à droite et les problèmes de la page s'affichent. ;)


Offline Hotcmel

  • Sr. Member
  • ****
  • Posts: 789
    • Planete Kawasaki
Re: Passage en HTTPS de mon forum
« Reply #85 on: December 20, 2017, 03:10:35 AM »
ok merci je testerais ;)

Offline Hotcmel

  • Sr. Member
  • ****
  • Posts: 789
    • Planete Kawasaki
Re: Passage en HTTPS de mon forum
« Reply #86 on: February 07, 2020, 09:48:44 AM »
Oui je reviens ici suite à un changement de theme , quel est le rapport  :-\

Ben le rapport c est que sur certaines pages je ne suis plus en https :(
 en regardant le code effectivement je tombe sur des avatar qui pointe sur des vieille URL

que puis je faire ?


Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,463
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Passage en HTTPS de mon forum
« Reply #87 on: February 07, 2020, 01:12:04 PM »
Bonjour,

Il faut activer le proxy dans l'admin de Smf ou alors supprimer toutes les images qui ne sont pas en https :)

Pour le proxy c'est dans Admin -> Paramètres du Serveur -> Activer le Proxy pour les Images -> Cocher et sauver.

:)
Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline Hotcmel

  • Sr. Member
  • ****
  • Posts: 789
    • Planete Kawasaki
Re: Passage en HTTPS de mon forum
« Reply #88 on: February 08, 2020, 03:57:57 AM »
Salut,

Nickel ca fonctionne merci beaucoup :)

Offline Pяηѕѕ LF

  • Sophist Member
  • *****
  • Posts: 1,042
  • Pяεηsεs
Re: Passage en HTTPS de mon forum
« Reply #89 on: February 21, 2020, 05:33:40 PM »
salut,

et moi et moi et moi ^^..

donc après avoir tout lu j'ai essayé de le faire mais bon j'ai un message comme ceci:

Internal Server Error

The server encountered an internal error or misconfiguration and was unable to complete your request.

Please contact the server administrator at postmaster@www.site.com to inform them of the time this error occurred, and the actions you performed just before this error.

More information about this error may be available in the server error log.

donc je suis chez ovh dans l'espace configuration je pense avoir cliqué et depuis j'ai :

Certificat SSL
    Oui - LETSENCRYPT - DV

donc j'imagine que c'est activé chez ovh.. du coup j'ai été dans le .htaccess et tout la fin j'ai rajouté le code donné:


  # HTTP to HTTPS
  RewriteCond %{HTTPS} !on
  RewriteRule ^(.*)$ https://%{SERVER_NAME}/$1        [R=301,L]

puis j'ai installé le RepairSettings et la ou y'avais http j'ai changé en https 5 à 6 fois je pense puis enregistré..

mais ça aurait été trop beau que ça marche comme ça du premier coup :pP donc j'ai eu ce message d'erreur et demande votre aide.
1.1.21 Default

Offline maximus23

  • Local Moderator
  • SMF Super Hero
  • *
  • Posts: 11,463
  • Gender: Male
  • Smf 2.1 RC2
    • Smf Français Forum non Officiel
Re: Passage en HTTPS de mon forum
« Reply #90 on: February 22, 2020, 07:07:29 AM »
Bonjour,

Vérifie que ton espace Php ne soit pas passé en Php 7.X car la version 1.x de Smf ne le supporte pas je pense.

Essaye sans htaccess il ne sert pas à ce niveau.

Dans la version 1 il n'y a pas de proxy même si cela fonctionne tu vas avoir des messages de Mix content car tes images seront en http en non https.

Je crois que tu pars vers l'aventure là. Pour cela tu dois faire un upgrade vers au moins la version 2 de Smf.

Je dois dire que cela fait très longtemps que je n'ai plus suivi le support pour cette version de Smf donc je peux me tromper.

:)

Pas de support par PM ou Courrier...Veuillez utiliser le forum pour vous avoir une réponse rapide à votre demande d'aide. Merci.
Amitiés et à Bientôt...
No support by PM or Mail...You will get better and faster responses in the support forums. Thank you.
Have a nice day...

Offline Pяηѕѕ LF

  • Sophist Member
  • *****
  • Posts: 1,042
  • Pяεηsεs
Re: Passage en HTTPS de mon forum
« Reply #91 on: February 22, 2020, 05:11:42 PM »
bonsoir,

pour la Configuration   >   Version PHP globale  4.4  :) donc à mon avois je suis loin du php 7 dont tu parles ^^.

d'ailleur j'ai un message qui me dit attention la version php que vous utilisez n'est plus maintenue et que en cliquant pour mettre à niveau la version php le fonctionnement du site pourrait être impacté etc..

si toi tu me dis que je pars vers l'aventure alors je laisse tombé comme tu dis c'est peut-être pas possible avec la version 1.

peut être que si ya des amis qui utilisent la version 1 et qui on pu l'installer peut être qu'il nous feront par de leur aventure.

merci bonne soirée ++
 
1.1.21 Default