Advertisement:

Author Topic: Upgrade from 2.0 RC4 to 2.0.13  (Read 13787 times)

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #20 on: April 21, 2017, 02:07:58 PM »
Is the RC4 install still running? Link?
If you mean live forum, http://forum.infocentr.ru/ [nofollow] , on 78.108.68.135 is RC4 install after "succesfull" upgrade

Offline Sir Osis of Liver

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 5,861
  • til it's chiseled in stone
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #21 on: April 21, 2017, 02:10:21 PM »
What did you upgrade from (before RC4)?

Going offline now, will be back on tonight (EDT).

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #22 on: April 21, 2017, 02:19:51 PM »
What did you upgrade from (before RC4)?

Going offline now, will be back on tonight (EDT).
Don't now(it was not my forum earlier), in database i see    smfVersion 2.0 RC3 in smf_settings

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 46,156
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #23 on: April 21, 2017, 02:24:12 PM »
can you try to upgrade to SMF 2.0 RC4 and see if that is successful?
https://download.simplemachines.org/index.php?thanks;filename=smf_2-0-rc4_update.zip

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #24 on: April 21, 2017, 02:43:40 PM »
can you try to upgrade to SMF 2.0 RC4 and see if that is successful?
https://download.simplemachines.org/index.php?thanks;filename=smf_2-0-rc4_update.zip
I can not doing it on live forum, test install is clean RC4 with DB dump from live forum/

Offline Sir Osis of Liver

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 5,861
  • til it's chiseled in stone
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #25 on: April 22, 2017, 01:45:25 AM »
Ok, mope, been at this a while and I think you have two problems.  The RC4 upgrade fails on a RC3 test install, it changes the copyright version, but not smf_settings.  Your production forum may still be RC3.  However, you should be able to upgrade to 2.0.13.  I've done this several times, RC3 -> RC4 fails, RC3 -> 2.0.13 works.  RC3, RC4, and 2.0.13 all have the karma_good field, so upgrader doesn't replace it.  Best guess is you have a bad database dump.  You need to do it again, either with backup utility in your host control panel (if it has one), or phpmyadmin.  Dump it 2-3 times, see if file size is same.  You have a large database, phpmyadmin will sometimes timeout without error, and you end up with an incomplete dump.

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #26 on: April 22, 2017, 11:50:20 AM »
Ok, mope, been at this a while and I think you have two problems.  The RC4 upgrade fails on a RC3 test install, it changes the copyright version, but not smf_settings.  Your production forum may still be RC3.  However, you should be able to upgrade to 2.0.13.  I've done this several times, RC3 -> RC4 fails, RC3 -> 2.0.13 works.  RC3, RC4, and 2.0.13 all have the karma_good field, so upgrader doesn't replace it.  Best guess is you have a bad database dump.  You need to do it again, either with backup utility in your host control panel (if it has one), or phpmyadmin.  Dump it 2-3 times, see if file size is same.  You have a large database, phpmyadmin will sometimes timeout without error, and you end up with an incomplete dump.
Thanks! I'll trying it

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #27 on: April 25, 2017, 12:36:58 AM »
Ok, mope, been at this a while and I think you have two problems.  The RC4 upgrade fails on a RC3 test install, it changes the copyright version, but not smf_settings.  Your production forum may still be RC3.  However, you should be able to upgrade to 2.0.13.  I've done this several times, RC3 -> RC4 fails, RC3 -> 2.0.13 works.  RC3, RC4, and 2.0.13 all have the karma_good field, so upgrader doesn't replace it.  Best guess is you have a bad database dump.  You need to do it again, either with backup utility in your host control panel (if it has one), or phpmyadmin.  Dump it 2-3 times, see if file size is same.  You have a large database, phpmyadmin will sometimes timeout without error, and you end up with an incomplete dump.
Ok, now i'm really don't understand, which version of smf is used. Upgrading not changing anything. There is no field karma_good on table smf_members on live forum database  :-\
smf_members:
Code: [Select]
id_member mediumint(8) unsigned
member_name varchar(80) []
date_registered int(10) unsigned [0]
posts mediumint(8) unsigned [0]
id_group smallint(5) unsigned [0]
lngfile varchar(255) []
last_login int(10) unsigned [0]
real_name varchar(255) []
instant_messages smallint(5) [0]
unread_messages smallint(5) [0]
buddy_list text
pm_ignore_list varchar(255) []
message_labels text
passwd varchar(64) []
email_address varchar(255) []
personal_text varchar(255) []
gender tinyint(4) unsigned [0]
birthdate date [0001-01-01]
website_title varchar(255) []
website_url varchar(255) []
location varchar(255) []
icq varchar(255) []
aim varchar(255) []
yim varchar(32) []
msn varchar(255) []
hide_email tinyint(4) [0]
show_online tinyint(4) [1]
time_format varchar(80) []
signature text
time_offset float [0]
avatar varchar(255) []
pm_email_notify tinyint(4) [0]
karma int(10) NULL [100]
voices int(10) NULL [10]
usertitle varchar(255) []
notify_announcements tinyint(4) [1]
notify_regularity tinyint(4) unsigned [1]
notify_send_body tinyint(4) [0]
notify_types tinyint(4) [2]
member_ip varchar(255) []
member_ip2 varchar(255) []
secret_question varchar(255) []
secret_answer varchar(64) []
id_theme tinyint(4) unsigned [0]
is_activated tinyint(3) unsigned [1]
validation_code varchar(10) []
id_msg_last_visit int(10) unsigned [0]
additional_groups varchar(255) []
smiley_set varchar(48) []
id_post_group smallint(5) unsigned [0]
total_time_logged_in int(10) unsigned [0]
password_salt varchar(255) []
ignore_boards text
notifyKarma int(11) [0]
timezone varchar(50)
timezone_offset mediumint(6)
timezone_update int(10) unsigned
mod_prefs varchar(20) []
warning tinyint(4) [0]
passwd_flood varchar(12) []
new_pm tinyint(3) [0]
pm_prefs mediumint(8) [0]
openid_uri text
pm_receive_from tinyint(3) unsigned [1]
oauth_token varchar(255) NULL
oauth_uid varchar(255) NULL

Offline Sir Osis of Liver

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 5,861
  • til it's chiseled in stone
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #28 on: April 25, 2017, 05:20:15 PM »
There is no karma field in 2.0, should be karma_good and karma_bad

Do you know which mod added the voices field?

Do you have Karma enabled in Admin -> Core Features on your production forum?


Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #29 on: April 26, 2017, 03:23:31 AM »
There is no karma field in 2.0, should be karma_good and karma_bad

Do you know which mod added the voices field?

Do you have Karma enabled in Admin -> Core Features on your production forum?
But i have this field, don't know which mod added field voices. Karma is disabled.

Offline Sir Osis of Liver

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 5,861
  • til it's chiseled in stone
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #30 on: April 26, 2017, 12:49:17 PM »
Some mods will add tables, or add fields to core tables, but I'm not aware of any mod that changes or removes existing fields in core tables.  This appears to be what has happened to your database.  Upgrader does not add the missing fields because they should already be there.  You can try manually adding the missing fields to smf
_members
in the upgraded database, using parameters from a clean install.

You must have a mod installed that changed the database but circumvents the problem, or your production forum would throw the same error.  Can you post a list of installed mods?


Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #31 on: April 26, 2017, 10:59:37 PM »
Some mods will add tables, or add fields to core tables, but I'm not aware of any mod that changes or removes existing fields in core tables.  This appears to be what has happened to your database.  Upgrader does not add the missing fields because they should already be there.  You can try manually adding the missing fields to smf
_members
in the upgraded database, using parameters from a clean install.

You must have a mod installed that changed the database but circumvents the problem, or your production forum would throw the same error.  Can you post a list of installed mods?
Code: [Select]
1. Auto Merge Double Post 1.3 
2. Stop Forum Spam 0.6 
3. Global Headers Footers 2.0
4. Fancy Features for Russian 0.9.9.5
5. Spoiler BBCode 1.1.3
6. YouTube BBCode 2.6 
7. Spoiler Tag 0.7.2 
8. First Post on every Page 1.3 
9. Search Focus Dropdown 1.6.1
10. dQuoteSelection 3.0 b1 
11. Who Voted What? 2.11 
12. Hide Ignored Boards 1.1 
Don't know which mod may change database. Now i just added fields karma_good and karma_bad to smf_members and forum is working, as i see(on 78.108.68.135)

Offline Sir Osis of Liver

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 5,861
  • til it's chiseled in stone
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #32 on: April 26, 2017, 11:20:45 PM »
Where did you find the Fancy Features mod?  It was submitted to customization and rejected twice, in Aug 2010 and Aug 2011, apparently never approved, and is not available on mod site.  If adding the two karma fields fixed the problem, and everything else is working, you'll have to go with it and hope there isn't any other damage to your database.  You'll need to install current versions of the mods you wish to continue using.

Offline obladi-oblada

  • Semi-Newbie
  • *
  • Posts: 18
Re: Upgrade from 2.0 RC4 to 2.0.13
« Reply #33 on: April 27, 2017, 12:10:38 AM »
Where did you find the Fancy Features mod?  It was submitted to customization and rejected twice, in Aug 2010 and Aug 2011, apparently never approved, and is not available on mod site.  If adding the two karma fields fixed the problem, and everything else is working, you'll have to go with it and hope there isn't any other damage to your database.  You'll need to install current versions of the mods you wish to continue using.
It was not my forum in the past(just one month ago). Thanks for your help!