Advertisement:

Author Topic: Odd problem with subscription system  (Read 7543 times)

Online Bob Perry of Web Presence Consulting

  • Sr. Member
  • ****
  • Posts: 935
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Odd problem with subscription system
« on: April 20, 2017, 11:20:08 AM »
For some reason I haven't fathomed yet the system keeps sending me multiple email notices about my customers renewing their subscriptions, sometimes 5 or 6 a day, I checked with PayPal and one of the customers and they don't get multiple notices & PayPal only executes the transaction once... anyone else ever run into that?

Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,708
  • Too long in the wasteland
Re: Odd problem with subscription system
« Reply #1 on: April 20, 2017, 05:55:53 PM »
That's a new one.  Sounds like you may have a problem with the scheduled task that updates subscriptions once per day by default.  Anything in your error log?

Online Bob Perry of Web Presence Consulting

  • Sr. Member
  • ****
  • Posts: 935
  • Gender: Male
  • (T)ogether (E)veryone (A)chieves (M)ore
    • Bobert921 on Facebook
    • https://www.linkedin.com/in/bperry921/ on LinkedIn
    • @bperry921 on Twitter
    • Web Presence Consulting
Re: Odd problem with subscription system
« Reply #2 on: April 20, 2017, 06:23:43 PM »
That's a new one.  Sounds like you may have a problem with the scheduled task that updates subscriptions once per day by default.  Anything in your error log?


No error log entries, have not checked the host log though... back about two weeks ago PayPal was sending me messages that it wasn't communicating with the subscriptions.php correctly, and before I actually fixed it via PayPal, I did some tinkering with changing the time of the scheduled task... I also changed the active/finished status and expiration dates of the customer profiles too... I also found a problem with the one module I have that affects subscriptions directly, its an old one that allows you have one time lifetime subscription payments, uninstalled manually and reinstalled, fixed that...haven't put much effort into tracking down the email problem after fixing the actual transaction process part of it, the delete key works just fine lol...
Best Regards,
Bob Perry



"The world is moving so fast these days that the man who says it can't be done is generally interrupted by someone doing it." Elbert Hubbard