• Welcome to Simple Machines Community Forum. Please login or sign up.
January 26, 2022, 04:43:30 PM

News:

Bored?  Looking to kill some time?  Want to chat with other SMF users?  Join us in IRC chat or Discord


SMF 2.0.14 Released

Started by Colin, May 14, 2017, 05:16:14 PM

Previous topic - Next topic

chyg

Quote from: vbgamer45 on May 14, 2017, 06:17:38 PM
Thanks for this release time to update my final servers to php 7!

Hello! You have already purchased the SMFHacks suite, the display version is not compatible! Is there a technical support or a paid installation? SMF1.0.14
SMF中文QQ群:347253194

vbgamer45

Do you need help with upgrading SMF? What  SMF version are you on?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Illori

please do not use this topic for support. please open a topic in the support boards.

Kindred

Quote from: chyg on June 14, 2017, 11:03:29 AM
Hello! Has purchased the kit, showing the version is not compatible! Is there a technical support or a paid installation? (SMF1.0.14)

Quote from: vbgamer45 on May 14, 2017, 06:17:38 PM
Thanks for this release time to update my final servers to php 7!

I am sorry, but that sentence did not make much sense. What did you purchase? And also this thread is not for support requests
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

"Loki is not evil, although he is certainly not a force for good. Loki is... complicated."

SpyDie

The fact it requires a specific version is fine, and makes sense, and you can make it in big red letters for people to not miss and people will still miss it.

Something to consider next time: bumping the minor version would also have made sense here or, if possible (I don't know what new code has caused this requirement), have two seperate releases. One for the patch fixes, and then a minor version upgrade for the new PHP version (which is still old so you've got the ability to be backwards compatible to a degree).

Personally, I saw this as a patch upgrade and assumed it would be upgrade without fault. Every other SMF patch upgrade has, until this one.
Beta. Software undergoes beta testing shortly before it's released. Beta is Latin for 'still doesn't work.'

Arantor

No, bumping the minor version would not have made sense given that there is already a 2.1 with literal years of more development.

The new code that caused this requirement was code backported from 2.1 that fixes some issues with PHP 7, except no-one checked it required PHP 5.4 before releasing it (and it was too late to redo it in a more compatible way, though I gather SMF 2.0.15 will fix that)
No good deed goes unpunished
All helpful urges should be circumvented

Steve

I guess I'll keep asking this until someone answers. If I'm on 2.0.13 and PHP 5.3 with no way to go to 5.4, how do I get to 2.0.15 if .14 isn't going to work on my forum?

And yes Kindred, I know, I know, not for support. Sorry.
Please do not PM me for support.

vbgamer45

I guess you would install 2.0.15 instead of 2.0.14 if that is the goal?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Eudemon

 ;) glad it is still being actively updated

naan

I make my update from 2.0.13 to 2.014 today.

Then i have problems with my database connection.

Solution:
The database must be also a higher version.
Server-Version: 5.5.47-0+deb7u1 - (Debian) ----- don't work

Now i have
5.7.12 - MySQL Community Server (GPL) ----work now


Perhaps you can write this to the requirement:
php must be higher 5.4
mysql must be higher than ???

mfg
andi nagl
naan.de // psaForum and other things.

Arantor

I don't think it's entirely about the server version; there is no reason why 5.5 wouldn't work (I still have one deployment on MySQL 5.5 and it seems to work out OK), but I asked for more details in your support topic.
No good deed goes unpunished
All helpful urges should be circumvented

Apllicmz




Torngate

Works great, thanks for the update guys!!
Site Administrator- Shadow Fleet Star Trek RPG

Arantor

So when are we getting the bugfix release?
No good deed goes unpunished
All helpful urges should be circumvented

d3vcho

Still some work left to do. Developers are busy this days.
"Greeting Death as an old friend, they departed this life as equals"

Arantor

Quote from: d3vcho(); on July 15, 2017, 01:25:13 PM
Still some work left to do. Developers are busy this days.

Not being funny, but it's been 2 months since this release went out with a number of bugs... any news?
No good deed goes unpunished
All helpful urges should be circumvented

d3vcho

No news so far, Arantor. We're still waiting for the developers. Hopefully, we'll get news soon.
"Greeting Death as an old friend, they departed this life as equals"

ForumMix

Hi, have just installed the latest version and the installation went well. But when everything is clear to get up this environment. And with an IP-address 127.0.0.1

What do I do now?

See picture

http://imgur.com/V4AGg8A

Deaks

you need to create a new topic as this is not for support

GNR


Advertisement: