Advertisement:

Author Topic: 2.0.14 error  (Read 3384 times)

Offline Rogerd

  • Semi-Newbie
  • *
  • Posts: 40
2.0.14 error
« on: May 15, 2017, 03:43:23 AM »
After patching from 2.0.13 to 2.0.14 I get this error  "Fatal error: Function name must be a string in /home/************/public_html/Sources/Load.php on line 142" my forum is now unusable, any help please.

Line 142:    $request = $smcFunc['db_query']('', '

PS:  I downloaded the patch from this site and uploaded using the package manager.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,639
    • StoryBB/StoryBB on GitHub
Re: 2.0.14 error
« Reply #1 on: May 15, 2017, 03:51:23 AM »
Version of PHP?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Rogerd

  • Semi-Newbie
  • *
  • Posts: 40
Re: 2.0.14 error
« Reply #2 on: May 15, 2017, 03:55:57 AM »
Looking in phpmyadmin it says 5.6.30, sorry I'm hopeless at this stuff.

Offline gorbi

  • Jr. Member
  • **
  • Posts: 124
    • https://www.facebook.com/s.gorbachevsky on Facebook
    • @gorbachevsky on Twitter
Re: 2.0.14 error
« Reply #3 on: May 15, 2017, 04:07:30 AM »
errors

Offline Yariksat

  • Semi-Newbie
  • *
  • Posts: 38
Re: 2.0.14 error
« Reply #4 on: May 15, 2017, 04:57:16 AM »
PHP Warning:  mysqli_select_db() expects parameter 1 to be mysqli, resource given in /Sources/Subs-Db-mysql.php on line 826
Code: [Select]
public function select($database, $connection = null)
{
global $db_connection;

==> return mysqli_select_db($connection === null ? $db_connection : $connection, $database);
}

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.0.14 error
« Reply #5 on: May 15, 2017, 08:29:31 AM »
Looking in phpmyadmin it says 5.6.30, sorry I'm hopeless at this stuff.
Please attach your Sources/Load.php file.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Rogerd

  • Semi-Newbie
  • *
  • Posts: 40
Re: 2.0.14 error
« Reply #6 on: May 15, 2017, 09:02:30 AM »
Here's my sources/load.php file, thank's

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.0.14 error
« Reply #7 on: May 15, 2017, 09:04:25 AM »
Hmm file looks ok did you have any errors when installing the patch?

Do you know your php version along with if you mysqli installed or not?
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Rogerd

  • Semi-Newbie
  • *
  • Posts: 40
Re: 2.0.14 error
« Reply #8 on: May 15, 2017, 10:50:30 AM »
I've put this in the hands of the hosts as i've no idea what I'm doing, they have asked the following questions, could anyone please confirm using any of the following is ok: PHP 5.4 up to 7.0 or does the 1.0.14 definately need PHP version 7.0
Also is apache 2.4 compatible with my SMF website.

Below is how the host put the questions

"get it confirmed if your websites will be compatible with PHP version 5.4 and above
It appears your application required PHP 7.0 version. Can you please confirm the same ?
Please get it confirmed with your Developer if Apache version 2.4 does not create any compatibility issues with the websites."

   Many thank's in advance.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: 2.0.14 error
« Reply #9 on: May 15, 2017, 11:00:45 AM »
we do not require php 7. php 5.4.* should be fine.

Offline Rogerd

  • Semi-Newbie
  • *
  • Posts: 40
Re: 2.0.14 error
« Reply #10 on: May 15, 2017, 11:03:08 AM »
we do not require php 7. php 5.4.* should be fine.

Thank's Illori, and would apache 2.4 be ok, and I take it if I upgraded to PHP 7.0 it wouldn't be a problem, thank's

What I'm trying to say is PHP 7.0 and apache 2.4 would be ok to use without problems.
« Last Edit: May 15, 2017, 11:13:39 AM by Rogerd »

Offline gorbi

  • Jr. Member
  • **
  • Posts: 124
    • https://www.facebook.com/s.gorbachevsky on Facebook
    • @gorbachevsky on Twitter
Re: 2.0.14 error
« Reply #11 on: May 15, 2017, 11:04:47 AM »
we do not require php 7. php 5.4.* should be fine.
5.4 or 5.3?

Offline sawz

  • Charter Member
  • SMF Hero
  • *
  • Posts: 3,365
  • Gender: Male
  • getting older
Re: 2.0.14 error
« Reply #12 on: May 15, 2017, 11:05:42 AM »
we do not require php 7. php 5.4.* should be fine.

how about 5.3? i experienced the same problem on an upgrade.
keep smiling, they'll always wonder what your up too.....

Offline nazerine

  • Newbie
  • *
  • Posts: 1
Re: 2.0.14 error
« Reply #13 on: May 15, 2017, 11:09:19 AM »
we do not require php 7. php 5.4.* should be fine.

From my experience this morning, 5.3 is not compatible. Moving to 5.6 fixed error "./Sources/Load.php on line 142"

Now I encounter this error: "The database value you're trying to insert does not exist: theme_guests"

Rolled back to previous version of "./Sources/Load.php" and my forum is now loading again

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.0.14 error
« Reply #14 on: May 15, 2017, 11:11:11 AM »
saws I would really recommend upgrading php version it is pretty easy for a hosting provider to do. 5.3 came out of service on 14 Aug 2014
Try to go up to 5.6 your forum will get speed improvements too the higher you go up in your php version
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,284
Re: 2.0.14 error
« Reply #15 on: May 15, 2017, 11:17:07 AM »
the readme says SMF 2.0.14 requires php 5.3 or higher, it does not state which exactly version of php 5.3.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 71,639
    • StoryBB/StoryBB on GitHub
Re: 2.0.14 error
« Reply #16 on: May 15, 2017, 11:17:37 AM »
the readme says SMF 2.0.14 requires php 5.3 or higher, it does not state which exactly version of php 5.3.

5.3.0 through 5.3.29 are bug fixes, it shouldn't matter.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Saftek

  • Semi-Newbie
  • *
  • Posts: 21
Re: 2.0.14 error
« Reply #17 on: May 15, 2017, 11:54:44 AM »
Yeah, I upgraded to php 5.4 (from 5.3) and it appears to have resolved my issue.

Online vbgamer45

  • Customizer
  • SMF Super Hero
  • *
  • Posts: 21,559
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: 2.0.14 error
« Reply #18 on: May 15, 2017, 12:10:24 PM »
Good to know.  Now time to wonder what change caused that issue to work.

If one reads this upgrade up from PHP 5.3
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline Saftek

  • Semi-Newbie
  • *
  • Posts: 21
Re: 2.0.14 error
« Reply #19 on: May 15, 2017, 12:28:26 PM »
Good to know.  Now time to wonder what change caused that issue to work.

If one reads this upgrade up from PHP 5.3

don't know but that was the only change I made.