Advertisement:

Author Topic: White screen after uprgrade to 2.0.14 patch  (Read 428 times)

Offline ceylankral

  • Semi-Newbie
  • *
  • Posts: 10
White screen after uprgrade to 2.0.14 patch
« on: May 18, 2017, 03:22:42 AM »
dears, my website gives me white screen after upgrade to 2.0.14 , when finished the upgrading, directly gave me a white screen. and i cant do anything. i tried repair_settings.php but also thats not working. same white screen for repair_settings.php .

my last try is deleting all website and reinstall clearly all smf files with new db. but when i click to next step(2) , gives me again white screen. this is very interesting. clear and new smf files, new db, but still gives white screen after when i click to step-2.

i checked hosting error log, there is a lot of error logs after upgrading smf. like this:

"Warning(Yellow color) - mod_fcgid: stderr: PHP Fatal error: Function name must be a string in /var/www/vhosts/mywebsite.com/httpdocs/forum/Sources/Load.php on line 133"
"Error(Red color) - GET /forum/index.php?topic=12443 HTTP/1.0"

red colored error is changing alway. but why i still getting load.php error after i change to clear smf and clear db. i cant understand.

can you help me?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 67,539
    • Arantor on GitHub
Re: White screen after uprgrade to 2.0.14 patch
« Reply #1 on: May 18, 2017, 03:23:51 AM »
Get your host to upgrade to PHP 5.4 or above.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline ceylankral

  • Semi-Newbie
  • *
  • Posts: 10
Re: White screen after uprgrade to 2.0.14 patch
« Reply #2 on: May 18, 2017, 03:30:50 AM »
thank you. i will do it. after i do, i will write the result :)

Offline Tiribulus

  • Sophist Member
  • *****
  • Posts: 1,010
  • Gender: Male
    • Tiribulus on Facebook
    • No Other God
Re: White screen after uprgrade to 2.0.14 patch
« Reply #3 on: May 18, 2017, 11:41:05 AM »
Well. That explains that.

It might be a good idea to update the system requirements page  O:)

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 67,539
    • Arantor on GitHub
Re: White screen after uprgrade to 2.0.14 patch
« Reply #4 on: May 18, 2017, 01:20:18 PM »
I've already asked that this be done. It's taking a discussion though I don't really understand why it needs much discussion.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 47,499
Re: White screen after uprgrade to 2.0.14 patch
« Reply #5 on: May 18, 2017, 01:54:51 PM »
as we have not officially bumped the version, so the team has to decide on that and then we can update the requirements. we are aware it needs to be done.