Advertisement:

Author Topic: Spell check Not Working  (Read 414 times)

Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,737
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Spell check Not Working
« on: May 29, 2017, 05:40:22 AM »
OK, not sure if this has anything to do with moving all my sites to a new server. but the same thing is happening to me here on this site. 

Been told the Spell Check has stopped working on one of my sites, so I checked and it isn't working.  Checked all my other sites and it's not wrking on those either.  Tried different browsers same thing.  Click the spell check button and you just get a empty white box as seen in the screen shot below, taken while I was typing this post.

Checked the settings and it says my server has,

Enable spell checking. You MUST have the pspell library installed on your server and your PHP configuration set up to use the pspell library. Your server DOES appear to have this set up.

Tested in SMF 2.0.13 and SMF 2.0.14  And with Firefox Chrome and IE11 and Edge, all up to date.

Any ideas? Just me or is there a problem.


Offline Illori

  • Support Specialist
  • SMF Legend
  • *
  • Posts: 52,734
Re: Spell check Not Working
« Reply #1 on: May 29, 2017, 06:15:31 AM »
that means the dictionary files are not installed.

Offline lurkalot

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 1,737
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Spell check Not Working
« Reply #2 on: May 29, 2017, 06:32:57 AM »
that means the dictionary files are not installed.

Thanks.  I just read that somewhere,  ;)

So this is a server thing?  they're not installed on the server this site uses, or mine.  I guess I'll have to talk the user into using the built in browser spell check, they might have to use an add-on if using IE11.  Then I'll turn the SMF spell check off then. 

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 73,189
Re: Spell check Not Working
« Reply #3 on: May 29, 2017, 07:03:39 AM »
They're not installed on your server.

I'd encourage your user to use a current browser, e.g. Edge, that has spell checker because everyone has one now.
No good deed goes unpunished
All helpful urges should be circumvented