Advertisement:

Author Topic: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter  (Read 1420 times)

Offline Avandy

  • Newbie
  • *
  • Posts: 2
Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« on: May 31, 2017, 09:47:39 AM »
Liebe Experten,

ich bin gerade mit meinem "Latein" am Ende. Habe gestern das Upgrade über den Paketmanager im Admin-Bereich vorgenommen. Seitdem ist das Forum futsch und die Seite meldet nur:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

Zunächst habe ich das Passwort der Datenbank geändert und in der Settings eingetragen. Das war im englischsprachigen Support-Forum empfohlen worden. Leider ohne Erfolg.

Nun habe ich heute - nach der Empfehlung im englischsprachigen Supportforum -  das große Update-Paket hochgeladen und lande in der nächsten Sackgasse:

Wenn ich upgrade.php aufrufe, kommt nun folgende Meldung:

Fatal error: Uncaught Error: Call to undefined function set_magic_quotes_runtime() in /homepages/35/d69149255/htdocs/schrottimmoforum/upgrade.php:812 Stack trace: #0 /homepages/35/d69149255/htdocs/schrottimmoforum/upgrade.php(122): loadEssentialData() #1 {main} thrown in /homepages/35/d69149255/htdocs/schrottimmoforum/upgrade.php on line 812

Ich nutze PHP 7.1 - es kann also nicht an einer veralteten PHP-Version liegen.

Wer weiß einen Rat?

Danke,

Markus




Offline Softie

  • Semi-Newbie
  • *
  • Posts: 52
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #1 on: May 31, 2017, 10:41:14 AM »
Quote
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.

^^Die gleiche Meldung kam bei mir auch nach dem hochladen und installieren des Upgrades.

Erst als ich die PHP Version von 5.4.16 auf 5.6.30 änderte - funktionierte es anstandslos. Hab sowas vorher auch noch nie erlebt. Ich hab bei SMF 2.0.14 auch nirgends eine entsprechende Auflistung mit den unterstützten bzw. kompatiblen PHP Versionen gesehen. Man lässt die Nutzer einfach im Regen stehen.

Offline albertlast

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 171
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #2 on: May 31, 2017, 03:11:07 PM »
Der fehler im upgrade liegt an deiner php version.
füg in der upgrade.php
vor der line 812 dies ein:
if (function_exists('set_magic_quotes_runtime'))


Offline Avandy

  • Newbie
  • *
  • Posts: 2
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #3 on: June 01, 2017, 03:21:43 AM »
Danke für die Hinweise. Ich nutze PHP 7.1. Daran sollte es nicht liegen.

Bin jetzt einen Schritt weiter nachdem ich den Code eingefügt habe, danke schon mal. Jetzt habe ich zig Fehlermeldungen in der Upgrade-Datei, muss mal nachsehen, ob ich daran etwas ändern kann.

Offline albertlast

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 171
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #4 on: June 01, 2017, 03:32:15 AM »
den von dir beschrieben fehler tritt bei php 7+ halt auf,
daher liegt es an der version.

der fehler wird wohl in der nächsten version behoben.

Offline naan

  • Jr. Member
  • **
  • Posts: 146
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #5 on: June 27, 2017, 08:42:02 AM »
liegt nicht an php.

Der Fehler liegt in der Version der Datenbank.

Ich hatte den gleichen Fehler.

Code: [Select]
Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again lat

2.0.14 konnte sich mit meiner Datenbank nicht verbinden. 2.0.13 konnte es noch.
Version der alten Datenbank war: 5.5.47-0+deb7u1 - (Debian)
die neue datenbank hatte dann: 5.7.12 - MySQL Community Server (GPL)

Lösung bei mir:
Ich habe die alte Datenbank mit phpmyadmin exportiert.
Eine neue Datenbank angelegt, die dann automatisch eine aktuellere Software-Version hat.
Dann den Export in die neue Datenbank importiert.
Dann die settings.php auf die neue Datenbank eingestellt.
Dann ging es.

naan.de // psaForum and other things.

Offline naan

  • Jr. Member
  • **
  • Posts: 146
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #6 on: June 27, 2017, 09:01:27 AM »
Geht doch mal in phpmysql und schau nach, welche server-version da steht.

Ich vermute fast, dass es nicht an der version 5.5 liegt, sondern an debian.
Denn in der Version 5.5 haben ja viele kein Problem.

Wann wurde denn deine datenbank angelegt?
Ist das schon Jahre her? Wie bei mir.
naan.de // psaForum and other things.

Offline albertlast

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 171
Re: Upgrade auf Version 2.014 - Probleme - weiß nicht weiter
« Reply #7 on: June 27, 2017, 01:23:25 PM »
Ich hab mir die Code stelle angeschaut und
kam zu dem von mir genanten Ergebnis.

Deine mysql version ist unrelevant für den oben genannten fehler.