Advertisement:

Author Topic: Upgrading to beta 4 Error Json decode error: Syntax error, malformed  (Read 2101 times)

Offline qubbah

  • Full Member
  • ***
  • Posts: 556
After uograding finished..
Im Having this error ... (in forum error log)

Json decode error: Syntax error, malformed JSON

File: /var/www/html/vs/Sources/Load.php
Line: 1535

and my arabic text only show like  :
الْمُتَّقÙ
« Last Edit: July 29, 2017, 01:03:00 PM by qubbah »

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,433
    • sbulen on GitHub
Re: Upgrading to beta 4 Error Json decode error: Syntax error, malformed
« Reply #1 on: July 30, 2017, 01:19:09 AM »
qubbah -

A few questions -
1)  What version were you upgrading FROM? 
2)  Did you have custom profile fields defined before the upgrade?  (That line of code that errored out is accessing custom profile fields.) 
3)  Was all of your content readable BEFORE the upgrade?  Could you copy & paste some of the pre-upgrade data here (one of the posts that goes bad)?
4)  I'm interested in seeing lots of charset & collation variables...  Would you be willing to run this utility & share the output?  Pre-upgrade would be best.
         https://github.com/sbulen/sjrbTools/blob/master/SMF_UTF8_Diag.php
« Last Edit: July 30, 2017, 02:09:44 AM by shawnb61 »
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp