Advertisement:

Author Topic: Problema proxy SSI de imágenes  (Read 395 times)

Offline Madirex

  • Jr. Member
  • **
  • Posts: 140
Problema proxy SSI de imágenes
« on: July 31, 2017, 02:34:33 PM »
El proxy SSI de las imágenes de la versión 2.0.14 de SMF no me funciona en el mod ADK Blog en la página de blogs (https://www.circuitsbm.com/index.php?action=blogs) pero en cambio si entro a cualquier entrada de cualquier blog el proxy funciona sin problema, solo afecta en esa página.

Y tampoco me funciona en la página del mod TeamPage (https://www.circuitsbm.com/index.php?action=teampage)

Por favor, evita cambiar el tamaño de fuente.  Tema modificado - Iris.
« Last Edit: July 31, 2017, 02:39:39 PM by Irisado »

Offline Príncipe_Azul

  • Full Member
  • ***
  • Posts: 599
  • Gender: Male
  • Colaborador
    • Foro ArgentinaIRC - Programación General, Informática, IRC y mIRC Scripting
Re: Problema proxy SSI de imágenes
« Reply #1 on: August 02, 2017, 12:56:50 AM »
Hola Madirex, según la respuesta de Gluz en éste mensaje:

https://www.simplemachines.org/community/index.php?topic=554187.msg3928203#msg3928203

el proxy si debería funcionar con los avatares externos.


Saludos
Foro ArgentinaIRC - Ayuda de Programación General, Informática, IRC y mIRC Scripting.

Foro de Artesanías, Recetas de cocina, Ropa para perros, Tejidos, Bijouterie, Porcelana, Chocolatería, Fondos de pantalla, Noticias, Belleza, Medicina natural, Videos y Programas: http://www.MisArtesanias.net/

Offline Madirex

  • Jr. Member
  • **
  • Posts: 140
Re: Problema proxy SSI de imágenes
« Reply #2 on: August 02, 2017, 06:30:52 AM »
Hola, como ya indiqué en el post, el proxy SÍ funciona en los avatares externos. El problema es que no funcionan en esas páginas concretas por motivos que yo desconozco.

En ningún momento mencioné los avatares externos, puesto que como dije en el post, en muchas otras secciones el proxy me funciona sin ningún problema, solo que en el mod ADK Blog en la página de blogs (https://www.circuitsbm.com/index.php?action=blogs) no me funciona, y tampoco en la página del mod TeamPage (https://www.circuitsbm.com/index.php?action=teampage).

Pero por ejemplo, en el mismo mod de ADK Blog, si entro en una entrada el proxy funciona perfectamente en la imagen.
Puede que sea por el cambio de tamaño en la imagen.

Online Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 922
  • Gender: Male
Re: Problema proxy SSI de imágenes
« Reply #3 on: August 02, 2017, 10:01:53 PM »
Eso se tendría que ver con los creadores del MOD, pues el proxy solo funciona en los mensajes y en el índice del foro, en otras partes, sobre todo en páginas creadas por mods los creadores tendrán que hacer algo para que el proxy se cargue también en sus páginas.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline Madirex

  • Jr. Member
  • **
  • Posts: 140
Re: Problema proxy SSI de imágenes
« Reply #4 on: August 03, 2017, 10:56:27 AM »
Eso se tendría que ver con los creadores del MOD, pues el proxy solo funciona en los mensajes y en el índice del foro, en otras partes, sobre todo en páginas creadas por mods los creadores tendrán que hacer algo para que el proxy se cargue también en sus páginas.

¿Podrías decirme más o menos dónde se encuentra el código del proxy para ver si puedo configurarlo para que afecte a esas secciones?

Online Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 922
  • Gender: Male
Re: Problema proxy SSI de imágenes
« Reply #5 on: August 07, 2017, 04:53:56 PM »
El código está en varias partes, pero principalmente entre Subs.php y Load.php en el directorio Sources.

Viendo los cambios que se hacen de la versión 2.0.13 a la versión 2.0.14 puedes encontrar dónde se usa el proxy y cómo usarlo.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.