Advertisement:

Author Topic: After upgrading to 2.0.14 SSI.php does not work  (Read 366 times)

Offline maxwl

  • Newbie
  • *
  • Posts: 4
After upgrading to 2.0.14 SSI.php does not work
« on: August 07, 2017, 09:28:08 AM »
I am using the SSI.php to integrate (login) from my website with the forum. All is working well with 2.0.13 until I applied the 2.0.14 patch. After the patch members can only login directly from the forum, they can no longer login from the website (hxxp:bramptoncyclingclub.com [nonactive]).

From the website I have a login form with the action invoking forum/index.php?action=login2
The form also submits two fields:
<input id="user" name="user" type="text" value="" placeholder="username">
<input id="passwrd" name="passwrd" value="" type="password" placeholder="password">

Is there any additional fields that is required for 2.0.14?


Offline maxwl

  • Newbie
  • *
  • Posts: 4
Re: After upgrading to 2.0.14 SSI.php does not work
« Reply #2 on: August 07, 2017, 09:51:10 PM »
Thanks, problem solved

Offline T.Linden

  • Newbie
  • *
  • Posts: 5
Re: After upgrading to 2.0.14 SSI.php does not work
« Reply #3 on: August 11, 2017, 11:16:47 PM »
Sheesh, I've just spent a week tracking down why my logins were no longer working the way they should, and now I find that a simple one line patch to SSI.php hasn't been pushed out, when it's been known about since May?

That's really pathetic, guys.

Thanks Shambles for the links.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,098
  • Gender: Male
    • Kindred-999 on GitHub
Re: After upgrading to 2.0.14 SSI.php does not work
« Reply #4 on: August 12, 2017, 02:21:00 PM »
I don't think you comprehend what is involved in making a patch release....
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,035
    • Arantor on GitHub
Re: After upgrading to 2.0.14 SSI.php does not work
« Reply #5 on: August 12, 2017, 03:00:34 PM »
I don't think you comprehend what is involved in making a patch release....

If SSI had been tested before release, it wouldn't have been an issue in the first place.

But seriously, three months?
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.