Advertisement:

Author Topic: Desaparece el modo seguro al insertar una imagen en el Post, proxy activado  (Read 493 times)

Offline Tenebroso

  • Semi-Newbie
  • *
  • Posts: 24
Buenas, en cuanto entra una imagen entre [ img ] [ /img ] se mantiene el https pero desaparece el modo seguro.

Foro sin abrir al usuario. En creación. Tema por defecto el de SMF

No tengo ningún MOD, recién instalado versión 2.0.14

Activado el proxy de imágenes

Donde miro?

Gracias


Offline d3vcho(void)

  • On Hiatus
  • SMF Hero
  • *
  • Posts: 2,245
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
¿Puedes dejar una URL para que veamos el problema?

Offline Tenebroso

  • Semi-Newbie
  • *
  • Posts: 24

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 959
  • Gender: Male
Al parecer es el sitio y no la imagen, ya que la imagen carga desde https pero al ir al sitio el mismo se marca como solo http, por lo que al parecer no tiene certificado y el tráfico lo redirigen a http.

Prueba modificar y poner el enlace de la imagen solo con http y no con https.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline Tenebroso

  • Semi-Newbie
  • *
  • Posts: 24
https://imagizer.imageshack.us/v2/161x161q90/923/ShHxml.png [nofollow]


El primer enlace, si marcaría como Es seguro


Al subir este link, se desbarata el "Es seguro" en cualquier foro smf
https://imageshack.com/i/pmVqRMchp [nofollow]


Son enlaces no aptos con https, aquí, la imagen se visualiza y desaparece el modo seguro. Aquí también pasa. Magia

Realmente el link lleva a la interfaz de la web

Offline Tenebroso

  • Semi-Newbie
  • *
  • Posts: 24
http://imagizer.imageshack.us/a/img922/84/VqRMch.png [nofollow]



Este link es http y el proxy hace el trabajo, lo marca como seguro



Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 959
  • Gender: Male
Si, eso, pero no es problema de tu sitio, es problema del imageshack y por eso te mencionaba lo de quitarle el https a la imagen, así tu foro usará el proxy y no se marcará como no seguro.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline Tenebroso

  • Semi-Newbie
  • *
  • Posts: 24


En realidad, el enlace http://imageshack.com/i/pmVqRMchp [nofollow] lleva a una interfaz en la que la imagen real tiene esta URL http://imagizer.imageshack.us/v2/160x191q90/922/VqRMch.png [nofollow]

Sugerencia, no permitir meter entre  [ img ]  [ /img ] nada que no tenga extension de imagen

Tal vez estoy diciendo algo que no es correcto, pero lo comento por si puede ayudar y evitamos que desaparezca el MODO SEGURO cuando un usuario utiliza este servidor de almacenamiento de imágenes.

 

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 959
  • Gender: Male
En otros servidores de imágenes funciona, siempre y cuando la redirección y el sitio estén bien configurados, en este caso imageshack no lo está y por eso marca como no seguro.

Es por eso que te mencioné lo de quitar el https del enlace de la imagen, así el proxy hará el trabajo correctamente, ya que cuando un enlace tiene https no se usa el proxy para nada ya que debería ser contenido seguro, pero lo dicho anteriormente, si el sitio no está bien configurado y las redirecciones estén mal, el contenido no se sirve de forma segura aunque el enlace principal si lo sea. Quitando el https del enlace y si está activado el proxy, éste hace el trabajo y se asegura que se sirve el contenido de forma segura.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.