Advertisement:

Author Topic: Site not working after migration  (Read 1535 times)

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #20 on: September 07, 2017, 06:01:57 AM »
If there's nothing else in .htaccess delete the file. 
If that doesn't work, upload a clean set of files and try to get the forum working.


Thanks for your reply, i have already delete .htaccess file and also edit .htaccess but both option is not working, when we do anything in like as above option in .htaccess then other page will be show 404 error. otherwise it display only home page.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,715
  • Too long in the wasteland
Re: Site not working after migration
« Reply #21 on: September 07, 2017, 03:24:42 PM »
Something is still rewriting forum urls.  Can you pm FTP access (server/username/password)?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,715
  • Too long in the wasteland
Re: Site not working after migration
« Reply #22 on: September 08, 2017, 11:24:23 PM »
Pretty urls is still installed, that's what's causing the problem.  If I replace /Sources, the problem is fixed, but it will break your mods.  You must either uninstall the mod with package manager, or manually if pm can't do it.  Or you can upload a clean set of files and reinstall any mods you still need.

Do you have more mods installed on your forum apart from prettyURLs? Do you have backup from before prettyURLs in your Packages/backups directory?

Looks like pretty urls was the first of nine mods installed in April and August.  Assuming forum has been working until recently, problem may have been caused by one of the more recent mod installs, there may be a conflict.  Restoring the pretty urls pm backup doesn't seem like a good idea, since it's the first mod and is obviously screwed up.  I would go with a clean install.  This is not a host or .htaccess problem, just a borked mod.

« Last Edit: September 08, 2017, 11:51:20 PM by Sir Osis of Liver »

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #23 on: September 14, 2017, 11:40:42 AM »
no one help me.. my problem is not solve till today.

 :-[ :-[ :-[

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,715
  • Too long in the wasteland
Re: Site not working after migration
« Reply #24 on: September 14, 2017, 04:32:33 PM »
You must either uninstall the mod with package manager, or manually if pm can't do it.  Or you can upload a clean set of files and reinstall any mods you still need.

If you are unable to do this yourself, pm FTP access (server/username/password) and I'll have a look.

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #25 on: September 15, 2017, 10:24:21 AM »
You must either uninstall the mod with package manager, or manually if pm can't do it.  Or you can upload a clean set of files and reinstall any mods you still need.

If you are unable to do this yourself, pm FTP access (server/username/password) and I'll have a look.


I have already send PM , FTP access (server/username/password) .

have you seen your Inbox?

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #26 on: September 15, 2017, 10:57:16 AM »
Dear Sir,

i mentioned here to all process of my forums :

firstly i take backup of my forum coz that time i need switch my hosting. so i have migrate to my forums files and sql from one hosting to another .
before migration of my site, this forum was working well.. but when i upload all files and sql then run my forum but it display only home page not other page is open include login , register and admin page. so please suggest me how can we logged in admin or worked well other page. i have already checked my htaccess that file also correct.

and as per this forum suggestion i have delete my all addons but my forum is not working well so please give me good solution for my forums

Thanks

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,715
  • Too long in the wasteland
Re: Site not working after migration
« Reply #27 on: September 15, 2017, 01:06:28 PM »
As per my response to your pm, I need FTP access to your account root.  I can only access the forum directory with the info you gave me.

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #28 on: September 16, 2017, 09:25:49 AM »
but why you need for other site access ?

i have face problem in my forum only. so i have provide you my forum access.

So can you tell me why you want to check my other files and folders ?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 67,550
    • Arantor on GitHub
Re: Site not working after migration
« Reply #29 on: September 16, 2017, 04:01:58 PM »
Because other files can interfere with the forum...
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline rackons2015

  • Semi-Newbie
  • *
  • Posts: 15
Re: Site not working after migration
« Reply #30 on: September 18, 2017, 08:00:35 AM »
but other domain folder is not related to this forum subdomain . so why they are interrupted ?


If possible so please solve from forum without access of other domain files

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 67,550
    • Arantor on GitHub
Re: Site not working after migration
« Reply #31 on: September 18, 2017, 09:41:54 AM »
Because things outside the forum folder can affect things inside the forum folder.

I mean, I'm only a 15 year veteran of PHP, been doing websites for nearly 20 years, working professionally as a web dev for some of the largest institutions in the world, oh and formerly of the SMF dev team... if you tell me it can't be a thing, I guess you must be right...
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.