Advertisement:

Author Topic: Error al tratar de actualizar a 2.0.14  (Read 215 times)

Offline AlexBarsan

  • Semi-Newbie
  • *
  • Posts: 22
Error al tratar de actualizar a 2.0.14
« on: September 06, 2017, 10:30:15 AM »
Buen día a todos los guru's de este foro, son siglos desde mi ultimo ingreso pero hoy no lo puedo evitar, necesito ayuda de algún especialista.

Problema al tratar de actualizar del 2.0.13 a 2.0.14 con el parche la prueba que se hace antes de la actualización me aroja un error en el archivo subs.php mismo que adjunto por si alguna alma piadosa le puede echar un ojo, tengo bastantes mods instalados pero nada del otro mundo, y por mas que trato yo de editar para ver donde esta el problema no lo encuentro, cualquier ayudo o idea es bienvenida.

Mil gracias!

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Erro al tratar de actualizar a 2.0.14
« Reply #1 on: September 06, 2017, 10:32:12 AM »
¿Has probado a hacer la modificación de forma manual? Puedes seguir las indicaciones de este tema.
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline AlexBarsan

  • Semi-Newbie
  • *
  • Posts: 22
Re: Error al tratar de actualizar a 2.0.14
« Reply #2 on: September 06, 2017, 10:38:22 AM »
si ya trate de editar estas lineas de código, pero no lo logre ya que no coinciden bien y si muevo algo mas (ya lo hice) tengo puros errores así por lo pronto lo deje así y por eso pido ayuda acá... nunca me atoré tanto con un archivo y eso que llevo años administrando y modificando mi foro...

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Error al tratar de actualizar a 2.0.14
« Reply #3 on: September 06, 2017, 10:39:39 AM »
Ya que has dejado el archivo adjuntado, ¿puedes decirnos qué cambios indica que hay que realizar en ese archivo, y en qué líneas? Seguramente esté afectado por alguna modificación.
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline AlexBarsan

  • Semi-Newbie
  • *
  • Posts: 22
Re: Error al tratar de actualizar a 2.0.14
« Reply #4 on: September 06, 2017, 11:08:35 AM »
Pues esta cosa no puede mas que yo JAJAJA ya logre encontrar el error y las lineas, era una linea mas de código misma que agregó ADK portal (que por cierto parece que ya no existen....) ya modifique manual para dejar estas lineas bien y ya no marca error en la prueba, peroooo o sorpresa para que esta actualización funcione necesito que mi servidor corra al menos php 5.3 y solo esta en el 5.2.17 así que ahora a "pelear" con el hosting, ustedes expertos que opinan lo cambio a una versión superior? en el mismo host también tengo unos sitios alojados que coren drupal y wordpress, afectara a estos? en fin muchas gracias por todo

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Error al tratar de actualizar a 2.0.14
« Reply #5 on: September 06, 2017, 11:10:40 AM »
Una observación, se requiere al menos PHP 5.4 para que funcione SMF 2.0.14, ya que al publicar la versión nos dimos cuenta de que había errores con PHP 5.3, así que decidimos incrementar la versión mínima. En cuanto a los otros sitios, en teoría no debería afectar gravemente al funcionamiento que se incrementase la versión hasta PHP 5.6, quizás con PHP 7 ya si habría algunos problemas.

Por si acaso, guarda una copia de seguridad de todo antes de hacer el cambio.
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline AlexBarsan

  • Semi-Newbie
  • *
  • Posts: 22
Re: Error al tratar de actualizar a 2.0.14
« Reply #6 on: September 06, 2017, 11:17:38 AM »
gracias estoy en espera que me contesten del hosting, tienen disponible 5.4 y 5.6 cual recomiendas?

Online d3vcho();

  • Localizer
  • SMF Hero
  • *
  • Posts: 2,000
  • Gender: Male
  • Be prepared for hell
    • d3vcho on GitHub
    • @SMF_ES on Twitter
Re: Error al tratar de actualizar a 2.0.14
« Reply #7 on: September 06, 2017, 11:20:17 AM »
Cualquiera de las dos es aceptable, me quedaría con 5.6 por ser algo más reciente.
Programmer (noun.)
A person who fixed a problem you don't know you have, in a way you don't understand.


¡Únete al canal IRC de SMF en español! #smf-es en Freenode
Sigue a @SMF_ES en Twitter para enterarte de todas las novedades de SMF

Offline AlexBarsan

  • Semi-Newbie
  • *
  • Posts: 22
Re: Error al tratar de actualizar a 2.0.14
« Reply #8 on: September 06, 2017, 11:38:27 AM »
GRACIAS! doy por cerrado el tema.