Advertisement:

Author Topic: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running  (Read 1423 times)

Offline taysys

  • Semi-Newbie
  • *
  • Posts: 13
Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« on: September 08, 2017, 12:05:39 PM »
My ISPs server with 1.1.18 running crashed and don't know if we can get the latest database back.  So to help my users I set up a temporary GoDaddy server and had 2.014 installed through their wizard.  It's running fine, well mostly.  Can't modify category names but that's a known and is a separate subject.

So to see if I can get the old forum to come up after the ISP gets a new drive installed or the original one recovered, I restored an older copy of the DB in a separate database on GD.  Then copied over a clean set of 1.1.18 files into a different directory and tried to run the install.php.  Nothing happens, there is just a white screen.

First, can this be done?  If so what am I doing wrong?

Thanks for any assistance in advance.

Bob

Offline Looking

  • SMF Hero
  • ******
  • Posts: 2,126
  • SMF Customization
    • jeanborde on Facebook
    • SMF Custom Themes
Re: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« Reply #1 on: September 08, 2017, 12:08:49 PM »
To be honest it sounds like you need to get a proper host before anything else. A host should have auto backups and sorry to say but shared hosting on Godaddy is not going to be good for your community.

Offline taysys

  • Semi-Newbie
  • *
  • Posts: 13
Re: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« Reply #2 on: September 08, 2017, 01:27:38 PM »
GD is only temporary until I can get the original site restored on the other ISP.  GD was just a quick solution to get the users going again after 3 days of no forum.

I plan to DC the v2 copy on GD but wanted to see the latest  posts and then test the 1.1.18 for v2 conversion.  Basically use it as a sandbox.


Bob

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,082
  • 'Tis the gift to be simple
Re: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« Reply #3 on: September 08, 2017, 10:14:19 PM »
Do not use GoDaddy's auto installer, do it yourself -

https://wiki.simplemachines.org/smf/Installing

Install 1.1.18 using install package -

https://download.simplemachines.org/index.php?archive;version=72

Set up a new database, run install.php, then import your 1.1.18 database into the new database.  If you run install.php on your production db, it will delete all of your content.

Offline taysys

  • Semi-Newbie
  • *
  • Posts: 13
Re: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« Reply #4 on: September 10, 2017, 11:01:03 PM »
Well unfortunately I got 2.0.14 up and being used but with the GD installer.  Too late to back out of that one, though since it's just a temp site I am going to abandon it after I get the main site up.

The old v1 data was already imported into a second database.  This can be done again.  So I'll just delete the database and start over for v1. I would have still thought that since I did ftp v1 to a different directory that I could still start the installer.  It just sits there with a white screen.

Thanks.

Bob

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,082
  • 'Tis the gift to be simple
Re: Install Separate Copy of 1.1.18 on Server That Has 2.0.14 Running
« Reply #5 on: September 11, 2017, 12:28:43 AM »
If you upload the 1.1.18 package to a new directory and run install.php, it should at least load and ask for db credentials, even if there isn't a db.  If you upload only install.php to an empty directory, and run it, you should get this error -

A critical error has occurred.

This installer was unable to find the installer's language file or files. They should be found under:

/test/Themes/default/languages

In some cases, FTP clients do not properly upload files with this many folders. Please double check to make sure you have uploaded all the files in the distribution.

If that doesn't help, please make sure this install.php file is in the same place as the Themes folder.

If you continue to get this error message, feel free to look to us for support.


If you're not even getting that, GD is blocking the file from running.  They have been doing strange things with security lately.