Advertisement:

Author Topic: MySQL 5.0.12 Compatibility patch  (Read 155467 times)

Offline kegobeer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,994
  • Gender: Male
  • I am ninja!
    • The Kazebeer Family Website
Re: MySQL 5.0.12 Compatibility patch
« Reply #100 on: December 27, 2005, 03:50:36 PM »
MySQL AB recently announced their fifth version of MySQL to be ready for production use. Version 5 comes with a lot of new features, like stored procedures, triggers, and views. As of MySQL 5.0.12, a few changes have been made in the precedence of table joins. This causes some pages of Simple Machines Forum to stop working.

...

Regardless of whether this patch is applied or not, SMF will install without a problem on a MySQL 5.0.12 server and the package manager will remain accessible.

Addition - 12th December 2005
Since the first patch another problem with capatibility has been identified. If you had applied the previous patch, and now find sorting in the personal message centre does not work, run the modification attached to this post called smf_mysql_5.0.12_patch2. For all people patching for the first time simply use smf_mysql_5.0.12.
"The truth of the matter is that you always know the right thing to do. The hard part is doing it." - Norman Schwarzkopf
Posting and you (Click "WATCH THIS MOVIE")

Offline #1taz

  • Semi-Newbie
  • *
  • Posts: 10
Re: MySQL 5.0.12 Compatibility patch
« Reply #101 on: January 02, 2006, 04:18:59 PM »
Hi everyone...I'm getting this error when I try to install this MY SQL patch through the package manager:

2: copy(SSI.php~): failed to open stream: Permission denied
File: /home/compuhel/public_html/Sources/Subs-Package.php
Line: 1307

Also...for some odd reason I can't alter my chmod settings for my source/packages/temp directory or any files in it on my ftp...when I change the folder from 755 to 777 and try to delete it...it fails and switches right back to 755.

The same goes for it's contents...they fail  to delete and switch right back to 666.

I recently had a mod/theme conflict issue and my host and I re-installed SMF 1.05 overwriting all of my old files and deleted the old theme, and now I'm using the default theme.

Everything looks and works fine now..but my package manager doesn't seem to want to work.

I am a novice at this, so I have no clue what that error means...so speak slowly please and use small words....there is now a dumb person in the room...lol

Thanks!
« Last Edit: January 02, 2006, 05:28:43 PM by #1taz »

Offline Trekkie101

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 8,158
  • Gender: Male
  • Ad Astra!
    • https://www.facebook.com/DLRPRoundup on Facebook
    • @dlrproundup on Twitter
    • DLRP Roundup
Re: MySQL 5.0.12 Compatibility patch
« Reply #102 on: January 02, 2006, 05:57:22 PM »
Hi everyone...I'm getting this error when I try to install this MY SQL patch through the package manager:

2: copy(SSI.php~): failed to open stream: Permission denied
File: /home/compuhel/public_html/Sources/Subs-Package.php
Line: 1307

Also...for some odd reason I can't alter my chmod settings for my source/packages/temp directory or any files in it on my ftp...when I change the folder from 755 to 777 and try to delete it...it fails and switches right back to 755.

The same goes for it's contents...they fail  to delete and switch right back to 666.

I recently had a mod/theme conflict issue and my host and I re-installed SMF 1.05 overwriting all of my old files and deleted the old theme, and now I'm using the default theme.

Everything looks and works fine now..but my package manager doesn't seem to want to work.

I am a novice at this, so I have no clue what that error means...so speak slowly please and use small words....there is now a dumb person in the room...lol

Thanks!

http://www.simplemachines.org/community/index.php?topic=28393.0

Try running that :)

Offline #1taz

  • Semi-Newbie
  • *
  • Posts: 10
Re: MySQL 5.0.12 Compatibility patch
« Reply #103 on: January 02, 2006, 09:01:36 PM »
Nope..didn't help..it is still the same - but thanks!

EDIT: Fixed it...my chmod on my Subs-Package.php was set wrong...once I changed it to 777....everything went fine.

Thanks for everything everyone.

Oh and BTW....SSI.php~ wasn't even there.

How's that for wierd?
« Last Edit: January 03, 2006, 03:13:35 AM by #1taz »

Dam

  • Guest
Re: MySQL 5.0.12 Compatibility patch
« Reply #104 on: January 12, 2006, 12:23:01 PM »
The latest version in Downloads section should have all patches applied at the time.

It isn't obvious to browse the forum just to install SMF.

Offline Mark Thomas

  • Semi-Newbie
  • *
  • Posts: 33
Re: MySQL 5.0.12 Compatibility patch
« Reply #105 on: January 15, 2006, 12:01:38 PM »
I just upgraded MySQL from 4. to 5.0.18 and applied the patch ( smf_mysql_5_0_12.tar.gz ) to my SMF 1.0.5 board. Everything seems to working fine with the exception of sorting by date in personal messages. Sorting by author/topic works fine. So my question is, will applying the second patch ( smf_mysql_5_0_12_patch2.tar.gz ) fix it?

The only other mod installed is PHP 4.4.0 Compatibility Update.

P.S. this isn't a deal breaker, I'm not going to lose any sleep over it, just curious.

Many thanks to the SMF team, you make us admins look good!

Offline PeterRaskind

  • Newbie
  • *
  • Posts: 1
Re: MySQL 5.0.12 Compatibility patch
« Reply #106 on: January 21, 2006, 08:43:16 AM »
 8) Hahahahaha ! I spend an hour figuring it out .. deleting package, installing package ..
It turns out to be a [ Proceed ] button that I didnt press ..

Works like a charm .. what a noob ..

Offline 3-CXT

  • Jr. Member
  • **
  • Posts: 136
  • Gender: Male
    • Battleholicz-BattleBoard
Re: MySQL 5.0.12 Compatibility patch
« Reply #107 on: February 03, 2006, 11:05:26 AM »
can i install this patch also, when i only got php4.4? i will try php5.. but...i am not shure if this works

Offline kegobeer

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 3,994
  • Gender: Male
  • I am ninja!
    • The Kazebeer Family Website
Re: MySQL 5.0.12 Compatibility patch
« Reply #108 on: February 03, 2006, 11:07:28 AM »
can i install this patch also, when i only got php4.4? i will try php5.. but...i am not shure if this works

This is a MySQL patch, not a PHP patch.
"The truth of the matter is that you always know the right thing to do. The hard part is doing it." - Norman Schwarzkopf
Posting and you (Click "WATCH THIS MOVIE")

Offline 3-CXT

  • Jr. Member
  • **
  • Posts: 136
  • Gender: Male
    • Battleholicz-BattleBoard
Re: MySQL 5.0.12 Compatibility patch
« Reply #109 on: February 03, 2006, 12:55:23 PM »
oh my fault.. thnks a lot

Offline theiceman

  • Semi-Newbie
  • *
  • Posts: 23
Re: MySQL 5.0.12 Compatibility patch
« Reply #110 on: February 20, 2006, 06:12:18 AM »
atm iam unsing smf rc2
mods:
Enchanced post template    1.0
Hide Post, 1.0.7
WoW Itemstats for SMF 1.0.5/6, 1.1 RC1/RC2 (ver. 1.23)
WoW Itemstats 1.21 German Translation

do i need this patch too?

Versionsinformation:
Forum Version: SMF 1.1 RC2 (ausführlicher)
Aktuelle SMF Version: SMF 1.1 RC2
PHP Version: 5.0.5-Debian-0.8~sarge1
MySQL Version: 5.0.18-Debian_3.dotdeb.1-log
Server Version: Apache/2.0.54 (Debian GNU/Linux) mod_jk2/2.0.4 PHP/5.0.5-Debian-0.8~sarge1 mod_ssl/2.0.54 OpenSSL/0.9.7e
GD Version: bundled (2.0.28 compatible)

I Get this error if iam trying to delete a hole topic:


Datenbankfehler: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)
Datei: /****/Sources/RemoveTopic.php
Zeile: 355


Offline Compuart

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 5,774
  • Gender: Male
  • Zéeeeal
    • RealityNet
Re: MySQL 5.0.12 Compatibility patch
« Reply #111 on: February 20, 2006, 08:49:08 AM »
This error is not related to the patch, but a configuration error of MySQL. Either make sure the mysql socket is in that directory and accessible or configure MySQL to point the socket to another path. For the latter, locate your mysql.sock file (typically it might be in /tmp/mysql.sock or /var/lib/mysql/mysql.sock) and adjust the MySQL configuration file my.cfg (probably in the /etc directory) accordingly:
Code: [Select]
[mysqld]
socket=/var/lib/mysql/mysql.sock
Hendrik Jan Visser
Former Lead Developer & Co-founder www.simplemachines.org
Personal Signature:
Realitynet.nl -> ExpeditieRobinson.net / PekingExpress.org / WieIsDeMol.Com

Offline theiceman

  • Semi-Newbie
  • *
  • Posts: 23
Re: MySQL 5.0.12 Compatibility patch
« Reply #112 on: February 20, 2006, 10:20:19 AM »
thx for the quick to respond, i will try it this evening.

Offline Caladan Brood

  • Newbie
  • *
  • Posts: 1
Re: MySQL 5.0.12 Compatibility patch
« Reply #113 on: March 29, 2006, 05:57:09 PM »
Does this board run with MySQL 5.0.19 too? Are there any error or compatibility bug with MySQL 5.0.19?

Caladan.

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MySQL 5.0.12 Compatibility patch
« Reply #114 on: March 29, 2006, 07:59:31 PM »
This should fix 5.0.012 and up including .19.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Joges

  • Semi-Newbie
  • *
  • Posts: 39
Re: MySQL 5.0.12 Compatibility patch
« Reply #115 on: April 04, 2006, 10:02:51 AM »
Compuart, were you commentaiting this?
atm iam unsing smf rc2
mods:
Enchanced post template    1.0
Hide Post, 1.0.7
WoW Itemstats for SMF 1.0.5/6, 1.1 RC1/RC2 (ver. 1.23)
WoW Itemstats 1.21 German Translation

do i need this patch too?

Versionsinformation:
Forum Version: SMF 1.1 RC2 (ausführlicher)
Aktuelle SMF Version: SMF 1.1 RC2
PHP Version: 5.0.5-Debian-0.8~sarge1
MySQL Version: 5.0.18-Debian_3.dotdeb.1-log
Server Version: Apache/2.0.54 (Debian GNU/Linux) mod_jk2/2.0.4 PHP/5.0.5-Debian-0.8~sarge1 mod_ssl/2.0.54 OpenSSL/0.9.7e
GD Version: bundled (2.0.28 compatible)

I Get this error if iam trying to delete a hole topic:


Datenbankfehler: Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (111)
Datei: /****/Sources/RemoveTopic.php
Zeile: 355


I'm having the very same problem with 5.0.19.

EDIT: And here we go.... finally, after about 13hours of fighting: http://www.simplemachines.org/community/index.php?topic=63232.msg438732#msg438732 THX!
« Last Edit: April 04, 2006, 10:29:06 AM by Joges »

Offline Jump1979man

  • Jr. Member
  • **
  • Posts: 127
  • Gender: Male
Re: MySQL 5.0.12 Compatibility patch
« Reply #116 on: April 20, 2006, 10:54:54 AM »
Does this board run with MySQL 5.0.19 too? Are there any error or compatibility bug with MySQL 5.0.19?

Caladan.

I am having issues with 5.0.19 and this forum.

Offline linuxgeek

  • Newbie
  • *
  • Posts: 4
  • Gender: Male
    • The Dynaplex Network
Re: MySQL 5.0.12 Compatibility patch
« Reply #117 on: April 29, 2006, 02:52:24 PM »
MySQL AB recently announced their fifth version of MySQL to be ready for production use. Version 5 comes with a lot of new features, like stored procedures, triggers, and views. As of MySQL 5.0.12, a few changes have been made in the precedence of table joins. This causes some pages of Simple Machines Forum to stop working.

I am a bit confused about this.  I just tried to install SMF 1.1 RC2 on my local server with MySQL 5.1.7, Apache 2.2 with PHP 5.1.2 and can not get the installer to go beyond the page where I enter all the server information.  It keeps just coming back to that same data entry page.

Do I need to install the MySQL 5 compatibility patch for RC2?  I am not getting any error messages.
Local Server: FreeBSD 6.0, Apache 2.2 with PHP 5.1.2, MySQL 5.0.20, and SMF 1.1 RC2

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MySQL 5.0.12 Compatibility patch
« Reply #118 on: April 29, 2006, 04:06:51 PM »
No you do not need the MySQL Compatibility patch.

Make sure that your MySQL is configured properly.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline linuxgeek

  • Newbie
  • *
  • Posts: 4
  • Gender: Male
    • The Dynaplex Network
Re: MySQL 5.0.12 Compatibility patch
« Reply #119 on: April 29, 2006, 04:08:19 PM »
No you do not need the MySQL Compatibility patch.

Make sure that your MySQL is configured properly.

As far as I can tell, I have my MySQL configured correctly.  Other software works with it just fine.
Local Server: FreeBSD 6.0, Apache 2.2 with PHP 5.1.2, MySQL 5.0.20, and SMF 1.1 RC2