Advertisement:

Author Topic: MySQL 5.0.12 Compatibility patch  (Read 152799 times)

Offline linuxgeek

  • Newbie
  • *
  • Posts: 4
  • Gender: Male
    • The Dynaplex Network
Re: MySQL 5.0.12 Compatibility patch
« Reply #120 on: April 29, 2006, 08:40:26 PM »
No you do not need the MySQL Compatibility patch.

This just in..  ;)  I went back to MySQL 5.0.20 and so far things seem to be working.  I have not tried any maintenance functions, but have setup several forums, some with sub-boards, and that much seems fine now.  I could not even get SMF 1.1 RC2 (or any other version) to install and run on my local server until now.
Local Server: FreeBSD 6.0, Apache 2.2 with PHP 5.1.2, MySQL 5.0.20, and SMF 1.1 RC2

Offline shinji

  • Semi-Newbie
  • *
  • Posts: 84
  • Gender: Male
    • HARDMODDING&co.
Re: MySQL 5.0.12 Compatibility patch (module)
« Reply #121 on: May 23, 2006, 05:42:56 PM »
error fatal

Quote
Fatal error: Using $this when not in object context in /home/shinji/public_html/modules/mod_smf_recent_topics.php on line 30

line 30
Quote
if ($this->_result = $database->query()) {
MODD Artesano y Profesional..
(Mr.Shinji/Christianeithor)
User bar


Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MySQL 5.0.12 Compatibility patch
« Reply #122 on: May 23, 2006, 07:10:16 PM »
This doesn't seem to be related to the MySQL Compatibility issue.  It seems to be an issue with the joomla/mambo bridge.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline Max22

  • Jr. Member
  • **
  • Posts: 100
    • Eng2ita.net
Re: MySQL 5.0.12 Compatibility patch
« Reply #123 on: July 19, 2006, 05:59:54 PM »
I've this error during activation of board news function (in this case smf 1.1 rc2) in mkportal :

Code: [Select]
ERROR: Database error.
Cannot execute the query: SELECT m.posterTime, m.subject, m.ID_TOPIC, m.ID_MEMBER, m.ID_MSG, m.ID_BOARD, IFNULL(mem.realName, m.posterName) AS posterName, t.ID_BOARD, t.numReplies, b.name AS bName, m.body, m.smileysEnabled, m.Icon, mem.avatar, av.filename FROM smf_topics AS t, smf_messages AS m, smf_boards AS b LEFT JOIN smf_members AS mem ON (mem.ID_MEMBER = m.ID_MEMBER) LEFT JOIN smf_attachments AS av ON (mem.ID_MEMBER = av.ID_MEMBER) WHERE m.ID_MSG = t.ID_FIRST_MSG AND m.ID_MSG >= 756 AND b.ID_BOARD IN (2) AND b.ID_BOARD = t.ID_BOARD ORDER BY m.ID_MSG DESC LIMIT 1
MySql Error returned: Unknown column 'm.ID_MEMBER' in 'on clause'
MySql Error code: 1054

Please help me, I've MySQL 5.0.23-standard.

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MySQL 5.0.12 Compatibility patch
« Reply #124 on: July 20, 2006, 02:05:27 AM »
This this not related to the MySQL Compatibility.  It's an issue with MKPortal.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline GJ-tje

  • Semi-Newbie
  • *
  • Posts: 78
    • FlipDesign - The Twist in Design!
Re: MySQL 5.0.12 Compatibility patch
« Reply #125 on: August 31, 2006, 01:55:56 PM »
Does this mod need any modification in order to work with 1.1RC3?
If so, what needs to be changed?
« Last Edit: August 31, 2006, 01:58:57 PM by GJ-tje »
"People cannot gain anything without sacrificing something of equal value.
To obtain, something of equal value must be lost.
That is alchemy's first law of Equivalent Exchange."

"People should not be afraid of their Goverments. Goverments should be afraid of their People."

Offline JayBachatero

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 19,562
  • Gender: Male
    • @jaycreations on Twitter
    • JayBachatero.com
Re: MySQL 5.0.12 Compatibility patch
« Reply #126 on: August 31, 2006, 02:13:45 PM »
No RC3 is MySQL 5.0.12 compatible.
Follow me on Twitter

"HELP!!! I've fallen and I can't get up"
This moment has been brought to you by LifeAlert

Offline GJ-tje

  • Semi-Newbie
  • *
  • Posts: 78
    • FlipDesign - The Twist in Design!
Re: MySQL 5.0.12 Compatibility patch
« Reply #127 on: August 31, 2006, 02:24:59 PM »
No RC3 is MySQL 5.0.12 compatible.

That's even better news! Many thanks in advance!
"People cannot gain anything without sacrificing something of equal value.
To obtain, something of equal value must be lost.
That is alchemy's first law of Equivalent Exchange."

"People should not be afraid of their Goverments. Goverments should be afraid of their People."

Offline junglecat

  • Full Member
  • ***
  • Posts: 439
  • Gender: Female
  • Geek Wannabe
Re: MySQL 5.0.12 Compatibility patch
« Reply #128 on: January 04, 2007, 06:52:53 PM »
No RC3 is MySQL 5.0.12 compatible.
I updated mysql on my server to 5.0 and my forum 1.1.1 is down with sql errors. Someone please help! I need a patch to fix it. :(


ETA: never mind! It came back up all by itself.
« Last Edit: January 04, 2007, 06:56:45 PM by junglecat »
PM me for affordable hosting. I will install your SMF forum with your choice of a theme for FREE.
~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~
Join us at Christian Discussions 
~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~*~