Advertisement:

Author Topic: Update to 2.0.14 successful then white/blank screen  (Read 2816 times)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Update to 2.0.14 successful then white/blank screen
« on: October 04, 2017, 05:24:15 PM »
No sure what is happening.  SMF says it needs to be updated, test all successful .  run update, screen appears saying all is well and all upgrades should function normally.
Click any navigation and the page goes blank, no error.
close out reopen, to blank page.
I was able to restore the home folder form cpanel and my host backup, and its back to normal, tried upgrade again, same result.  Restored again
List of updates/mods

1.    SMF 2.0.14 Update    1.0    [ Uninstall ]
2.    SMF 2.0.13 Update    1.0    [ Uninstall ]
3.    SMF 2.0.12 Update    1.0    [ Uninstall ]
4.    SMF 2.0.11 Update    1.0    [ Uninstall ]
5.    Responsive Curve    1.0 Beta 3    [ Uninstall ]
6.    SMF 1.1.21 / 2.0.10 Update    1.0    [ Uninstall ]
7.    Google Analytics Code    1.4

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,041
    • Arantor on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #1 on: October 04, 2017, 05:25:54 PM »
What version of PHP do you have? SMF 2.0.14 requires PHP 5.4.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #2 on: October 04, 2017, 06:06:54 PM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #3 on: October 04, 2017, 07:48:52 PM »
What version of PHP do you have? SMF 2.0.14 requires PHP 5.4.

Cpanel says
PHP Version    5.6.31

SMF support and credits
Version Information:
Forum version: SMF 2.0.13 (more detailed)
Current SMF version: SMF 2.0.14
GD version: bundled (2.1.0 compatible)
MySQL version: 10.0.31-MariaDB-cll-lve
PHP: 5.3.29
Server version: LiteSpeed

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #4 on: October 04, 2017, 07:49:48 PM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
how do i turn that on and how does it prevent the white screen?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,106
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #5 on: October 04, 2017, 08:15:57 PM »
Don't actually follow aegerz's advice. He has his system configured in a way that most people would not find useful. :P

A white screen is a server side failure. Check with your host...  or look for a file called error.log or errorlog.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #6 on: October 04, 2017, 09:49:11 PM »
'tis true ... i blur the lines between development and live environments and my member base is very laid back and is very underutilized (got to make use of those spare cycles that i'm paying my host for !)

... but a blank screen is like sitting in a traffic jam going nowhere wheras my approach is akin to taking a detour; the longer way but always keeping moving.

... analogy-type thing ... that's my story and i'm sticking to it  ???  ::)

SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #7 on: October 04, 2017, 10:54:23 PM »
There have been at least two reports of cpanel reporting incorrect php version, I worked on one of the forums and saw it myself.  Have you run phpinfo?  File attached.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #8 on: October 05, 2017, 01:15:35 AM »
There have been at least two reports of cpanel reporting incorrect php version, I worked on one of the forums and saw it myself.  Have you run phpinfo?  File attached.

Just ran it:
PHP Version 5.3.29
Is there  anything else from that page thats needed?
Just sent my host support an ticket  host that cpanel is reporting the wrong version of PHP?
« Last Edit: October 05, 2017, 01:27:09 AM by Nodaz »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,041
    • Arantor on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #9 on: October 05, 2017, 03:27:49 AM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #10 on: October 05, 2017, 04:14:10 AM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
how do i turn that on and how does it prevent the white screen?

since you asked, I went through /etc/php.ini and turned all the logging values on and restarted httpd/apache.

the values I set on are for development so that's why it's not recommended. I need high visibility as I run many mods, upgrade them and have to deal with conflicts and bugs.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #11 on: October 05, 2017, 04:27:09 PM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.
Yes, found ity, PHP is now correct.
BUT
When i attempted the update, i was told to uninstall it as it was already installed, i tried that and am told that the uninstaller does not exist, i must have deleted the package  in this mess.
How do i rectify this?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #12 on: October 05, 2017, 04:33:21 PM »
You shouldn't have to update again, forum should be at 2.0.14.  The update installs correctly in php 5.3, it just doesn't run after installation.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #13 on: October 05, 2017, 07:11:26 PM »
You shouldn't have to update again, forum should be at 2.0.14.  The update installs correctly in php 5.3, it just doesn't run after installation.

Its not, still shows 2.0.13 after updating PHP, it shows 2.0.14 as installed and current  is now set to PHP: 5.5.38, 2.014 does not show in the downloaded packages.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #14 on: October 05, 2017, 07:26:18 PM »
can you attempt an uninstall 2.0.14 ?

get to the point where you can back out and see if there are any errors stopping you from committing ? any errors seen would provide some useful diagnostics.

I have uninstalled 2.0.14 and then reinstalled it on my test system without any problems.

once any patch is applied, all it takes is a page reload  for the new version to show at the bottom of your page. if the patch is truly on then you may have a caching issue.

I wait for my host to take my regular system image backup BEFORE I make system changes. I have had my system reimaged before and it's a godsend.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #15 on: October 05, 2017, 07:45:10 PM »
can you attempt an uninstall 2.0.14 ?

get to the point where you can back out and see if there are any errors stopping you from committing ? any errors seen would provide some useful diagnostics.

I have uninstalled 2.0.14 and then reinstalled it on my test system without any problems.

once any patch is applied, all it takes is a page reload  for the new version to show at the bottom of your page. if the patch is truly on then you may have a caching issue.

I made an attempt to uninstall, but tells me it is unable to continue:

An Error Has Occurred!
This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

the 2.0.14 package shows in package downloads and 2.0.14 show under installed packages. 

"Browse packages" shows 2.0.14 but doesn't show it installed (list files /Delete are only options)
But under
"Installed Packages" it does show as installed.
« Last Edit: October 05, 2017, 08:28:26 PM by Nodaz »

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #16 on: October 05, 2017, 08:47:43 PM »
I am not SMF support and this is issue arises from time to time.

the only thing I can suggest is that you emulate 2.0.14 (Advanced link at the bottom of the Browse Packages) page and try again.

I'm sure some real support will drop by and help you soon.  worst case, you may lose your mods after a system refresh. and will have to install them so go to Installed Packages and note the order that you installed them - it will go from latest to oldest.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #17 on: October 05, 2017, 11:48:55 PM »
I saw this once recently.  Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.  Not on my computer, can't find previous topic, but believe that's what we ended up doing.


Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #18 on: October 06, 2017, 07:34:49 PM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.

the PHP issue is resolved as i know how to change it, this issue now is this:
when i try to uninstall
I made an attempt to uninstall, but tells me it is unable to continue:

An Error Has Occurred!
This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

the 2.0.14 package shows in package downloads and 2.0.14 show under installed packages.

"Browse packages" shows 2.0.14 TWICE  but doesn't show it installed (list files /Delete are only options)


But under
"Installed Packages" it does show as installed.


But if i try to uninstall it from here i am told there is no uninstaller...

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,106
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #19 on: October 06, 2017, 09:55:02 PM »
Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.