Advertisement:

Author Topic: Update to 2.0.14 successful then white/blank screen  (Read 2815 times)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Update to 2.0.14 successful then white/blank screen
« on: October 04, 2017, 05:24:15 PM »
No sure what is happening.  SMF says it needs to be updated, test all successful .  run update, screen appears saying all is well and all upgrades should function normally.
Click any navigation and the page goes blank, no error.
close out reopen, to blank page.
I was able to restore the home folder form cpanel and my host backup, and its back to normal, tried upgrade again, same result.  Restored again
List of updates/mods

1.    SMF 2.0.14 Update    1.0    [ Uninstall ]
2.    SMF 2.0.13 Update    1.0    [ Uninstall ]
3.    SMF 2.0.12 Update    1.0    [ Uninstall ]
4.    SMF 2.0.11 Update    1.0    [ Uninstall ]
5.    Responsive Curve    1.0 Beta 3    [ Uninstall ]
6.    SMF 1.1.21 / 2.0.10 Update    1.0    [ Uninstall ]
7.    Google Analytics Code    1.4

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,041
    • Arantor on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #1 on: October 04, 2017, 05:25:54 PM »
What version of PHP do you have? SMF 2.0.14 requires PHP 5.4.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #2 on: October 04, 2017, 06:06:54 PM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #3 on: October 04, 2017, 07:48:52 PM »
What version of PHP do you have? SMF 2.0.14 requires PHP 5.4.

Cpanel says
PHP Version    5.6.31

SMF support and credits
Version Information:
Forum version: SMF 2.0.13 (more detailed)
Current SMF version: SMF 2.0.14
GD version: bundled (2.1.0 compatible)
MySQL version: 10.0.31-MariaDB-cll-lve
PHP: 5.3.29
Server version: LiteSpeed

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #4 on: October 04, 2017, 07:49:48 PM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
how do i turn that on and how does it prevent the white screen?

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,106
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #5 on: October 04, 2017, 08:15:57 PM »
Don't actually follow aegerz's advice. He has his system configured in a way that most people would not find useful. :P

A white screen is a server side failure. Check with your host...  or look for a file called error.log or errorlog.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #6 on: October 04, 2017, 09:49:11 PM »
'tis true ... i blur the lines between development and live environments and my member base is very laid back and is very underutilized (got to make use of those spare cycles that i'm paying my host for !)

... but a blank screen is like sitting in a traffic jam going nowhere wheras my approach is akin to taking a detour; the longer way but always keeping moving.

... analogy-type thing ... that's my story and i'm sticking to it  ???  ::)

SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #7 on: October 04, 2017, 10:54:23 PM »
There have been at least two reports of cpanel reporting incorrect php version, I worked on one of the forums and saw it myself.  Have you run phpinfo?  File attached.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #8 on: October 05, 2017, 01:15:35 AM »
There have been at least two reports of cpanel reporting incorrect php version, I worked on one of the forums and saw it myself.  Have you run phpinfo?  File attached.

Just ran it:
PHP Version 5.3.29
Is there  anything else from that page thats needed?
Just sent my host support an ticket  host that cpanel is reporting the wrong version of PHP?
« Last Edit: October 05, 2017, 01:27:09 AM by Nodaz »

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,041
    • Arantor on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #9 on: October 05, 2017, 03:27:49 AM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #10 on: October 05, 2017, 04:14:10 AM »
... but even if that is the problem, I like to turn logging on for all things php  (tiny site here) so I never get that unpleasant blank screen.

now that I trap all errors, I'm a happy man ... your situation may vary but it's good to have more logging than less as you can always turn that off once your environment is more stable.
how do i turn that on and how does it prevent the white screen?

since you asked, I went through /etc/php.ini and turned all the logging values on and restarted httpd/apache.

the values I set on are for development so that's why it's not recommended. I need high visibility as I run many mods, upgrade them and have to deal with conflicts and bugs.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #11 on: October 05, 2017, 04:27:09 PM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.
Yes, found ity, PHP is now correct.
BUT
When i attempted the update, i was told to uninstall it as it was already installed, i tried that and am told that the uninstaller does not exist, i must have deleted the package  in this mess.
How do i rectify this?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #12 on: October 05, 2017, 04:33:21 PM »
You shouldn't have to update again, forum should be at 2.0.14.  The update installs correctly in php 5.3, it just doesn't run after installation.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #13 on: October 05, 2017, 07:11:26 PM »
You shouldn't have to update again, forum should be at 2.0.14.  The update installs correctly in php 5.3, it just doesn't run after installation.

Its not, still shows 2.0.13 after updating PHP, it shows 2.0.14 as installed and current  is now set to PHP: 5.5.38, 2.014 does not show in the downloaded packages.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #14 on: October 05, 2017, 07:26:18 PM »
can you attempt an uninstall 2.0.14 ?

get to the point where you can back out and see if there are any errors stopping you from committing ? any errors seen would provide some useful diagnostics.

I have uninstalled 2.0.14 and then reinstalled it on my test system without any problems.

once any patch is applied, all it takes is a page reload  for the new version to show at the bottom of your page. if the patch is truly on then you may have a caching issue.

I wait for my host to take my regular system image backup BEFORE I make system changes. I have had my system reimaged before and it's a godsend.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #15 on: October 05, 2017, 07:45:10 PM »
can you attempt an uninstall 2.0.14 ?

get to the point where you can back out and see if there are any errors stopping you from committing ? any errors seen would provide some useful diagnostics.

I have uninstalled 2.0.14 and then reinstalled it on my test system without any problems.

once any patch is applied, all it takes is a page reload  for the new version to show at the bottom of your page. if the patch is truly on then you may have a caching issue.

I made an attempt to uninstall, but tells me it is unable to continue:

An Error Has Occurred!
This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

the 2.0.14 package shows in package downloads and 2.0.14 show under installed packages. 

"Browse packages" shows 2.0.14 but doesn't show it installed (list files /Delete are only options)
But under
"Installed Packages" it does show as installed.
« Last Edit: October 05, 2017, 08:28:26 PM by Nodaz »

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #16 on: October 05, 2017, 08:47:43 PM »
I am not SMF support and this is issue arises from time to time.

the only thing I can suggest is that you emulate 2.0.14 (Advanced link at the bottom of the Browse Packages) page and try again.

I'm sure some real support will drop by and help you soon.  worst case, you may lose your mods after a system refresh. and will have to install them so go to Installed Packages and note the order that you installed them - it will go from latest to oldest.
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #17 on: October 05, 2017, 11:48:55 PM »
I saw this once recently.  Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.  Not on my computer, can't find previous topic, but believe that's what we ended up doing.


Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #18 on: October 06, 2017, 07:34:49 PM »
There's probably a version selector somewhere in your cPanel so you can switch it to PHP 5.6 - it definitely has it available but a lot of hosts have it set to older versions.

the PHP issue is resolved as i know how to change it, this issue now is this:
when i try to uninstall
I made an attempt to uninstall, but tells me it is unable to continue:

An Error Has Occurred!
This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information.

the 2.0.14 package shows in package downloads and 2.0.14 show under installed packages.

"Browse packages" shows 2.0.14 TWICE  but doesn't show it installed (list files /Delete are only options)


But under
"Installed Packages" it does show as installed.


But if i try to uninstall it from here i am told there is no uninstaller...

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,106
  • Gender: Male
    • Kindred-999 on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #19 on: October 06, 2017, 09:55:02 PM »
Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #20 on: October 06, 2017, 10:05:05 PM »
Nodaz, i think you got into this mess by not restoring your database at the same time you restored your files.

if so, can you possibly go back and restore the 2 in sync ?

both the files and DB must be handled as one unit for most recovery operations.

of course, i could be wrong.



SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #21 on: October 06, 2017, 11:00:18 PM »
It isn't necessary to restore the database when reverting from 2.0.14 to 2.0.13, whether uninstalling the patch with package manager, or restoring the package backup.  This was a one-off, didn't have access to the account first time, now it's happened again.  Don't know what causes the glitch, but uploading clean 2.0.14 files should fix it.

Offline aegersz

  • Sophist Member
  • *****
  • Posts: 1,117
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: Update to 2.0.14 successful then white/blank screen
« Reply #22 on: October 06, 2017, 11:10:17 PM »
no, i meant that if he installed 2.0.14 and then restored some files only (from when the system was a 2.0.13) then the DB says that 2.0.14 is on but it isn't, hence possibly causing unpredictable issues.

or am i confused ?
SMF 2.0: 135+ mods installed (the full list can be seen at http://forum.drugs-and-users.org/index.php/topic,3301)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #23 on: October 06, 2017, 11:21:01 PM »
The _settings table contains smfVersion, but it apparently is ignored.  On my three forums running 2.0.13 and 2.0.14, the smfVersion value is 2.0.1, 2.0.2, 2.0.7.  index.php contains -

Code: [Select]

     $forum_version = 'SMF 2.0.14';


 but that reverts to .13 if patch is uninstalled or backup is restored.


Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 68,041
    • Arantor on GitHub
Re: Update to 2.0.14 successful then white/blank screen
« Reply #24 on: October 07, 2017, 02:01:36 AM »
So in the Packages folder you have two copies of 2.0.14, one of which can be deleted.
To assume is to hope that those who came before had the presence of mind and capacity to implement the dreams of those who would come after.

You either die a hero or live long enough to see yourself become the villain. It seems you have chosen which, and now I must do the same.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #25 on: October 07, 2017, 02:44:55 PM »
So in the Packages folder you have two copies of 2.0.14, one of which can be deleted.
Ok so i deleted one of them.
Now when i go to package manager and try to uninstall i am told
"Cannot find Package ! "
there is still an instance of 2.0.14 showing in "browse packages"

EDIT:
 i went back and the second instance is now there again...
SO, i go to installed packages and try to uninstall and now get :

This package cannot be uninstalled, because there is no uninstaller!

Please contact the mod author for more information."

Again

I dont understand why that happened.  Whe i look at the files in both instances it indicates they are both:

Files in archive smf_patch_2.0.14.tar.gz:

    package-info.xml (1629 bytes)
    proxy.php (5054 bytes)
    readme.txt (1474 bytes)
    smf_2-0-14_patch.xml (74005 bytes)
    Sources/Class-CurlFetchWeb.php (10954 bytes)



What is the simplest way to resolve this?
« Last Edit: October 07, 2017, 03:35:56 PM by Nodaz »

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #26 on: October 07, 2017, 03:50:54 PM »
Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #27 on: October 07, 2017, 05:20:19 PM »
Just upload 2.0.14 upgrade package, that should fix it.  And, yes, you'll have to reinstall mods.

So i downlaoded the package from the downloads page, then tried to upload it through the package manager and got this:


If i FTP in the packages folder i see this:


Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #28 on: October 07, 2017, 05:22:39 PM »
You can't do that with package manager.  You have to upload the files using ftp client or your host file manager.

https://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #29 on: October 07, 2017, 05:26:19 PM »
You can't do that with package manager.  You have to upload the files using ftp client or your host file manager.

https://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files

I just edited with a shot of my FTP, should i delete anything 2.0.14 related in the Packages folder before i start?

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #30 on: October 07, 2017, 05:29:08 PM »
You can't do that with package manager.  You have to upload the files using ftp client or your host file manager.

https://wiki.simplemachines.org/smf/How_to_upload_a_fresh_set_of_files

That link sends me to the download page for 2.0.13 i am presuming i should navigate to and find the large upgrade for 2.0.14?
The instructions seem to indicate i should be downloading and refreshing the current version.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #31 on: October 07, 2017, 05:32:47 PM »
Don't worry about /Packages files, uploading clean set of files has nothing to do with packages, other than that it removes all installed mods and gets you back to a clean install.

The wiki article needs an update.  Click the 'Download' link top of this page, it'll take you to 2.0.14 downloads.


Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #32 on: October 07, 2017, 05:38:30 PM »
ok, thanks for you patience>  should i dowmnload/upload the zip or the tar, i presumme to the Public_html folder?
Then extract that file in place and it will overwrite everything there?

Then this has me a little flumoxted:
Extract the archive to the forum's directory, making sure that you delete upgrade.php and all the upgrade-x.x.sql files, and overwrite index.php, the sources folder, and the themes folder. You can either use FTP or cPanel's File Manager. On your forum, if you have replaced the standard smiley files with your own and/or replaced the standard avatar files, you might want to refrain from uploading both the smileys and the avatars directory. Important Note: If you carried out the optional step, you should also upload the sources from the large upgrade archive before you reinstall any custom themes.
do i need to run anything after unzipping?

then delete those files after unzipping?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #33 on: October 07, 2017, 05:46:23 PM »
/public_html is your forum root, all of the directories/files in the upgrade package have to go there.  I've always downloaded the zip, unzipped, and uploaded everything via ftp.  Don't know what happens if you upload the zip and use file manager to unzip it in place, would guess you'll get a prompt whether you want to overwrite or not.  You don't need the upgrade scripts, they are used to upgrade the database, which is not necessary in your case, and they pose a security risk if left on the server.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #34 on: October 07, 2017, 05:49:44 PM »
/public_html is your forum root, all of the directories/files in the upgrade package have to go there.  I've always downloaded the zip, unzipped, and uploaded everything via ftp.  Don't know what happens if you upload the zip and use file manager to unzip it in place, would guess you'll get a prompt whether you want to overwrite or not.  You don't need the upgrade scripts, they are used to upgrade the database, which is not necessary in your case, and they pose a security risk if left on the server.

Ill upload them directly via FTP:


Ok Also here is a Screen Shot of my Public_Html directory, do you see anything there that can/should be be deleted (maybe left over from stuff)<
Im presuming extracting the archive will overwrite most files but leave stuff that is already there and not replaced)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,089
  • 'Tis the gift to be simple
Re: Update to 2.0.14 successful then white/blank screen
« Reply #35 on: October 07, 2017, 06:00:53 PM »
Assuming you already have good backups of all your files and database, I wouldn't delete anything unless forum had been hacked, just upload the clean files.  Anything left over from previously installed mods (looks like you have a gallery) won't cause any problems.  The database will still contain data/tables added by mods.  If you don't reinstall a mod, the data is ignored; if you reinstall a mod that's added stuff to the db (i.e., gallery), it should pick up where the previous mod install left off, so you don't lose anything.

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #36 on: October 07, 2017, 06:10:18 PM »
Assuming you already have good backups of all your files and database, I wouldn't delete anything unless forum had been hacked, just upload the clean files.  Anything left over from previously installed mods (looks like you have a gallery) won't cause any problems.  The database will still contain data/tables added by mods.  If you don't reinstall a mod, the data is ignored; if you reinstall a mod that's added stuff to the db (i.e., gallery), it should pick up where the previous mod install left off, so you don't lose anything.

Very good, thanks
I have backups through my host, but am going to run backups manually, download copies via FTP and  through the forum as well.
« Last Edit: October 07, 2017, 06:42:05 PM by Nodaz »

Offline Nodaz

  • Full Member
  • ***
  • Posts: 432
Re: Update to 2.0.14 successful then white/blank screen
« Reply #37 on: October 08, 2017, 05:33:36 PM »
Assuming you already have good backups of all your files and database, I wouldn't delete anything unless forum had been hacked, just upload the clean files.  Anything left over from previously installed mods (looks like you have a gallery) won't cause any problems.  The database will still contain data/tables added by mods.  If you don't reinstall a mod, the data is ignored; if you reinstall a mod that's added stuff to the db (i.e., gallery), it should pick up where the previous mod install left off, so you don't lose anything.

SUCCESS !!
FTP upload resulted in a working version of 2.0.14>
Thank you all for the help !