Advertisement:

Author Topic: Error Message  (Read 512 times)

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Error Message
« on: October 09, 2017, 09:49:59 AM »
One of the Admin. reported this error to me this morning. Sorry I do not understand what it means..

I am running 2.0.14 and i keep everything updated at ll times..

Version Information:
 Forum version: SMF 2.0.14 (more detailed)
 Current SMF version: SMF 2.0.14
 GD version: bundled (2.1.0 compatible)
 MySQL version: 5.6.36-cll-lve
 PHP: 5.6.31
 Server version: Apache

Here is the reported error:
The SELECT would examine more than MAX_JOIN_SIZE rows; check your WHERE and use SET SQL_BIG_SELECTS=1 or SET MAX_JOIN_SIZE=# if the SELECT is okay
File: /home/coffeeti/public_html/Sources/Search.php
Line: 1338

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.14, while your database is at version 2.0.12. The above error might possibly go away if you execute the latest version of upgrade.php.

Can someone explain, if I need do something here.

Thanks

Ron..

Offline shawnb61

  • Support Specialist
  • Jr. Member
  • *
  • Posts: 399
    • sbulen on GitHub
Re: Error Message
« Reply #1 on: October 09, 2017, 10:16:11 AM »
That is a generic error from mysql informing you that it cannot properly optimize/execute your query. 

First thing I would try is to do the database maintenance task, see if that helps.

Next thing I'd try is to confirm the presence of a search index under search settings.

If neither of those help, we should audit your indexes, just to confirm they're all there.
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #2 on: October 09, 2017, 10:23:13 AM »
That is a generic error from mysql informing you that it cannot properly optimize/execute your query. 

First thing I would try is to do the database maintenance task, see if that helps.

Next thing I'd try is to confirm the presence of a search index under search settings.

If neither of those help, we should audit your indexes, just to confirm they're all there.

generic error I can see..

maint. task, is this the one in the ACP of the board. I do this about once a week..


I do not understand what you mean with this one:  "confirm the presence of a search index under search settings."

How do I go about getting this done:  "we should audit your indexes, just to confirm they're all there."

Thanks for replying..shawn

Ron

Offline shawnb61

  • Support Specialist
  • Jr. Member
  • *
  • Posts: 399
    • sbulen on GitHub
Re: Error Message
« Reply #3 on: October 09, 2017, 10:30:58 AM »
You will find your search settings under admin | forum | search | search method.

If you don't have a search index, i suggest trying one.  Maybe your forum is growing and is at that point where it needs a search index.

More here:
https://wiki.simplemachines.org/smf/SMF2.0:Search_(admin)

Let's only audit your indexes if the above doesn't help.

Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #4 on: October 09, 2017, 10:49:20 AM »
You will find your search settings under admin | forum | search | search method.

If you don't have a search index, i suggest trying one.  Maybe your forum is growing and is at that point where it needs a search index.

More here:
https://wiki.simplemachines.org/smf/SMF2.0:Search_(admin)

Let's only audit your indexes if the above doesn't help.

OK I do have this in the Admin. Forum. I have attached three images for you to look at, see if I need changes:


Offline shawnb61

  • Support Specialist
  • Jr. Member
  • *
  • Posts: 399
    • sbulen on GitHub
Re: Error Message
« Reply #5 on: October 09, 2017, 12:01:25 PM »
Search Method...

You can read the online help there, but you basically have 2 options - fulltext or custom.  Fulltext is a smaller index, but sometimes doesn't perform as well.  Custom creates a larger index, performs better & generally has slightly better results. 

Warning - indexes are huge. 

I'd build/use the custom index unless you are completely worried about storage. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #6 on: October 09, 2017, 12:47:47 PM »
Search Method...

You can read the online help there, but you basically have 2 options - fulltext or custom.  Fulltext is a smaller index, but sometimes doesn't perform as well.  Custom creates a larger index, performs better & generally has slightly better results. 

Warning - indexes are huge. 

I'd build/use the custom index unless you are completely worried about storage.

I am not worried about storage..  Can you explain how I make a Custom Index

Thanks

Ron..

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,822
  • Too long in the wasteland
Re: Error Message
« Reply #7 on: October 09, 2017, 01:17:30 PM »
In Search Method click [create custom index], then check Custom index and save.

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #8 on: October 09, 2017, 01:29:25 PM »
In Search Method click [create custom index], then check Custom index and save.

I did this got a message to create a custom index. See image I posted.

But I did set it to Custom Index and clicked Saved

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,822
  • Too long in the wasteland
Re: Error Message
« Reply #9 on: October 09, 2017, 01:32:15 PM »
You have to create the index first, then save setting.  If you look at it now, you should see 'Custom index' checked.

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #10 on: October 09, 2017, 01:35:44 PM »
You have to create the index first, then save setting.  If you look at it now, you should see 'Custom index' checked.

Yes it is checked.. I have searched on the smf and internet how to make the Custom Index, and I an find anything on what I am to do to create this file..

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 6,822
  • Too long in the wasteland
Re: Error Message
« Reply #11 on: October 09, 2017, 01:39:34 PM »
Click on 'Custom index', the message pops up, close it, click on '[create custom index]', select index size, click 'Create', that creates the index.

Offline Oldcrow

  • Jr. Member
  • **
  • Posts: 264
  • Gender: Male
  • "One foot in the grave!"
    • Seniors Worldwide
Re: Error Message
« Reply #12 on: October 09, 2017, 01:49:58 PM »
Click on 'Custom index', the message pops up, close it, click on '[create custom index]', select index size, click 'Create', that creates the index.

Yes last time I posted, I went back and took a better look, Did this as you say, It is now creating a custom Index, sure does take some time doing it..

Thanks for the help, I sure appreciate it..

Glad to have you folks around..

Ron..