Advertisement:

Author Topic: SMF database update needed?  (Read 333 times)

Offline sck

  • Semi-Newbie
  • *
  • Posts: 89
SMF database update needed?
« on: October 10, 2017, 10:24:15 AM »
I recently transferred a forum to a new owner.   The forum is almost 10 years old and is running SMF 2.0.12 with no issues.  When the new owner started working with the site and the hosting company (GoDaddy) they were told that the server was outdated is no longer supported and needs to be updated (I am assuming they were referring to the sql database and not the actual server hardware as the hardware is GoDaddy's responsibility) .  Does this sound "right"?  if so, how hard is it to move the tables to a new database?  The forum only has a few minor mods installed but it does have 10 years of post 75K and 3.5k of members.   Neither the new owner or I are technical so much more than running a mod script or moving a file is pushing our ability.

because I don't own the site, I cant see the details of software (MySQL) versions.  I am just trying to help the new owner out.  GoDaddy told them they can do the upgrade but it would cost $$.  I just question if it is really needed or if it was just a tech that really didn't know SMF.

Comments appreciated.

 

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,100
  • 'Tis the gift to be simple
Re: SMF database update needed?
« Reply #1 on: October 10, 2017, 04:31:44 PM »
Actually, none of that makes sense, which is not unusual for GoDaddy.  A 2.0.12 database is current and shouldn't have any compatibility problems.  If you have admin access, go to Admin -> Support and Credits, post the version info.