Advertisement:

Author Topic: Upgrading from SMF 1.1.21 to 2.0.14  (Read 1113 times)

Offline ivanr

  • Semi-Newbie
  • *
  • Posts: 29
Upgrading from SMF 1.1.21 to 2.0.14
« on: November 04, 2017, 03:12:02 PM »
Hi,
I am looking to upgrade from 1.1.21 to 2.0.14 as I am starting see weird things not working properly in 1.2.21 and it was high time I upgraded anyway.

It was noted from another post on here that the PHP version had to be at least PHP5.4. I am on PHP5.3 at the moment

When/What is the best procedure to upgrade to PHP5.4 for a SMF 2.0.14 upgrade?

Is it;
1. upgrade to PHP5.4
2. Wait for the host make the PHP upgrade change.
3. Load the 2.0.14 package.
4. Run upgade.php

If someone could advise
Thanks
















Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,072
  • 'Tis the gift to be simple
Re: Upgrading from SMF 1.1.21 to 2.0.14
« Reply #1 on: November 04, 2017, 04:05:24 PM »
I believe 2.0.14 will upgrade correctly in php 5.3, but forum won't run.  You may be able to upgrade php version in your host control panel, otherwise ask host to do it.  They should upgrade your account at least to php 5.6, all lower versions are eol and not supported.  Best to wait until php is upgraded before upgrading forum.

Offline ivanr

  • Semi-Newbie
  • *
  • Posts: 29
Re: Upgrading from SMF 1.1.21 to 2.0.14
« Reply #2 on: November 05, 2017, 12:01:17 PM »
Thanks Sir Osis
Just the information I was after. I am able to upgrade to a higher PHP on the host myself so that is not a problem.