Advertisement:

Author Topic: cannot load main_block.png into Gimp  (Read 393 times)

Offline ClairDunn

  • Newbie
  • *
  • Posts: 3
cannot load main_block.png into Gimp
« on: November 18, 2017, 08:09:05 AM »
I have copied default theme to my own theme for safety and installed it. I am trying to follow the instructions given in the excellent article here:
https://wiki.simplemachines.org/smf/How_to_create_a_smf_theme

and on the second page of the instructions is this sentence:
In SMF 2.0 Curve one image is used to control the way your forum looks and it's called "main_block.png" which can be found at Themes/{your-theme}/cssimages/theme/ directory.

I do not have the /cssimages/ directory in my theme. And in the /css/ directory there are only two .css files. And in /images/ there is no main_block.png.

I can find it in /mytheme/images/theme/ BUT when I open it with Gimp I get this error: (note I have tried opening the same image in other themes and the error is always the same.) It's a longish msg. but the gist is "opening failed. File corrupted."

My SMF install appears to have been successful as I've managed to set up some basic configuration and have changed the background color on my forum's home page.

Anyone have any ideas -- this is a real showstopper at this point.

Thanks for any help.






Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,110
  • 'Tis the gift to be simple
Re: cannot load main_block.png into Gimp
« Reply #1 on: November 18, 2017, 02:53:02 PM »
Try opening it in a different image editor.  In default Curve, it's /Themes/default/images/themes/main_block.png.  If it loads correctly in Curve, there's nothing wrong with the file.  If not, upload a clean copy from the install or upgrade package.