Wondering if this will always be free?  See why free is better.

Main Menu

Tried for ages, still failing (phpBB 3.0.10 to smf 2.0.14)

Started by shnazzle, November 19, 2017, 05:17:39 PM

Previous topic - Next topic


As topic says;
I've tried for absolutely hours and hours and searched tons on here to no avail:

Undefined property: mysqli_result::$EOF in /xxxx/xxxxxx/public_html/smf/convert.php on line 2721
Notice: Undefined property: mysqli_result::$Fields in /xxxx/xxxxxxx/public_html/smf/convert.php on line 2725

Notice: Trying to get property of non-object in /xxxx/xxxxxxxx/public_html/smf/convert.php on line 2726

Fatal error: Call to undefined method mysqli_result::MoveNext() in /xxxx/xxxxxxxxxx/public_html/smf/convert.php on line 2731

It fails in convert_fetch_assoc() when it tries to look for $result->Fields, whcih doesn't exist in the object. The object does contain things likes num rows (11, which matches the number of Ranks) and fields (4). So it's reading in the table and finding applicable rows.

So, fails on the very first hurdle.

Any help would be greatly appreciated at this point before I just go in and write my own converter. Could have done that by now but there's a LOT to this great converter, so I didn't want to reinvent the wheel :(


I've made progress!

Having mysqli issues. I'm sure there's a very simple reason but for now, I've commented out all of the ADO and ODBC lines from convert_fetch_assoc and convert_fetch_row
Leaving only  return $smcFunc['db_fetch_assoc']($result);

Then there were a couple issues in the convert file (I may not have the latest one).

In Converting members:
- removed all substring pulls for msn/icq/aim/websites etc and replaced with '', as we don't use those fields anyway
- changed u.user_from to u.user_perm_from

In COnverting boards:
- change f.forum_posts to f.forum_posts_approved
- change f.forum_topics to f.forum_topics_approved

In Converting topics
- change t.topic_replies to t.topic_posts

Now it's busy converting posts. So far so good, about 1/5th through.

Tried logging in but it doesn't work. THe original admin password has also been removed. I've seen this covered before on here...