Advertisement:

Author Topic: Error package installation when installing 2.0.15 on top of 2.0.14  (Read 266 times)

Offline Robomcd

  • Semi-Newbie
  • *
  • Posts: 42
  • Gender: Male
    • Newcastles of the World Forum
I was not very active the last years, so a bit behind with updates.

Today I updated from 2.0.12 to 2.0.13. No problem.
Reloaded my forum, and updated from 2.0.13 to 2.0.14: fatal error with PHP. I figured out that my my websites were still running on an older PHP version, so updated to PHP 5.6.
Reloaded the forum, everything works perfect again.

Then tried to go from 2.0.14 to 2.0.15. It mentioned package was uploaded successfully, so I pushed install now, and got this message:

Error in Package Installation
At least one error was encountered during a test installation of this package. It is strongly recommended that you do not continue with installation unless you know what you are doing, and have made a backup very recently. This error may be caused by a conflict between the package you're trying to install and another package you have already installed, an error in the package, a package which requires another package that you don't have installed yet, or a package designed for another version of SMF. 


I deleted the downloaded 2.0.15, and through the update link from the email, downloaded the ..15 again. Same problem, same error message.

I have a very simple forum, no special tricks, and all 17 active packages/mods installed show a green "current version". Some mods I uploaded but not installed yet because at the time I was not sure I wanted that feature in the end.

Interesting is that the package 2.0.14 update is shown as "current version" and not as older version?

Any idea?

 

Offline Steve

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 3,940
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: Error package installation when installing 2.0.15 on top of 2.0.14
« Reply #1 on: December 04, 2017, 09:10:27 AM »
http://wiki.simplemachines.org/smf/Error_in_mod_installation

Also, if you have Stop Spammer installed, visit that mod's support thread for a fix.
Please do not PM me for support.

Offline Robomcd

  • Semi-Newbie
  • *
  • Posts: 42
  • Gender: Male
    • Newcastles of the World Forum
Re: Error package installation when installing 2.0.15 on top of 2.0.14
« Reply #2 on: December 05, 2017, 03:23:13 AM »
Thanks.

Stop Spammer was the culprit. I deleted it, installed 2.0.15, and now will try re-install stop spammer using the suggested edit. That whole thread is on this problem, but this quote sums it up nicely.

For anyone else trying here is the step by step guide.

Backup your SMF files, make a note of the Stop Spammer settings in Admin/Registrations/Settings

Put the site into maintenance mode.

Uninstall the Stop Spammer Mod

Install SMF 2.0.15

Edit the file on your server /Sources/ManageMembers.php

           find the string:-             if ($context['sub_action'] == 'query' && empty($_POST))
           replace with                   if ($context['sub_action'] == 'query' && !empty($_REQUEST['params']) && empty($_POST))

reinstall the Stop Spammer mod.

Off course I initially forgot to make back-ups, just did so. Today I will try reinstall stop spammer; too useful to miss.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,120
  • Gender: Male
    • Kindred-999 on GitHub
Re: Error package installation when installing 2.0.15 on top of 2.0.14
« Reply #3 on: December 06, 2017, 01:13:07 AM »
That is the incorrect edit.  Read the stop,spammer support thread for the correct one
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.