Advertisement:

Author Topic: Mi foro no conecta con SMF para ver actualizaciones, versiones, noticias, etc  (Read 1037 times)

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
Hola
Desde la última actualización de la BD mi foro no conecta con SMF. En todas las páginas en las que tiene que conectar, para ver últimas versiones, actualizaciones, noticias, etc, me sale un mensaje tipo

No puedes conectarte al último archivo de noticias de simplemachines.org.
Obteniendo información del soporte...
Intentando obtener los más recientes y populares paquetes de www.simplemachines.org [nofollow]...

y así cada vez que intenta conectar con simplemachines...

¿alguien sabe por qué puede ser? algo se ha perdido en la actualización de la BD que debe afectar a esto...

Offline Rock Lee

  • Sophist Member
  • *****
  • Posts: 1,211
  • Gender: Male
  • Digitalizando un nuevo mundo :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
¿En los log`s de errores aparece algo? generalmente es algun problema del host (algunas veces me ah pasado) pero en pasar de algunas horas se soluciona...


Saludos!
¡Regresando como cual Fenix! ~ Bomber Code © 2017
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
Lo de que no se pueda conectar con SMF puede ser por varias razones, como lo son que los servidores de SMF estén ocupados o con mucha carga y no resuelvan rápido la petición sobre las noticias. También puede ser que el host tenga restricciones sobre el cómo se cargan datos desde otras webs.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
Pues es que llevo días así con lo que no creo que sea por los servidores de SMF, y mi host siempre me lo ha cargado... Yo creo que con alguna de las actualizaciones algo se me ha quedado mal...

¿Sabéis dónde puedo mirar los logs de errores?

Offline Rock Lee

  • Sophist Member
  • *****
  • Posts: 1,211
  • Gender: Male
  • Digitalizando un nuevo mundo :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
Pues es que llevo días así con lo que no creo que sea por los servidores de SMF, y mi host siempre me lo ha cargado... Yo creo que con alguna de las actualizaciones algo se me ha quedado mal...

¿Sabéis dónde puedo mirar los logs de errores?

Las de tu host generalmente se encuentra en la carpeta www o html, se ve a simple vista. Sino lo de SMF debes ir a Centro de Administración » Registros » Log de Errores debería mostrarte cual es el problema.


Saludos!
¡Regresando como cual Fenix! ~ Bomber Code © 2017
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
Pues efectivamente me faltan ficheros.

Los errores que tengo es que no puede cargar los siguientes: latest-news.js, current-version.js, latest-packages.js
No se pudo cargar el archivo solicitado: latest-packages.js.

Los logs del hosting no he sido capaz de encontrarlos...

¿Sabéis en qué directorio deberían estar estos ficheros?
¿Qué hago? ¿Reinstalo el foro?

Offline Rock Lee

  • Sophist Member
  • *****
  • Posts: 1,211
  • Gender: Male
  • Digitalizando un nuevo mundo :D
    • BomberCode.Oficial on Facebook
    • RockLee-BC on GitHub
    • @Bomber_Code on Twitter
    • Bomber Code ~ La nueva era del conocimiento
Consulta con tu hosting si han hecho algún cambio recientemente, ya que no te marca lo de las versiones por no poder cargar el js ... Tienes ir a administración de archivos (file manager) y marcar la casilla que te deje ver los archivos ocultos (sino mal recuerdo) para te los muestre aun si con esto no te lo muestra es por que el hosting no tiene problemas sino SMF con no poder conectar a simplemachines para verificar el tema de la versión.


Saludos!
¡Regresando como cual Fenix! ~ Bomber Code © 2017
Ayudas - Aportes - Tutoriales - Y mucho mas!!!

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
Esos archivos no están en la instalación de SMF, se usan en el servidor de éste sitio para mandar las noticias y actualizaciones en la sección de Información del Panel de Administración, y esos se cargan directamente desde el servidor de SMF.

Si sigue pasando eso, ve al Panel de Administración, en la sección de Tareas Programadas, busca una que dice algo como "Recuperar archivos Simple Machines" y marca la segunda casilla, la que está en la columna de ejecutar, y al final de esa columna está el botón de Ejecutar, Ejecuta esa tarea y con eso debe recargar todo lo que usa desde éste sitio, y eso debe corregir los errores.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
Gracias, he ejecutado esa tarea pero nada, seguimos igual...

¿Si reinstalo el foro desde cero solucionaré algo?

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
No, reinstalar no hace nada con esos archivos, ya que no están en la instalación, están en los servidores de SMF y por alguna razón desde tu foro, o el host donde está, está bloqueada la comunicación con SMF o parte del sitio.

¿Dónde tienes alojado tu foro?
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
en nominalia...

pero es que me resulta muy raro que sea cosa del host porque se ha estropeado al hacer la actualización...

pero voy a abrir otra incidencia...

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
¿La actualización la hiciste a través de el gestor de paquetes?

Si es así, puedes desinstalar la actualización y verificar que sin la actualización no se te generan esos errores y carga todo como es debido. Si todo se instaló sin errores debe desinstalarse sin errores. Si se corrige la falla, entonces si podemos decir que es cosa de la actualización, pero por lo que he revisado en otros foros que tengo acceso, no me aparece ningún error parecido sobre los archivos .js desde www.simplemachines.org

Si la actualización la hiciste por otro método, va a ser mas complicado revertir el proceso para probar lo que menciono antes.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
sí que la hice por el gestor de paquetes...
me recomiendas entonces que haga marcha atrás? pues lo intento...

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
lo he desinstalado y sigue igual...

estoy a la espera de que nominalia me conteste (espero que a partir de mañana...), porque estoy convencida de que es algo de ellos...

muchas gracias, ya os contaré!

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
Es lo que decía, si no hay cambio con la actualización instalada o desinstalada, es cosa del host, porque puede ser que por configuraciones de seguridad impidan la ejecución de scripts de ciertos sitos.

Puedes volver a instalar la actualización sin problemas y esperar a ver que te dicen los del host.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
hola otra vez
ya tengo la respuesta del host...

A nivel de Hosting hemos revisado todos los parámetros y configuraciones entre el dominio y el Hosting y no hemos detectado incidencia la cual pueda estar afectando en cuanto a su funcionamiento. Además, le informamos que a nivel de plataforma, no se han cambios los cuales puedan perjudicar el funcionamiento de las distintas páginas web que podamos estar alojando.

vamos, que se lavan las manos...

me sugieren que vuelva a una versión anterior (que funcionara), pero eso ya lo he hecho...
la verdad es que estoy ya un poco desesperada...
alguna sugerencia más?

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
En un directorio diferente, o en un subdominio, instalar otra copia de SMF (en una base de datos diferente) para ver si ahí funciona correctamente, y si lo hace, ir instalando los temas y MODs para ver si hace lo mismo.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
ok, voy a ir haciéndolo poco a poco...
aunque creo que ya será a la vuelta de vacaciones

gracias!! ya te contaré

Offline xiqueta

  • Semi-Newbie
  • *
  • Posts: 24
y cómo hago lo de que sea en una BD diferente?
tendré que partir de un backup de la mía, y al final será la misma...



Offline Dhayzon

  • Sophist Member
  • *****
  • Posts: 1,105
  • Gender: Male
  • DhayZone RevolutioN
    • Dhayzon on GitHub
    • @dhayzon on Twitter
    • http://dhayzon.com/
eso me pasaba cuando monte smf en un servidor propio a veces suele ser solo el permiso a ciertos archivos,  nunca supe a que archivos hay q agregarle los permisos ya que en ese entonces me dio flojera. pero me parece que es cuestion de probar

Offline Gluz

  • Local Moderator
  • Sr. Member
  • *
  • Posts: 983
  • Gender: Male
Deberás revisar tu paquete de hosting, hay algunos que si permiten la creación de otras bases de datos, hay otros que no permiten la creación de nuevas pero ya tienen un número fijo de bases creadas por cuenta, y hay otros que solamente permiten el uso de una sola.

En caso de que sea una sola hay que estar pendiente de que al momento de instalar, el prefijo de la base de datos (por defecto smf_) se cambie a otra cosa diferente (test_ por ejemplo) para así no tenga problemas con el foro que ya está instalado.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.