Advertisement:

Author Topic: About: 3 test failed for Installations actions for "SMF 2.0.15 Update"  (Read 192 times)

Offline ninik

  • Semi-Newbie
  • *
  • Posts: 80
    • Ancient Greece Reloaded
Hi guys,

I would like to ask you a question:

I am considering to update-patch the forum from 2.0.14 to 2.0.15 but I receive 3 test failed in the following areas - and which are:

/Themes/default/Login.template.php

Code: [Select]
Code: (Find)
<input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" /><p class="centertext"><input type="submit" value="', $txt['login'], '" class="button_submit" /><input type="hidden" name="hash_passwrd" value="" />

Code: (Replace)
<input type="hidden" name="', $context['session_var'], '" value="', $context['session_id'], '" /><input type="hidden" name="hash_passwrd" value="" />



/Sources/SendTopic.php

Code: [Select]

Code: (Find)
if (filter_var($_POST['ryemail'], FILTER_VALIDATE_EMAIL) === false)

Code: (Replace)
if (filter_var($_POST['y_email'], FILTER_VALIDATE_EMAIL) === false)

/Sources/ManageMembers.php

Code: [Select]
Code: (Find)
if ($context['sub_action'] == 'query' && !empty($_REQUEST['params']) && empty($_POST))
$_POST += safe_unserialize(base64_decode($_REQUEST['params']));

Code: (Replace)
if ($context['sub_action'] == 'query' && empty($_POST))
{
if (!empty($_REQUEST['params']))
{
$_POST += safe_unserialize(base64_decode($_REQUEST['params']));
}
elseif ($context['browser']['is_ie'] && !empty($_SESSION['params']))
{
$_POST += $_SESSION['params'];
unset($_SESSION['params']);
}
}

Should I proceed with the installation? Should I do manual changes or should I do nothing?

PS: I am using the Adk prortal (which is this one: https://custom.simplemachines.org/mods/index.php?mod=2255) - although, I do not know if it plays a vital role in all of this, I just thought I should mention it.

PS 2: in all three failed tests I also receive the following:

Code: [Select]
Code: (Find)
* @version 2.0.14

Code: (Replace)
* @version 2.0.15

But even if I replace the versions manually the same error still appears.

In other words, instead of seeing for example @ version 2.0.14 I only see that:  @version 2.0.



Any suggestions are more than welcome.

Thank you in advance guys...
« Last Edit: December 12, 2017, 12:38:54 PM by ninik »

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 55,280
  • Gender: Male
    • Kindred-999 on GitHub
Re: About: 3 test failed for Installations actions for "SMF 2.0.15 Update"
« Reply #1 on: December 12, 2017, 04:49:19 PM »
well, as with any mod, it just means that you have to manually edit those code because some other mod has already changed it.

Sepcifically, in the last case - the stop spammer mod.
instructions and support for that mod and the change needed are in the support thread of the stop spammer mod.
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline ninik

  • Semi-Newbie
  • *
  • Posts: 80
    • Ancient Greece Reloaded
Re: About: 3 test failed for Installations actions for "SMF 2.0.15 Update"
« Reply #2 on: December 12, 2017, 08:18:51 PM »
Hi Kindred,

thank you for the clarifications... I managed to install the new patches after I had to go through some manual editing... uninstalling a mode, installing the patches... re-installing the mod.

But, all OK now...

I thank you  :)