Advertisement:

Author Topic: Forum is down  (Read 1615 times)

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Forum is down
« on: December 24, 2017, 01:06:01 PM »
In trying to fix a problem with forum users suddenly being unable to either post or view attachments, I've now made the forum non-accessible. 
The following error message now appears when trying to access the forum:  Fatal error: require_once() [function.require]: Failed opening required '/home/content/55/3007655/html/simplemachinesforum/Sources/Subs-Auth.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/55/3007655/html/simplemachinesforum/Sources/Security.php on line 535 

I would greatly appreciate any help you can offer.


Bill

Offline SaltedWeb

  • Sr. Member
  • ****
  • Posts: 861
  • Gender: Male
  • The Tired One
Re: Forum is down
« Reply #1 on: December 24, 2017, 01:10:24 PM »
Sounds like a permission on a file changed ? I would start there and see if the permissions are correct.
Knowing your limitations makes you human, exceeding these limitations makes you worthy of being human.

Offline Shambles

  • SMF Hero
  • ******
  • Posts: 5,208
  • Gender: Male
    • i30 Owners Club
Re: Forum is down
« Reply #2 on: December 24, 2017, 01:17:00 PM »
I would say the Subs-Auth.php file has been deleted -  most likely by your host's security scans.

Have a look in the /Sources folder and see if it's there,

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #3 on: December 24, 2017, 01:30:33 PM »
That file is indeed missing.  How should I proceed?

Offline br360

  • Support Specialist
  • SMF Hero
  • *
  • Posts: 2,398
    • GenXcommunity
Re: Forum is down
« Reply #4 on: December 24, 2017, 01:50:30 PM »
If you don't already have a copy; download the smf version you have to your computer, extract the package and then upload Subs-Auth.php back to where your other source folders are. Then open a ticket with your host explaining what they did and make sure they know not to delete the file again.


Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,583
Re: Forum is down
« Reply #5 on: December 24, 2017, 02:15:53 PM »
If you don't already have a copy; download the smf version you have to your computer, extract the package and then upload Subs-Auth.php back to where your other source folders are. Then open a ticket with your host explaining what they did and make sure they know not to delete the file again.



you may need to upload the file with your hosts file manager rather then FTP to make it say in place.

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #6 on: December 24, 2017, 02:29:09 PM »
Here's the result after I uploaded the file:  Fatal error: require_once() [function.require]: Failed opening required '/home/content/55/3007655/html/simplemachinesforum/Sources/Subs-Auth.php' (include_path='.:/usr/local/php5/lib/php') in /home/content/55/3007655/html/simplemachinesforum/Sources/Security.php on line 543

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,583
Re: Forum is down
« Reply #7 on: December 24, 2017, 02:51:10 PM »
did you upload it with your hosts file manager?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,469
Re: Forum is down
« Reply #8 on: December 24, 2017, 03:21:41 PM »
On GoDaddy servers, if you upload source files via ftp, upload will be successful but file will immediately be deleted.  If you watch carefully, you can see it happen.  This can affect up to a dozen source files.  You can upload the file using cpanel file manager and it will stick.  I've only seen this on GD, but a couple of recent posts indicate it may be happening on other hosts.

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #9 on: December 24, 2017, 05:44:51 PM »
I uploaded the file using GoDaddy's file manager.  The forum will now come up, but when I try to log in, I get this error message:  Fatal error: Call to undefined function safe_unserialize() in /home/content/55/3007655/html/simplemachinesforum/Sources/Subs-Auth.php on line 114

Offline SaltedWeb

  • Sr. Member
  • ****
  • Posts: 861
  • Gender: Male
  • The Tired One
Re: Forum is down
« Reply #10 on: December 24, 2017, 06:14:54 PM »
Not that its any fault of SMF, but seems that GD is consistently causing issues with this software.
Make one wonder if it should not be recommended at that not unless they just do this no matter what program they have installed. ( sorry didnt mean to Hijack the post seems allot of GD have issues)
Knowing your limitations makes you human, exceeding these limitations makes you worthy of being human.

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #11 on: December 24, 2017, 06:33:08 PM »
I was wondering if upgrading to a newer version would correct all of the errors in my forum.  I can't log on as an administrator at this time.  My website is culvercadet.com and there's a link there to the forum.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 58,617
  • Gender: Male
    • Kindred-999 on GitHub
Re: Forum is down
« Reply #12 on: December 24, 2017, 07:41:57 PM »
sounds like you might not have uploaded a current version of the file...   or you uploaded the 2.0.15 version and you are not actually running 2.0.15
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #13 on: December 28, 2017, 10:58:12 AM »
I seem to have everything working except for this error message: The default theme's directory is wrong, please correct it by clicking this text.     I can't seem to resolve this issue.  Any ideas?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 51,583
Re: Forum is down
« Reply #14 on: December 28, 2017, 11:01:06 AM »
What is repair_settings.php? should fix that for you.

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #15 on: December 28, 2017, 02:41:56 PM »
I've now managed to create a new problem by changing one of the database settings in the repair_settings tool.  I now get this message when I try to run repair settings:   Fatal error: Call to undefined function () in /home/content/55/3007655/html/simplemachinesforum/repair_settings.php on line 368

Warning: Unknown: open(/home/content/55/3007655/tmp/sess_2er7q4arga7240tjne152mkg55, O_RDWR) failed: No such file or directory (2) in Unknown on line 0

Warning: Unknown: Failed to write session data (files). Please verify that the current setting of session.save_path is correct () in Unknown on line 0

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,469
Re: Forum is down
« Reply #16 on: December 28, 2017, 03:24:18 PM »
Why did you change a db setting?  Which one?

Offline shawnb61

  • Developer
  • SMF Hero
  • *
  • Posts: 1,583
    • sbulen on GitHub
Re: Forum is down
« Reply #17 on: December 28, 2017, 03:29:35 PM »
To me, that looks like 'Enable DB Sessions' was disabled.  Two thoughts: 

First, I would suggest re-enabling it.   

Second, I would suggest talking with your host to determine why /tmp isn't configured/working properly. 
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline billpoynter

  • Newbie
  • *
  • Posts: 8
Re: Forum is down
« Reply #18 on: December 28, 2017, 03:45:10 PM »
Is it possible that I could give someone access to the site so that they can determine what I have done to it?  I think that the original problem was caused by GoDaddy, but I have only made it worse.  I take one step forward and two back.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 9,469
Re: Forum is down
« Reply #19 on: December 28, 2017, 03:56:20 PM »
PM your username/password for GD account and I'll have a look.