Advertisement:

Author Topic: GoDaddy Upgrade from 2GH to 4GH Linux Hosting Caused Database Connection Error  (Read 6831 times)

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
 
Hello all you amazing SMF Wizards!  I need your help!!

GoDaddy just migrated from 2GH Linux hosting to 4GH Linux Hosting and my SMF forum went down.. 12+ years of content and conversation, gone in a poof I had no control over.  Reeeeeeally hopeful someone knows how to get it back online.    :'(

SimpleMachines 1.1.21 is known to have issues with php 5.6, so I downgraded to 5.4 (last time it worked was 5.2 under 2GH). PHP 5.4 supposedly works with SMF 1.1.21 - does it not?

Could a CHMOD perhaps be needed because 4GH defaults for files and folders may be different then they were under 2GH?  Or would those not change as a result of the upgrade? I made amazing progress just by doing a Save As on a file in UTF-8 instead of ANSI as you'll see below, so I've learned not to overlook the simple stuff.

Oh, and I would prefer NOT to upgrade to SMF 2.0.x if at all poss and lose all custom mods - plus I keep reading about nothing but problems with this upgrade if not done from within SMF, which is unfortunately no longer an option.

Forum link: http://www.fx-knight.com/smForum/index.php


Error we are getting:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


Their tech suspected the issue might be the syntax of the $db_server path in the settings.php file..

Used to be:
dbname.db.3857732.hostedresource.com

GoDaddy suggested new ones to try are:
grid55mysql277.secureserver.net
shr.prod.phx3.secureserver.net

But.. perhaps unlike WordPress, Simple Machines likes db name to be part of the path as it was originally?
What would be the correct syntax starting with dbname.. and ending with ..secureserver.net?

(This is something that seems to be SMF-specific, what it likes to see here, so the GoDaddy tech didn't want to assume that what works for Word Press would also work for SMF.)


Next, we noticed the settings.php file was being saved as ANSI
Changing to encoding to UTF-8 and doing a Save As generated the following:

Warning: Cannot modify header information - headers already sent by (output started at /home/content/32/3857732/html/_fxK2/smForum/Settings.php:1) in /home/content/32/3857732/html/_fxK2/smForum/Sources/Subs-Auth.php on line 346

Warning: Cannot modify header information - headers already sent by (output started at /home/content/32/3857732/html/_fxK2/smForum/Settings.php:1) in /home/content/32/3857732/html/_fxK2/smForum/Sources/Subs-Auth.php on line 347

Warning: Cannot modify header information - headers already sent by (output started at /home/content/32/3857732/html/_fxK2/smForum/Settings.php:1) in /home/content/32/3857732/html/_fxK2/smForum/Sources/Subs-Auth.php on line 348

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


These are the lines of code in question from /Sources/Subs-Auth.php:

   // Don't cache this page!
   header('Expires: Mon, 26 Jul 1997 05:00:00 GMT');
   header('Last-Modified: ' . gmdate('D, d M Y H:i:s') . ' GMT');
   header('Cache-Control: no-cache');


So... could it be that 4GH doesn't like the date format 2GH used to use on the headers?
Although.. the error above seems to suggest we already have headers coming from elsewhere?

Really hopeful this gives someone out there a lead on what is causing the database connection error..


Here are the contents of the settings.php file:

########## Forum Info ##########
$mbname = 'fxKnight';      # The name of your forum.
$language = 'english';      # The default language file set for the forum.
$boardurl = 'http://fx-knight.com/smForum';      # URL to your forum's folder. (without the trailing /!)
$webmaster_email = 'support@fxKnight.com';      # Email address to send emails from. (like noreply@yourdomain.com.)
$cookiename = 'fxKnight923';      # Name of the cookie to set for authentication.

########## Database Info ##########
$db_server = 'dbname.db.3857732.hostedresource.com';
$db_name = 'dbname';
$db_user = 'user';
$db_passwd = 'password';
$db_prefix = 'smf_';
$db_persist = 0;
$db_error_send = 1;

########## Directories/Files ##########
# Note: These directories do not have to be changed unless you move things.
$boarddir = '/home/content/32/3857732/html/_fxK2/smForum';      # The absolute path to the forum's folder. (not just '.'!)
$sourcedir = '/home/content/32/3857732/html/_fxK2/smForum/Sources';      # Path to the Sources directory.

 

Any help would be GREATLY appreciated, and I cannot tell you in words how grateful I am for your knowledge & expertise!

-=Andrei 

« Last Edit: January 02, 2018, 01:21:09 AM by andrei23 »

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,215
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Don't post your settings file. Please remove your login information.

Your best best is contact their support. And or look at the phpmyadmin area in your godaddy hosting for the connection string you should be able to see the database.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
User/pass was obviously not included  :)

I have been back and forth with their support, and have gotten about as far as I believe I can with them. They are now saying it's a content issue, not hosting - even though content hasn't changed since everything worked prior to their migration.

They simply do not know enough about SMF.. which is why I came here hoping to find people who know more.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Hello all you amazing SMF Wizards!  I need your help!!

GoDaddy just migrated from 2GH Linux hosting to 4GH Linux Hosting and my SMF forum went down.. 12+ years of content and conversation, gone in a poof I had no control over.  Reeeeeeally hopeful someone knows how to get it back online.    :'(

See a similar case: Connection problems again! (GoDaddy Host)

SimpleMachines 1.1.21 is known to have issues with php 5.6, so I downgraded to 5.4 (last time it worked was 5.2 under 2GH). PHP 5.4 supposedly works with SMF 1.1.21 - does it not?

SMF 1.1.x incompatibility with recent PHP versions (PHP5.5+)

Could a CHMOD perhaps be needed because 4GH defaults for files and folders may be different then they were under 2GH?  Or would those not change as a result of the upgrade? I made amazing progress just by doing a Save As on a file in UTF-8 instead of ANSI as you'll see below, so I've learned not to overlook the simple stuff.

The database or the database login should have no effect, specially on linux hosts the character set of the settings files, and the editor used to edit them, may have affect. File permissions should not easily become a problem, and I think problems like that would manifest themselves differently.

Oh, and I would prefer NOT to upgrade to SMF 2.0.x if at all poss and lose all custom mods - plus I keep reading about nothing but problems with this upgrade if not done from within SMF, which is unfortunately no longer an option.
You cannot upgrade from 1.x to 2.x within SMF, so I don't know what you have been reading.
Upgrading SMF

Forum link: http://www.fx-knight.com/smForum/index.php

Error we are getting:

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


Their tech suspected the issue might be the syntax of the $db_server path in the settings.php file..

Used to be:
xx.hostedresource.com

GoDaddy suggested new ones to try are:
xx.secureserver.net
xxx.secureserver.net

But.. perhaps unlike WordPress, Simple Machines likes db name to be part of the path as it was originally?
What would be the correct syntax starting with fxb072.. and ending with ..secureserver.net?
That would be whatever is your hosts database address, not in anyway specific to SMF, and the DB name does not need to be there.

---

BACKUP your current settings.php and settings_bak.php, replace them with these ( these are empty from the installation package ) and correct the settings using repair_settings. (Do NOT manually edit them.) There may be something wrong with your settings.php judging from the non-db errors.

What is repair_settings.php?

You will need to do this "twice". First correct the database information and save, then all the rest of the settings and save again.
« Last Edit: January 02, 2018, 01:40:19 AM by Aleksi "Lex" Kilpinen »
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
Really helpful info, Aleksi - THANK YOU!

I have read both of the threads you have referenced prior to posting.  The first one seemed to have additional issues going on beyond what I am experiencing, due to moving his installation to a new folder, and upgrading from SMF 1.x to 2.x, and the second one I have verified I am compatible.. my host is running PHP 5.4 and MySQL 5.5 (SMF 1.1.21 should work with both according to the article).

I have followed your instructions carefully in regards to Settings.php and the repair tool and alas, same issue persists. Cannot connect to the database. So we can rule out paths, I guess. 

Back to what other differences there might be between 2GH Linux hosting and 4GH that offend SMF or might prevent it form connecting to its database?

Or how about the headers error referenced in /Sources/Subs-Auth.php ?  Perhaps 4GH uses a different date format that SMF doesn't like?

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Or how about the headers error referenced in /Sources/Subs-Auth.php ?  Perhaps 4GH uses a different date format that SMF doesn't like?
That was actually what I was hoping to fix by having you replace the settings files. Now, I am surprised to see the errors there still.
Did you edit any other php files right before this started?

Could you attach your Subs-Auth.php here?
« Last Edit: January 02, 2018, 02:30:17 AM by Aleksi "Lex" Kilpinen »
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,942
  • 'Tis the gift to be simple (duh)
GoDaddy has trashed several forums as they're migrating to new servers.  I was able to recover one, another had its database destroyed with no backups.  Do you have a good recent db backup?  If not, ask GD support for a dump while they still may be able to find the db.  If you have the db, open an account with a different host, do a clean 1.1.21 install, upgrade to 2.0.15.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
I wouldn't be ready to say anything about the DB just yet, I would like to see us get those errors cleared first and see if the DB actually functions.

Other than that, getting away from GoDaddy is a good advice.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,942
  • 'Tis the gift to be simple (duh)
GoDaddy's servers have the bad habit of deleting up to a dozen source files, one of them being Subs-Auth.php, when uploaded via ftp.  Wouldn't surprise me if same thing happened when they migrated this forum.  Source files must be uploaded with cpanel file manager.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
I'm fairly sure the file is there, but that - or some other settings related file has some problems, most probably contents before the opening tag or after the closing tag, such as UTF8 Byte Order Mark in the beginning of the file...

This based on the Warning: Cannot modify header information - headers already sent by Settings.php, in Subs-Auth.php on line 346.
So the file is there, and it is tripping errors for some reason.
« Last Edit: January 02, 2018, 04:43:25 PM by Aleksi "Lex" Kilpinen »
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,942
  • 'Tis the gift to be simple (duh)

Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later.


Their tech suspected the issue might be the syntax of the $db_server path in the settings.php file..

Used to be:
dbname.db.3857732.hostedresource.com

GoDaddy suggested new ones to try are:
grid55mysql277.secureserver.net
shr.prod.phx3.secureserver.net


Ask them for an ip address.  It's my understanding from the forum I recovered that it can take a while for new server address to propogate.

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
Subs-Auth.php is there, Sir Osis - I went to check it when the new error occurred. But I did notice the effect you are referring to when I tried making a duplicate copy of the forum for testing. That file wasn't in the 2nd version, and I tried repeatedly to move it using FileZilla with no avail. Using their cpanel was the only way.  One would HOPE they used a more direct method for their migration. Though I suspect they did, because Subs-Auth.php was indeed there when I first went to look for it.

Aleksi - no files were modified on my end between the forum working and not. It went down with the migration, but that was also understandable as the 2GH server was on PHP 5.2, meanwhile the new 4GH server was running PHP 5.6, which we know to be incompatible with SMF 1.1.21

Could it be that temporarily existing within, and trying to execute within, a PHP 5.6 environment somehow damaged or corrupted any of the files?  So by the time a rolled back to PHP 5.4 the damage was already done?  Do we have any info on WHY the forum doesn't work with 5.6?  That might help us figure out where to look.  Just a thought.

The database itself seems to be sound and uncorrupted.  The GoDaddy tech had a look at it.  But if there is a tool for checking it I'm open to it.. I have extra copies of it, both online and locally.  I can always put one up for you to play with and send you a URL, if that's helpful in diagnosis?

Where might I find the installation files for 1.1.21?  Trying a fresh install might not be a bad idea.. we could determine IF that version can even run in the new 4GH environment. If not, no sense in looking for a corrupt file or line of code in my version, I suppose?

Any other ideas for a next step or things to try?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,942
  • 'Tis the gift to be simple (duh)
Not on my computer, can't post the link, but click 'Download' in top menu, then 'Archived Releases' to find 1.1.21 package.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,502
  • Gender: Male
    • Kindred-999 on GitHub
If they moved your server, then all of the for7m paths have changed.
Also, given go daddy’s general incompetence, I can pretty much guarantee that the address of your MySQL database has also changed... which would explain the connection problems

You need to run repair_settings.php and reset the database connection information. And then reset the paths for the forum
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Could it be that temporarily existing within, and trying to execute within, a PHP 5.6 environment somehow damaged or corrupted any of the files?  So by the time a rolled back to PHP 5.4 the damage was already done?  Do we have any info on WHY the forum doesn't work with 5.6?  That might help us figure out where to look.  Just a thought.
The different PHP version should not really cause any corruption in files, Settings.php is pretty much the only file that 1.1 edits on it's own without user interaction - and the Warning seen before your database error would suggest a file problem IMO.
That, and the warning referencing both settings.php and subs-auth.php were the reasons I started from them.

The database itself seems to be sound and uncorrupted.  The GoDaddy tech had a look at it.  But if there is a tool for checking it I'm open to it.. I have extra copies of it, both online and locally.  I can always put one up for you to play with and send you a URL, if that's helpful in diagnosis?

Where might I find the installation files for 1.1.21?  Trying a fresh install might not be a bad idea.. we could determine IF that version can even run in the new 4GH environment. If not, no sense in looking for a corrupt file or line of code in my version, I suppose?
Trying a fresh install on the new setup might not be a bad idea, but I do think 1.1 should work there as long as the database works, and you keep the PHP version below 5.5.

If they moved your server, then all of the for7m paths have changed.
Also, given go daddy’s general incompetence, I can pretty much guarantee that the address of your MySQL database has also changed... which would explain the connection problems

You need to run repair_settings.php and reset the database connection information. And then reset the paths for the forum
This was the first thing we tried, and either the settings.php did not get updated correctly, or the database information used is wrong, or something else is amiss, since this didn't seem to have any effect on the situation...
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,502
  • Gender: Male
    • Kindred-999 on GitHub
I am betting that the database information that they provided is incorrect.

that was the case when one of the sites I support moved hosting within GoDaddy...     it took moving to level 3 support at GoDaddy to get the correct details
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
I tried both the database path listed in phpMyAdmin and the one used by my other WordPress sites that DO work in the new hosting environment, both generated the same error. (What I tried  is documented in my 1st post above.) The absolute paths for both SMF install  folder and /Sources came from cpanel - pretty confident in all 3 paths, but perhaps the SYNTAX is incorrect? Like should I preface with server IP or anything? Seems to be these “absolute” paths are still relative, as they start with / .. however, as I said, my other WordPress sites that went through this same migration all find their databases, just SMF seems lost..

(I will be traveling the next 4 days, so my ability to try things will be limited.. but I will very much be reading, so please keep the ideas coming on what it might be or what I should try. I am extremely grateful for your help!!)

Offline andrei23

  • Semi-Newbie
  • *
  • Posts: 29
  • Gender: Male
    • fxKnight.com
Any tools out there to check database integrity? GoDaddy tech told me it “looked” ok, butboerhaps SMF needs it to be a certain way. Could anything have changed as part of 2GH to 4GH migration?

How about CHMOD settings for files and folders? When moved to a new server, to they normally keep their settings, or inherit them from the new server? Any way to check what they are? I only know CHMOD to change them, but not check what they are already..

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,942
  • 'Tis the gift to be simple (duh)
I am betting that the database information that they provided is incorrect.

that was the case when one of the sites I support moved hosting within GoDaddy...     it took moving to level 3 support at GoDaddy to get the correct details

I've seen this as well, GD support is bull******ting their customers.  Best way to check database integrity is connect it to a clean install.  If your account is too screwed up to do this, pm your db credentials and I'll connect to it with a test install on my server.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,107
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Any tools out there to check database integrity? GoDaddy tech told me it “looked” ok, butboerhaps SMF needs it to be a certain way. Could anything have changed as part of 2GH to 4GH migration?

How about CHMOD settings for files and folders? When moved to a new server, to they normally keep their settings, or inherit them from the new server? Any way to check what they are? I only know CHMOD to change them, but not check what they are already..
In the off chance that the migration was done properly, nothing like that should become a problem - but when it's GoDaddy, your guess is as good as ours really. Sorry to say that.

What you could do to test this, is install a second forum from scratch (preferably using a different DB, or atleast a recognizable different prefix) and if everything works, then use repair_settings to switch that installation to use the old DB, to see if it still works or not.
« Last Edit: January 04, 2018, 04:48:24 AM by Aleksi "Lex" Kilpinen »
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas