Advertisement:

Author Topic: Error after 2.014 install - blocked from site - Error 500  (Read 2096 times)

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Error after 2.014 install - blocked from site - Error 500
« on: January 03, 2018, 01:41:36 PM »
I used the package manager to upgrade from 2.013 to 2.014.  It said all was successful but now all pages are blocked. 

"The package was installed successfully. You should now be able to use whatever functionality it adds or changes; or not be able to use functionality it removes."


www.sawmillandtimberforum.com

HELP! 

I have NO CLUE how to change anything on the server so anyone that can point me in the direction to fix this is greatly appreciated. 

Kirk Allen

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #1 on: January 03, 2018, 02:19:33 PM »
Looks like the server company got it working but not sure what they did but now have a new problem.

When I try to add a new forum board I get this message? 

Field 'board_color' doesn't have a default value
File: /home/kallen/public_html/Sources/Subs-Boards.php
Line: 790

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.14, while your database is at version 2.0.11. The above error might possibly go away if you execute the latest version of upgrade.php.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #2 on: January 03, 2018, 04:07:01 PM »
According to the server tech support:  "From the message it sounds like the software was updated but an upgrade script was not run (which will upgrade the database and anything else that needs to be done on the back end). Upgrading SMF is not a service that we provide."

Any suggestions how to upgrade script?

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,640
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #3 on: January 03, 2018, 04:17:35 PM »
You have to add a default to into the smf_boards table in the board_color column in the database structure that appears to be coming from a modification
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #4 on: January 03, 2018, 05:34:30 PM »
How do I go about doing that?

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,640
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #5 on: January 03, 2018, 05:49:38 PM »
Phpmyadmin would be the best or you can contact your host to make the change.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #6 on: January 03, 2018, 05:55:56 PM »
I found the smf_boards in Phpmyadmin but not sure how to add a default as suggested?  Not seeing board_color?

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,640
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #7 on: January 03, 2018, 05:58:01 PM »
It might not be that table. that was a guess on my part.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #8 on: January 03, 2018, 06:06:53 PM »
SMF error suggests a database upgrade?  How do I do that?  Not finding anything on updating.php database.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: How to upgrade the database?
« Reply #9 on: January 03, 2018, 06:40:35 PM »
I keep getting an error pointing to possible database needing to upgrade each time I try to add a new category on our forum.  Won't add the category and keeps giving me the error message.

Offline Steve

  • Freak
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 4,421
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: Re: How to upgrade the database?
« Reply #10 on: January 03, 2018, 06:50:58 PM »
Split your question off. Let's not get the two problems confused even though yours may be similar.
Online Manual

Please do not PM me for support.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,079
Re: Re: How to upgrade the database?
« Reply #11 on: January 03, 2018, 08:02:12 PM »
what is the full error message you are seeing?

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,079
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #12 on: January 03, 2018, 08:03:17 PM »
You have to add a default to into the smf_boards table in the board_color column in the database structure that appears to be coming from a modification

this is all you need to do to fix your issue. if you dont know how to do that you should post in the mods support topic that added that column. you dont need to upgrade your database as there have been no database changes to apply.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: How to upgrade the database?
« Reply #13 on: January 03, 2018, 10:01:16 PM »
This is the message I get when I try to add a catagory to my forum.

Field 'board_color' doesn't have a default value
File: /home/kallen/public_html/Sources/Subs-Boards.php
Line: 790

Note: It appears that your database may require an upgrade. Your forum's files are currently at version SMF 2.0.14, while your database is at version 2.0.11. The above error might possibly go away if you execute the latest version of upgrade.php.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #14 on: January 03, 2018, 10:04:05 PM »
Dont know how to do it and not finding where to post in Mod Support?

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,388
  • Riding the endless highway in the sky.
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #15 on: January 03, 2018, 10:08:43 PM »
You need to identify the mod that added the code to Subs-Boards.php, it's not in core code.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #16 on: January 03, 2018, 10:09:17 PM »
You have to add a default to into the smf_boards table in the board_color column in the database structure that appears to be coming from a modification

this is all you need to do to fix your issue. if you dont know how to do that you should post in the mods support topic that added that column. you dont need to upgrade your database as there have been no database changes to apply.

When you say "this is all you need to do to fix your issue", I don't know what your pointing to that is what I need to do?  I have been unable to even locate a board_color entry and even if I found it I don't know what to do with it when I do find it.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #17 on: January 03, 2018, 10:09:40 PM »
You need to identify the mod that added the code to Subs-Boards.php, it's not in core code.


How do I find the mod? 

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,388
  • Riding the endless highway in the sky.
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #18 on: January 03, 2018, 10:17:30 PM »
Look in Admin -> Package Manager, post a list of installed mods.

Offline KEA

  • Jr. Member
  • **
  • Posts: 189
Re: Error after 2.014 install - blocked from site - Error 500
« Reply #19 on: January 03, 2018, 10:25:44 PM »
Modification Packages — Installed  Help
Mod Name   Version   
1.   SMF 2.0.15 Update   1.0     [ Uninstall ] [ List Files ] [ Delete ]
2.   Country Flags   3.0     [ Uninstall ] [ List Files ] [ Delete ]
3.   Anti-spam by CleanTalk   2.00     [ Uninstall ] [ List Files ] [ Delete ]
4.   Admin Ban Button in Post   3.0     [ Uninstall ] [ List Files ] [ Delete ]
5.   Users Online Today   2.1     [ Uninstall ] [ List Files ] [ Delete ]
6.   Global Headers Footers   2.0     [ Uninstall ] [ List Files ] [ Delete ]
7.   Anti Bot: Are You Human/Bot?   3.0     [ Uninstall ] [ List Files ] [ Delete ]
8.   Add IP2Location to Track IP   1.31     [ Uninstall ] [ List Files ] [ Delete ]
9.   Recent Topics On "Recent Posts" Page   1.2     [ Uninstall ] [ List Files ] [ Delete ]
10.   Sorted Package Manager Listing   1.2     [ Uninstall ] [ List Files ] [ Delete ]
11.   Language Drop Down   1.5.3     [ Uninstall ] [ List Files ] [ Delete ]
12.   Google Member Map   2.6     [ Uninstall ] [ List Files ] [ Delete ]
13.   Yet Another YouTube BBCode Tag   3.11     [ Uninstall ] [ List Files ] [ Delete ]
14.   Previous and Next Links for Page Index   2.1.204     [ Uninstall ] [ List Files ] [ Delete ]
15.   Ad Managment   3.2     [ Uninstall ] [ List Files ] [ Delete ]
16.   SMF Gallery Pro   7.2.1     [ Uninstall ] [ List Files ] [ Delete ]
17.   Referrals System   3.1     [ Uninstall ] [ List Files ] [ Delete ]
18.   Delete Spam Posts   1.6     [ Uninstall ] [ List Files ] [ Delete ]
19.   Bot Buster   1.1     [ Uninstall ] [ List Files ] [ Delete ]
20.   Topic Limit On Board   1.0     [ Uninstall ] [ List Files ] [ Delete ]