Advertisement:

Author Topic: Missing pictures  (Read 4757 times)

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Missing pictures
« on: January 05, 2018, 02:39:04 AM »
Hello folks,

After migrating the forum from one hosting to another, there are topics with missing pictures from the posts of the members.
I had made a backup from ftp files and database but the pictures are still missing.

How can I solve this issue and return the pictures back?
Thanks!

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #1 on: January 05, 2018, 02:53:35 AM »
Attachments or hotlinked images? If hotlinked, are the images actually still accessible?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #2 on: January 05, 2018, 03:00:56 AM »
Attachments are still missing.
I am aware about hotlinked images that there is limited time when links are live/viewable.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #3 on: January 05, 2018, 03:03:00 AM »
Are the files actually there? How did you move the files from one server to another?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #4 on: January 05, 2018, 03:07:06 AM »
I downloaded the whole public_html folder and uploaded the files to the new host provider.
Avatars are fine but attachments with pictures are missing.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,298
    • StoryBB/StoryBB on GitHub
Re: Missing pictures
« Reply #5 on: January 05, 2018, 03:08:24 AM »
You downloaded with what tool?
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #6 on: January 05, 2018, 03:09:46 AM »
OK, did you use Filezilla? :)

If you did and if you still have access to the old server:

Connect to the old server via FTP again
In the FileZilla menu, go to Transfer -> Transfer Type and choose "Binary"
Download the attachments directory again

Connect to the new server, make sure "Transfer Type" is set to "Binary"
Upload the attachments directory again, overwriting the old files

A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #7 on: January 05, 2018, 03:10:22 AM »

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #8 on: January 05, 2018, 03:16:17 AM »
OK, did you use Filezilla? :)

If you did and if you still have access to the old server:

Connect to the old server via FTP again
In the FileZilla menu, go to Transfer -> Transfer Type and choose "Binary"
Download the attachments directory again

Connect to the new server, make sure "Transfer Type" is set to "Binary"
Upload the attachments directory again, overwriting the old files

Transfer type was set to "Auto".

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #9 on: January 05, 2018, 03:17:11 AM »
Yes, that's what I was guessing. Can you try again using Binary?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,298
    • StoryBB/StoryBB on GitHub
Re: Missing pictures
« Reply #10 on: January 05, 2018, 03:18:54 AM »
Remember: you need to use Binary both for downloading and uploading.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #11 on: January 05, 2018, 03:23:45 AM »
Remember: you need to use Binary both for downloading and uploading.
Thanks guys, but I didn't know that.
Now I am aware about that setting and I hope that the forum is still accessible through ftp at the old hosting provider.

I will let you know what's going on.   

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #12 on: January 05, 2018, 03:44:45 AM »
Old issue that keeps resurfacing every now and then. :)

Important Notice: Do you use Filezilla?  Avatars and Attachments lost?
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #13 on: January 05, 2018, 04:06:41 AM »
Old issue that keeps resurfacing every now and then. :)

Important Notice: Do you use Filezilla?  Avatars and Attachments lost?
It's annoys me since I didn't know this with the setting to binary. :-[
Is there any way to avoid this, but with default setting to Auto?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,298
    • StoryBB/StoryBB on GitHub
Re: Missing pictures
« Reply #14 on: January 05, 2018, 04:08:38 AM »
Not in SMF 2.0

We did solve it in SMF 2.1.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,248
  • 'Tis the gift to be simple (duh)
Re: Missing pictures
« Reply #15 on: January 05, 2018, 12:02:45 PM »
This problem occurs due to another FZ setting which is cleverly buried in a completely different place.

Edit -> Settings -> Transfers -> File Types -> Treat files without extension as ASCII files

Attachment file names are hashed for security purposes, and extension is removed.  If transfer type is set to Auto, the hidden setting causes the attachments to be transferred as ASCII, corrupting the files.  Someone must have put in a lot of overtime thinking this up.  I believe the 2.1 fix is to just add an extension.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,390
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Missing pictures
« Reply #16 on: January 05, 2018, 12:03:43 PM »
That is true, now - it wasn't when this problem first occurred, but when fixing this, selecting binary manually will do. ;)
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,248
  • 'Tis the gift to be simple (duh)
Re: Missing pictures
« Reply #17 on: January 05, 2018, 12:16:42 PM »
Don't really see the point to that setting.  All file types will transfer correctly if binary is used, so why do an ASCII transfer?  There were several schemes posted that were supposed to fix attachment files that were corrupted by ASCII transfer, but none of them worked for me.

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,298
    • StoryBB/StoryBB on GitHub
Re: Missing pictures
« Reply #18 on: January 05, 2018, 12:23:01 PM »
Don't really see the point to that setting.  All file types will transfer correctly if binary is used, so why do an ASCII transfer?  There were several schemes posted that were supposed to fix attachment files that were corrupted by ASCII transfer, but none of them worked for me.


Partly because it's faster and partly because in theory it's the right choice for text files to have compatibility (Windows Notepad doesn't support Linux line endings for example)
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline pocttopus

  • Jr. Member
  • **
  • Posts: 285
    • @pocttopus on Twitter
Re: Missing pictures
« Reply #19 on: January 08, 2018, 11:42:02 AM »
I had downloaded the "attachments" folder from the previous hosting and uploaded with Binary setting (Transfer->Transfer type->Binary), but the attachments are still missing.
On the other hand, the forum uses an SSL certificate and after the installation all the links from photobucket are not viewable but they are in the post's.
Can this be the issue for attachments too? I mean after installing the SSL?  :-\