Advertisement:

Author Topic: SA Google+ intergration  (Read 41955 times)

Offline gonza28

  • Semi-Newbie
  • *
  • Posts: 27
    • @@gonzadoky on Twitter
Re: SA Google+ intergration
« Reply #80 on: August 01, 2014, 06:44:17 AM »
Hi SA.
I am happy your mod co facebook integration.
You are a great.

Today I installed GplusIntegration and followed all the steps and console google.

I already have everything set up. Forum everything is enabled. The imagne of "button" is on imgur.com. Everything looks perfect.
When registering a user redirection fails.
I've checked many times to see what's wrong, but I find nothing.
In the console I left the default as mensiona URLs in the tutorial. I will upload an image to display. The tester etá user logged in correctly then G+

400. That's an error

Error: redirect_url_mismatch

The redirect URl in the request:
http://myforumxample.com/index.php?action=gplus

Help. hug

Offline gonza28

  • Semi-Newbie
  • *
  • Posts: 27
    • @@gonzadoky on Twitter
Re: SA Google+ intergration
« Reply #81 on: August 01, 2014, 09:09:55 AM »
Solved!
By putting in the API as URIS OF REDIRECTION:
http://www.example.com/index.php?action=gplus
not work.

If we put: http://www.myforum.com/index.php?action=gplus
so if it worked.
Users can register correctly.
Thanks for the great work! ;)

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,888
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: SA Google+ intergration
« Reply #82 on: August 01, 2014, 09:14:36 AM »
Glad you got it to work.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline desai_amogh

  • Semi-Newbie
  • *
  • Posts: 35
    • Electronics Forum India
Re: SA Google+ intergration
« Reply #83 on: January 24, 2015, 09:40:17 PM »
Getting database error while registering with username and password..

error in screenshot attached ..  please help..




File: /public_html/Sources/Subs-Members.php  is here:
Line: 805
Code: [Select]
785: foreach ($regOptions['register_vars'] as $var => $val)
786: {
787: $type = 'string';
788: if (in_array($var, $knownInts))
789: $type = 'int';
790: elseif (in_array($var, $knownFloats))
791: $type = 'float';
792: elseif ($var == 'birthdate')
793: $type = 'date';
794:
795: $column_names[$var] = $type;
796: $values[$var] = $val;
797: }
798:
799: // Register them into the database.
800: $smcFunc['db_insert']('',
801: '{db_prefix}members',
802: $column_names,
803: $values,
804: array('id_member')
==>805: );
806: $memberID = $smcFunc['db_insert_id']('{db_prefix}members', 'id_member');
807:
808: // Update the number of members and latest member's info - and pass the name, but remove the 's.
809: if ($regOptions['register_vars']['is_activated'] == 1)
810: updateStats('member', $memberID, $regOptions['register_vars']['real_name']);
811: else
812: updateStats('member');
813:
814: // Theme variables too?
815: if (!empty($theme_vars))
816: {
817: $inserts = array();
818: foreach ($theme_vars as $var => $val)
819: $inserts[] = array($memberID, $var, $val);
820: $smcFunc['db_insert']('insert',
821: '{db_prefix}themes',
822: array('id_member' => 'int', 'variable' => 'string-255', 'value' => 'string-65534'),
823: $inserts,
824: array('id_member', 'variable')
825: );
« Last Edit: January 24, 2015, 10:35:41 PM by desai_amogh »

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,888
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: SA Google+ intergration
« Reply #84 on: January 25, 2015, 12:38:51 AM »
This mod does not add a column called google_plus might be from another profile fields mod.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline DSystem

  • Jr. Member
  • **
  • Posts: 238
  • Gender: Male
  • EletronicaBR - Admin
    • eletronicaBR.com
Re: SA Google+ intergration
« Reply #85 on: February 12, 2015, 06:11:06 AM »
I installed this mod and it's working perfectly.

So I have a doubt.

He wasn't supposed to get the email registered on google + and add the profile of the Forum Member?


Offline Miker1029

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
    • http://www.facebook.com/428239094034539 on Facebook
    • https://plus.google.com/+Android-x86Net/about on LinkedIn
    • @AndroidX86Forum on Twitter
    • Android - X86 Forums
Re: SA Google+ integration
« Reply #86 on: March 19, 2015, 10:06:24 AM »
Hi,

 I was wondering if you could go into more detail on the Custom Login Image, I just Put a Pictures of g+ login in my domain and pointed to it, and of course it didn't work...

Also I have no G+ buttons on the forum,  I'm using SMF 2.0.9, With the BlackJack Theme...

I believe I have everything setup right tho...I can see on the bottom it's going to google and all that

Any Help

Mike

Offline Miker1029

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
    • http://www.facebook.com/428239094034539 on Facebook
    • https://plus.google.com/+Android-x86Net/about on LinkedIn
    • @AndroidX86Forum on Twitter
    • Android - X86 Forums
Re: SA Google+ integration
« Reply #87 on: March 20, 2015, 07:36:04 AM »
Update:

Ok I got it working for the Registration Screen, Haven't gotten farther then that yet...I had to use a .GIF not .JPG for the button...

I Got this Error:Fatal error: Call to undefined function twit_USettings() in /home/mike2769/public_html/Sources/GPlus/GPlusHooks.php on line 172

What happened with this is I already had my "3 Test" Gmail account registered in the forum, so when I clicked the Button I got the 400 Error from Google saying They don't know what's up, and then the forum said the E-mail already Existed...

SOOOO, I tried to Login, And got that Error When I clicked the Login Button on the SMF Top Menu....

SO, Went to my Backups and re-uploaded GPlusHooks.php (Think I edited, on the first page there was something about having all boards ON instead of OFF as default, Mighta Misread tho)..

Still Same error, Cleared Browser Cache in F.F. Same Error, So I tried with Chrome and It let me in, Went Directly to G+ Config and Shut it down, Which Allowed me to Log-In With FireFox...

Got me Confused...

Any Ideas??  I'm gonna try and Uninstall and Re Install and See if that fixes it....

Thanks for the Help.

Mike

EDIT:

Ok I GET The Error When coming back from the Error With google+ the page that show on return is:

http://www.android-x86.net/index.php?action=gplus;area=auto;agree

And Obviously this is the page I get the Error on:

http://www.android-x86.net/index.php?action=login

It Seems Once you get PAST that gplus error page (1st One) it clears out and you can log-in (Hence why Chrome worked)

Ok About all the Info I got, Running 2.0.9, Blackjack Theme (curve base)

AND it only gives that Error On the Second Login Link, Not the One on the very top the one on the list with home, profile, and all that, The Top one takes you to the Login Screen.... ODD!

Top Login Link: http://www.android-x86.net/index.php?action=login2

Menu Login Link: http://www.android-x86.net/index.php?action=login

Seems the Solution here is Obvious, SO where Do I edit the Link to Login from the Menu?  8-)
« Last Edit: March 20, 2015, 07:55:06 AM by Miker1029 »

Offline Miker1029

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
    • http://www.facebook.com/428239094034539 on Facebook
    • https://plus.google.com/+Android-x86Net/about on LinkedIn
    • @AndroidX86Forum on Twitter
    • Android - X86 Forums
Re: SA Google+ integration
« Reply #88 on: March 20, 2015, 08:12:50 AM »
Ok, Google+ Log-in works, G+ Buttons Showing up, (Wish I could delete my first Post, LOL, Now I realize How stupid it was, but I'm not into Social Media, Just doing it for the forum)

Now If I could figure that Link, I looked in Sources/Subs, To Confusing...

If anyone has a Way to change the link it would be appreciated....

Mike

Offline Miker1029

  • Jr. Member
  • **
  • Posts: 165
  • Gender: Male
    • http://www.facebook.com/428239094034539 on Facebook
    • https://plus.google.com/+Android-x86Net/about on LinkedIn
    • @AndroidX86Forum on Twitter
    • Android - X86 Forums
Re: SA Google+ intergration - User Password?
« Reply #89 on: January 10, 2016, 01:20:55 PM »
Hey All,

    I had a user the other day that wanted to turn off member sending E-mails to him and He was Unable Because He Registered with Google+ and It doesn't Have/Know What password to use, I tried on my test account, and My Google+ password didn't work....

Anyone have Any Idea How I can Figure out the Password, Or Ideally just Remove the "Current Password:" Check from the Profile Page....

Thanks,

Mike

Offline nend

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,755
  • 2 deep n2 the code
    • sicommnend on GitHub
    • SIComm.us
Re: SA Google+ intergration
« Reply #90 on: January 10, 2016, 10:24:10 PM »
Hi vb

Just passing by this post and remembered about a bug I found in the Google+ Integration.

It seems like it has a dependency, I can't really remember where it was at exactly, I was planning to work on it myself but never got around to it.

If you enable "Enable Auto Login", it tries to call on a function from SA Twitter or SA Facebook, can't really recall which one exactly and don't have access to my work right now to say for sure. It is in that general area. So without one of the other mods installed with this one it fails.

Sorry I can't give any more details. Will do so when I can access my local files.  :-\

Offline nend

  • SMF Friend
  • SMF Hero
  • *
  • Posts: 1,755
  • 2 deep n2 the code
    • sicommnend on GitHub
    • SIComm.us
Re: SA Google+ intergration
« Reply #91 on: January 10, 2016, 10:28:11 PM »
Here
GPlusHooks.php
Code: [Select]
function gplus_loadTheme(){
    global $modSettings, $user_info, $context;

loadLanguage('GPlus');

if (empty($modSettings['allow_guestAccess']) && $user_info['is_guest'] && (isset($_REQUEST['action']) || in_array(isset($_REQUEST['action']), array('gplus'))))
    {
    $modSettings['allow_guestAccess'] = 1;
    }

if(isset($_SESSION['gplus']['idm']) && isset($_REQUEST['action']) && $_REQUEST['action'] == 'login' && !empty($modSettings['gp_app_enabledautolog'])){

$context['gplus_id'] = twit_USettings($_SESSION['gplus']['idm'],'id_member','gpid');

if (!empty($context['gplus_id'])) {
redirectexit('action=gplus;area=connectlog');   
}
    }

See
Code: [Select]
twit_USettings($_SESSION['gplus']['idm'],'id_member','gpid');

Offline SMFHacks.com Team

  • Jr. Member
  • **
  • Posts: 382
    • smfhacks on Facebook
    • @smfhacks on Twitter
    • SMFHacks.com
Re: SA Google+ intergration
« Reply #92 on: January 10, 2016, 10:33:48 PM »
Update fixed

1.0
!Fixed undefined twit_USettings bug
Disclaimer: SMFHacks.com Team is not affiliated with the SMF Team or the SimpleMachines NPO.

http://ForumRankings.net - Get Forum Ranked!
SMFHacks.com -  Paid Modifications for SMF
Latest Mods:
Community Suite
Newsletter Pro SMF Gallery Pro SMF Classifieds SMF Store

Offline concorde7

  • Jr. Member
  • **
  • Posts: 142
  • Gender: Male
Re: SA Google+ intergration
« Reply #93 on: February 20, 2016, 02:21:14 AM »
2 Questions.
1. I see no google+ option when logging in. Is that a theme or mod issue?
2. related to question 1 ... Can I just make a custom button for people to click ot login with since my theme doesnt have the g+ login button on the page?



Reseller Theme by Daniiel
SMF 2.0.11

1.    reCAPTCHA for SMF    0.9.9    
2.    Ad Managment    3.2    
3.    Misc Anti Spam    1.0    
4.    Anti-Spam Links    1.0.1    
6.    Add Social Media Icons To Profiles    1.2.0    
7.    SA GPlus    1.0    
8.    Optimus Brave    1.8.7    
9.    SMF 1.1.21 / 2.0.10 Update    
10.    SMF Articles    2.0.2    
12.    reCAPTCHA for SMF

Offline Cizaquita

  • Newbie
  • *
  • Posts: 8
Re: SA Google+ intergration
« Reply #94 on: February 26, 2016, 02:33:26 AM »
2 Questions.
1. I see no google+ option when logging in. Is that a theme or mod issue?
2. related to question 1 ... Can I just make a custom button for people to click ot login with since my theme doesnt have the g+ login button on the page?



Reseller Theme by Daniiel
SMF 2.0.11

1.    reCAPTCHA for SMF    0.9.9    
2.    Ad Managment    3.2    
3.    Misc Anti Spam    1.0    
4.    Anti-Spam Links    1.0.1    
6.    Add Social Media Icons To Profiles    1.2.0    
7.    SA GPlus    1.0    
8.    Optimus Brave    1.8.7    
9.    SMF 1.1.21 / 2.0.10 Update    
10.    SMF Articles    2.0.2    
12.    reCAPTCHA for SMF

1- You need to configurate the URL image to login.
2- Yes yu can, only you need to add the image URL in the Google+ mod configuration.

Offline Cizaquita

  • Newbie
  • *
  • Posts: 8
Re: SA Google+ intergration
« Reply #95 on: February 26, 2016, 02:38:33 AM »
What is the default password when an user Register with "Auto" option?


Quote
I have an error, when i tried to register with my G+ account says that my name is too long and i can't register.

What is the problem? Mod error or SMF error?

Thanks.
Edit: Solved this question, I had modifie the Subs-member.php
« Last Edit: February 26, 2016, 03:08:20 AM by Cizaquita »

Offline Cizaquita

  • Newbie
  • *
  • Posts: 8
Re: SA Google+ intergration (PHP ERROR 'invalid_grant')
« Reply #96 on: May 19, 2016, 03:12:57 PM »
Hi!

I am having this error:

Code: [Select]
PHP Fatal error:  Uncaught exception 'apiAuthException' with message 'Error fetching OAuth2 access token, message: 'invalid_grant'' in /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/gplusauth/auth/apiOAuth2.php:105\nStack trace:\n#0 /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/gplusauth/apiClient.php(138): apiOAuth2->authenticate(Array)\n#1 /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/Sources/GPlus/GPlusHooks.php(254): apiClient->authenticate()\n#2 /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/Sources/GPlus/GPlus.php(116): gplus_init_auth()\n#3 /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/Sources/GPlus/GPlus.php(51): gplus_main()\n#4 [internal function]: GPlus()\n#5 /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/index.php(161): call_user_func('GPlus')\n#6 {main}\n  thrown in /var/sentora/hostdata/xxxxxx/public_html/xxxxxx/foro/gplusauth/auth/apiOAuth2.php on line 105, referer: http://laresistencia.co/foro/index.php?action=login
I just checked the .php file and search in Google about this error but I don't know what is the problem.

Anybody can help me? Thanks!
« Last Edit: May 19, 2016, 04:17:54 PM by Cizaquita »

Offline jack001

  • Jr. Member
  • **
  • Posts: 195
  • Gender: Male
  • Edutainment Forum
    • @edutain_forum on Twitter
    • EDUTAINMENT FORUM - Education with Entertainment
Re: SA Google+ intergration
« Reply #97 on: July 05, 2018, 11:35:26 AM »
i am trying to apply for 2.1 beta4. It installed without any error but login isn't showing.
Any idea why?
https://www.edutainmentforum.com Edutainment forum - Education with Entertainment!

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,888
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: SA Google+ intergration
« Reply #98 on: July 05, 2018, 11:36:21 AM »
This mod does not support 2.1 yet
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro