Advertisement:

Author Topic: https still working after uninstall  (Read 462 times)

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
https still working after uninstall
« on: January 11, 2018, 08:00:11 AM »
Hello folks,

I had uninstalled SSL certificate and changed the paths with "repair_settings.php" file and ".htaccess" removed from ftp files but still on the links https is active. ???
How can disable https and enable/return to http?  :-\

Here is also what I have found at "Configuration -> Themes and layout -> Theme settings"


Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,068
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: https still working after uninstall
« Reply #1 on: January 11, 2018, 10:24:37 AM »
First - Try running repair_settings again, and make sure all URLs really start with http://
Your screenshot would imply it is not so at the moment.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #2 on: January 11, 2018, 10:43:03 AM »
I had uploaded again repair_settings.php and now all suggestions are with https instead of only http.
Am I missing something here? ???

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,068
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: https still working after uninstall
« Reply #3 on: January 11, 2018, 10:44:46 AM »
Just make sure they are all http and save, then go test your forum. ( Which by the way, seems to work as http for me just right currently. )
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #4 on: January 11, 2018, 11:21:29 AM »
This is weird or?  ???
Every single link is http but forum still works with https.  :o


Online drewactual

  • Jr. Member
  • **
  • Posts: 250
    • College Football Fan Site CFB51
Re: https still working after uninstall
« Reply #5 on: January 11, 2018, 11:40:58 AM »
are you on a shared or dedicated?

ask your host if shared, or check yourself in the htaccess file if there is a redirect to https.  if there is, no matter what SMF is asking for, your going to get https
https://www.cfb51.com is a College Football Fan Site, Store, and Publisher, launched in July of 2017

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #6 on: January 11, 2018, 11:56:52 AM »
are you on a shared or dedicated?

ask your host if shared, or check yourself in the htaccess file if there is a redirect to https.  if there is, no matter what SMF is asking for, your going to get https
Yes, shared via buyshared.
Also I had removed .htaccess file from the server.

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,068
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: https still working after uninstall
« Reply #7 on: January 11, 2018, 01:05:07 PM »
There's no redirect, as it works just perfectly through http.
Are you trying to block https or what exactly are you trying to accomplish?

Your hosting control panel will most probably have settings to control the http/https behaviour,
but currently it is just serving the same content through both it would seem.

A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #8 on: January 11, 2018, 02:01:28 PM »
We have a big collection of pictures which are uploaded to photobucket.
After installation of SSL certificate, google started to index our forum fine but on the other side pictures were not displayed because photobucket is not using a secure protocol. ???

Now I had to be sure that the pictures are going to stay displayed. :-\
I just want to push our forum to use secure protocol but some services are not allowing at this time.

Do you have any idea how to turn this SSL on again?  ::)

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,208
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: https still working after uninstall
« Reply #9 on: January 11, 2018, 02:03:35 PM »
Does photobucket links work with https:// if you change them if so that might be easier to update those posts to https://
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #10 on: January 11, 2018, 02:15:13 PM »
No, photobucket is not accepting secure protocol. He is just returning to http. :-\

Online vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 20,208
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: https still working after uninstall
« Reply #11 on: January 11, 2018, 02:20:47 PM »
That's lame they need to get with the times and for a big company like them that charge a lot of money now.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #12 on: January 11, 2018, 03:16:16 PM »
Yeah... I know.  :-\

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,068
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: https still working after uninstall
« Reply #13 on: January 16, 2018, 12:06:20 PM »
So, did you get things sorted - or was there something you still needed help with? :)
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Online pocttopus

  • Jr. Member
  • **
  • Posts: 238
    • @pocttopus on Twitter
Re: https still working after uninstall
« Reply #14 on: January 16, 2018, 12:39:31 PM »
I don't know how to tell members to migrate to different image hosting using ssl.  :-\
Some of them are even using galleries with profiles.

Also I'm afraid if someday photobucket shut's down. :(
I'll mark this topic as solved since there is no way to do something from my side because photobucket is a members choice. :-[

Oh how I hate that photobucket!  >:(

Offline Aleksi "Lex" Kilpinen

  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,068
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: https still working after uninstall
« Reply #15 on: January 16, 2018, 01:02:37 PM »
Actually, I think Photobucket has SSL support.... It's just difficult, and there's no real documentation anywhere... But, apparently all the embed codes Photobucket offers, work with just replacing http to https. ( The website links however do not ).

https://support.photobucket.com/hc/en-us/articles/115012940387-Does-Photobucket-support-HTTPS-
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas