Advertisement:

Author Topic: forum pages not displaying correctly.  (Read 1084 times)

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #20 on: January 13, 2018, 06:13:59 PM »
Just out of interest, could you try turning off SMF Caching, (if it's turned on).

Admin > Configuration > Server Settings > Caching. set the SMF caching level to No caching

Had some really strange results on three of my sites with this turned on, and so has someone else that I know of.
Is that in the admin panel or folder?
with me changing to maintenance mode the forum no longer loads get a 404 error page

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,326
    • StoryBB/StoryBB on GitHub
Re: forum pages not displaying correctly.
« Reply #21 on: January 13, 2018, 06:19:37 PM »
At this point I'd be talking to your host and asking them if they have Varnish enabled, and if so to turn it off.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #22 on: January 13, 2018, 06:23:44 PM »
At this point I'd be talking to your host and asking them if they have Varnish enabled, and if so to turn it off.
I will do that thanks

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #23 on: January 13, 2018, 06:44:08 PM »
Ok just renamed my settings.php  then renamed my settings_bak to settings.php and the forum will display in maintenance mode :o  maybe my settings.php file got corrupt along with something else ??? ::)
I get blank screens now navigating after a couple of pages ??? ::)

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,326
    • StoryBB/StoryBB on GitHub
Re: forum pages not displaying correctly.
« Reply #24 on: January 13, 2018, 07:04:29 PM »
...seriously, talk to your host about Varnish. That's the best explanation for the symptoms you have right now.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

No good deed goes unpunished / No act of charity goes unresented.

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #25 on: January 27, 2018, 07:37:07 PM »
Looks like the site was hacked >:(
Scan revealed some suppisious files and a rerouting script.
 This was the perfect time to do a fulll install and get totaly upto date.
Thanks for everyones help! ;)