Advertisement:

Author Topic: forum pages not displaying correctly.  (Read 1080 times)

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
forum pages not displaying correctly.
« on: January 13, 2018, 08:50:16 AM »
This all started on the 11th. Suddenly trying to go to another page on my forum it reverts back to the page I left.
sometimes I can get on other times I'm stuck at the login screen.
the urls seem to change correctly to the proper addresses the forum just doesn't display the correct page and usually loops back to where I was.
I've had Godaddy look into it and they suggested seeing if there were any suggestions here.
I've not seen any issues like this reported so I'm stumped.
Goddady says the server is fine.
I'm running version 2.0.11
Interesting if I rename a SMF back up file(doesn't matter which one) I can proceed to the next page on my forum.
using this I was able to log into the admin pages and do maintenance and backups (none of which helped)
which make me think it is an issue on the server end and not SMF.
Any suggestions are most welcome

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #1 on: January 13, 2018, 01:12:00 PM »
I got a PHPInfo.php uploaded http://tuicemen.com/forum/phpinfo.php [nofollow]
the forum is @ http://tuicemen.com/forum [nofollow]
I reverted to the default theme thinking that may help but it hasn't.
 

Offline aegersz

  • SMF Hero
  • ******
  • Posts: 1,445
  • Gender: Male
  • "mods" junkie
    • dopetalk
Re: forum pages not displaying correctly.
« Reply #2 on: January 13, 2018, 02:08:04 PM »
works ok for me so maybe clear browser cookies and cache ?

easy to do and worth a try
The configuration of my Linux VPS (SMF 2.0 with 140+ mods) can be found here and notes on my mods can be found here (warning: those links will take you to a drug related forum)

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #3 on: January 13, 2018, 02:50:17 PM »
I'm getting a message that forum is down, being redirected to http://forums.x10.com/.

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #4 on: January 13, 2018, 03:44:06 PM »
works ok for me so maybe clear browser cookies and cache ?

easy to do and worth a try
your the first to report that. How many pages did you try loading? Sometimes I can do 3 or 4 but that's the max before it stops.
Just noticed the home button seems to work most of the time but not always
This is really frustrating even Godaddy sees this and said it was that SMF changed something.
I think it was Friday and they just wanted to go home. ??? ::)
Clearing browser cookies and cache has no affect but then I didn't expect it would as I have the same thing happening on other PCS and different browsers.
I'm getting a message that forum is down, being redirected to http://forums.x10.com/ [nofollow].

I had the redirect up while scanning files.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #5 on: January 13, 2018, 04:00:52 PM »
First 3-4 links worked, now every link remains on same topic page.  Looks like PHPSESSID is in the middle of every url.  Running any mods?  Did you change anything?


Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #6 on: January 13, 2018, 04:31:02 PM »
I am running a few Spam mods however I haven't changed anything has been running fine for over a year.
Only approved or rejected new members
Thursday night this started.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #7 on: January 13, 2018, 04:38:49 PM »
GoDaddy has been moving accounts to different servers, some have been damaged and they're stonewalling account owners.  Just took a look at your site in FF, and it's stuck on same page I last saw it in IE.  All urls look like this -

http://tuicemen.com/forum/index.php?PHPSESSID=uksqain54er8ltoh1du4kh2t90&action=register

They all go to same topic.  Never seen that before, but best guess is it's a server glitch.

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #8 on: January 13, 2018, 04:49:59 PM »
That's what I suspected and had hoped it would clear up.
Spent 3 hours in chat with support yesterday.
Looks like I'll have to wait till Monday and get on them again.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #9 on: January 13, 2018, 04:53:39 PM »
Now it's displaying Admin -> Package Manager -> Installed Packages, and I'm seeing Tuicemen logged in up top.  You only have three mods installed, I would upload the 2.0.15 large upgrade package, see what happens.  Don't think that'll fix it, but you'll have a clean install, current version.

Offline a10

  • Charter Member
  • Sr. Member
  • *
  • Posts: 811
Re: forum pages not displaying correctly.
« Reply #10 on: January 13, 2018, 05:00:38 PM »
Same here! Something is seriously wrong. After a little navigating then suddenly ended up seemingly logged in

Tuicemen
Show unread posts since last visit
etc

and looking at "View and Remove Installed Packages"
url: hxxp://tuicemen.com/forum/index.php?action=admin;area=packages;sa=packageget;get;e337cca2ce8f=13edd69264edbb1d4e7e741884ea8ac1

I'd first suspect some horrendous caching going on, maybe ask F**kupdaddy to investigate that.

« Last Edit: January 13, 2018, 05:11:23 PM by a10 »
2.0.15, ssl, php 7.1.19, MySQL 10.1.30-MariaDB-1~xenial
Mods: Contact Page, Like Posts, Responsive Curve, Search Focus Dropdown.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #11 on: January 13, 2018, 05:05:42 PM »
Everyone sees the same page, and every link goes there, but it's changed since an hour or so ago.  Varnish caching was causing some bizarre problems, but nothing like this, and I don't remember seeing it on any GD accounts.

If cpanel is working BACKUP YOUR DATABASE.

Offline a10

  • Charter Member
  • Sr. Member
  • *
  • Posts: 811
Re: forum pages not displaying correctly.
« Reply #12 on: January 13, 2018, 05:17:05 PM »
Getting better... now, on /forum/index.php it opened the complete list of Announcements :O)

Quote
window.smfAnnouncements = [
   {
      subject: 'SMF 2.0.15 has been released',
      href: 'https://www.simplemachines.org/community/index.php?topic=557176.0',
      time: 'November 19, 2017, 09:03:58 PM',
      author: 'Colin',
      message: 'A patch has been released, addressing a few vulnerabilities in SMF 2.0.14 and fixing several bugs as well. We urge all forum administrators to upgrade as soon as possible. Just visit the package manager to install the patch.'
   },
   {
      subject: 'SMF 2.1 Beta 3 released',
      href: 'https://www.simplemachines.org/community/index.php?topic=554301.0',
      time: 'May 31, 2017, 09:21:59 PM',
      author: 'Colin',
      message: 'Simple Machines is proud to announce the third beta of the next version of SMF, which contains many bugfixes and a few new features since 2.1 Beta 2.'
   },
etc etc
2.0.15, ssl, php 7.1.19, MySQL 10.1.30-MariaDB-1~xenial
Mods: Contact Page, Like Posts, Responsive Curve, Search Focus Dropdown.

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #13 on: January 13, 2018, 05:22:24 PM »
I'm seeing the board index, and theme has changed from Curve to BacknBlack. :o

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #14 on: January 13, 2018, 05:27:39 PM »
I'm seeing the board index, and theme has changed from Curve to BacknBlack. :o

yes changed it to that as that was what was running when this all started Changed to the default in case that was screwing things but that wasn't it.
I tryed creating a new temp forum but that has failed ON gdaddy even using their SFM installer so something is messed up with the server


Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #15 on: January 13, 2018, 05:30:08 PM »
Can you clear forum cache via ftp or file manager?  Delete all files in /cache except .htaccess and index.php.
« Last Edit: January 13, 2018, 05:40:14 PM by Sir Osis of Liver »

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #16 on: January 13, 2018, 05:39:55 PM »
that's all that is displaying other then two directory's temp and perm

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 8,250
  • 'Tis the gift to be simple (duh)
Re: forum pages not displaying correctly.
« Reply #17 on: January 13, 2018, 05:40:24 PM »
I would put the forum in maintenance mode, it just displayed your profile account settings.  Set $maintenance = 1 in Settings.php.  May not work, server appears to be randomly tossing up pages.

Offline 2icemen

  • Semi-Newbie
  • *
  • Posts: 16
Re: forum pages not displaying correctly.
« Reply #18 on: January 13, 2018, 05:45:45 PM »
Ok Placed I'm in maintenance mode

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,135
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: forum pages not displaying correctly.
« Reply #19 on: January 13, 2018, 05:51:25 PM »
Just out of interest, could you try turning off SMF Caching, (if it's turned on).

Admin > Configuration > Server Settings > Caching. set the SMF caching level to No caching

Had some really strange results on three of my sites with this turned on, and so has someone else that I know of. 
« Last Edit: January 13, 2018, 06:03:12 PM by lurkalot »