Advertisement:

Author Topic: No se ve como debería  (Read 1877 times)

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
No se ve como debería
« on: January 14, 2018, 03:14:47 PM »
Buenas...yo no sé qué me está pasando pero estoy a punto de dejar el foro porque la verdad es que en más de 7 años no me ha dado ni medio problema y ahora están viniendo todos de golpe
Ahora resculta que se ve tal que así

y no sé cómo se arregla y lo que es peor no entiendo nada de ésto que viene a ser chino básico para mí,no puedo responder a lo que preguntan ni hay forma de que salga ni smilies ni nada porque se ve así

No sé por dónde me da el aire y no tengo ni idea...si alguien me tira una idea de qué hacer y además me lo explica muy pero muy clara y detalladamente,lo agradecería mucho

Un saludo
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline d3vcho();

  • Sempiterno
  • Lead Localizer
  • SMF Hero
  • *
  • Posts: 4,318
  • Gender: Male
    • frandominguez03 on GitHub
Re: No se ve como debería
« Reply #1 on: January 14, 2018, 03:18:25 PM »

"Greeting Death as an old friend, they departed this life as equals."

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #2 on: January 14, 2018, 03:22:24 PM »
Ya lo he hecho y he conseguido que se viera así...antes ni eso

Ah...y además me aparece como página no segura

« Last Edit: January 14, 2018, 03:34:08 PM by Natalia66 »
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline vicram10

  • SMF Hero
  • ******
  • Posts: 5,971
  • Gender: Male
  • Founding Father of Ultimate Portal
    • vmrm10 on Facebook
    • vicram10 on GitHub
    • vicram10 on LinkedIn
    • @vicram_10 on Twitter
    • Noticias Tecnologicas, Tutoriales e Internet
Re: No se ve como debería
« Reply #3 on: January 14, 2018, 04:06:42 PM »
pagina no seguro es por que no tienes https para tu dominio simplemente por eso (es ajeno a SMF esa parte)

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
« Last Edit: January 14, 2018, 04:28:39 PM by Natalia66 »
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Gluz

  • Sr. Member
  • ****
  • Posts: 985
  • Gender: Male
Re: No se ve como debería
« Reply #5 on: January 14, 2018, 08:29:40 PM »
Al parecer hay algo mal en el tema, porque al principio en vez de HEAD tiene BODY y se repite mas adelante.

¿Qué modificaciones has hecho? tanto MODs instalados como al tema, porque eso parece mas un cambio manual que algo que hiciera un MOD.
Need help with PHP, HTML, CSS, Themes or MODs?

Quote
Think in spanish, habla en inglés.

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #6 on: January 15, 2018, 02:37:17 AM »
Lo único que he hecho ha sido quitar la mod del tamaño de imagen (y gracias a eso se ve así porque antes ni eso) la borré pero lo demás...nada
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #7 on: January 15, 2018, 09:09:48 AM »
El servidor me dice ésto:
Hi there,

You're using http:// resouces on a https:// URL, these will be blocked by the browser:

<link rel="stylesheet" type="text/css" href="http://www.elsitiodemirecreo.net/Themes/default/css/index.css?fin20" />
<link rel="stylesheet" type="text/css" href="http://www.elsitiodemirecreo.net/Themes/default/css/webkit.css" />
<script type="text/javascript" src="http://www.elsitiodemirecreo.net/Themes/default/scripts/script.js?fin20"></script>
<script type="text/javascript" src="http://www.elsitiodemirecreo.net/Themes/default/scripts/theme.js?fin20"></script>

You need to update all your resources to use https:// if you plan on using https:// URL.

y cuando le digo que de dónde me dice que

You need to edit the theme of your website and update the URLs, please contact the developer of your website to get this issue resolved

Entonces? Qué es lo que se supone que tengo que hacer? Alguien que me de una mano?
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #8 on: January 15, 2018, 09:54:47 AM »
Bueno...acabo de actualizar el foro a la 2.15 y al menos no aparecen los fallos que aparecían antes y se ha instalado bien pero se sogue viendo mal y sale lo de los scripts no seguros y que no es una página segura ¿alguien sabe cómo hacerlo?
Gracias!!!!!!!
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Natzu01

  • Jr. Member
  • **
  • Posts: 155
    • https://www.facebook.com/AnimeaZ.Oficial/ on Facebook
Re: No se ve como debería
« Reply #9 on: January 15, 2018, 06:33:14 PM »
pues para empezar trata de sacar los scrips de tu foro que aveces es lo que trae problemas lo digo por experiencia en general los .js que veas en rojo al darle f12 luego a console veras las rutas,  ahora para que no salga eso de pagina no segura pues ya es cosa de google y los buscadores que esta asi desde el año pasado no es de smf si quieres que te salga el candadito verde de pagina segura pues tendrias que adquirir en algun proveedor el certificado SSL si lo llegas a adquirir solo es cosa luego de reparar las rutas de http a https y listo  :)

Offline vicram10

  • SMF Hero
  • ******
  • Posts: 5,971
  • Gender: Male
  • Founding Father of Ultimate Portal
    • vmrm10 on Facebook
    • vicram10 on GitHub
    • vicram10 on LinkedIn
    • @vicram_10 on Twitter
    • Noticias Tecnologicas, Tutoriales e Internet
Re: No se ve como debería
« Reply #10 on: January 15, 2018, 06:48:10 PM »
Bueno...acabo de actualizar el foro a la 2.15 y al menos no aparecen los fallos que aparecían antes y se ha instalado bien pero se sogue viendo mal y sale lo de los scripts no seguros y que no es una página segura ¿alguien sabe cómo hacerlo?
Gracias!!!!!!!

tienes comprado el Certificado SSL?

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #11 on: January 16, 2018, 05:31:08 AM »
En el servidor pone que sí
Quote
Se instaló correctamente el anfitrión SSL.
Este certificado SSL ya se instaló.

El sitio web SSL ahora está activo y se puede acceder a través de HTTPS en este dominio:

elsitiodemirecreo.net
También se puede acceder al sitio web SSL a través de este dominio, pero el certificado no admite esto. Los navegadores web mostrarán una alerta cuando accedan a este dominio a través de HTTPS:
mail.elsitiodemirecreo.net
El certificado SSL también admite este dominio, pero este dominio hace no refiere al sitio web SSL que se mencionó anteriormente:
www.elsitiodemirecreo.net

Y en el de webdisk.elsitiodemirecreo.net

Quote
Identificación de certificados:   elsitiodemirecreo_net_db4f2_1419b_1521699218_0d628b9ea4dcfc3f0e06bcbd3f5b4cda
Dominios:   
elsitiodemirecreo.net
www.elsitiodemirecreo.net
Emisor:   Let's Encrypt
Tamaño de la clave:   2.048 bits (db4f28ed …)
Vencimiento:   22/03/2018 06:13:39
Instalar un sitio web SSL
Nota: No tiene ninguna dirección IP dedicada. Por lo tanto, los navegadores de web que no admitan la Indicación del nombre del servidor probablemente darán advertencias de seguridad falsas a los usuarios cuando accedan a cualquiera de los sitios web SSL. Microsoft® Internet Explorer™ en Windows XP™ es el navegador de web más usado que no admite SNI.

https://i.imgur.com/jFh6jgc.jpg

En cuanto a lo de F12..qué hacemos cuando no sale ninguna? porque de entrada apararece bien

https://i.imgur.com/RI1tabo.jpg

Pero al entrar...ahí es cuando vienen todos los problemas

https://i.imgur.com/bJ7rmEL.jpg
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Dhayzon

  • Sophist Member
  • *****
  • Posts: 1,297
  • Gender: Male
  • DhayZone RevolutioN
    • Dhayzon on GitHub
    • @dhayzon on Twitter
    • http://dhayzon.com/
Re: No se ve como debería
« Reply #12 on: January 16, 2018, 12:06:50 PM »
me imagino que tu problema ya está solucionado con respecto a los estilos, pues ahora te explico como funciona un certificado SSL

Los SSL son gratuitos en algunos hosting, En otros Tienes q Comprarlo.

a veces de por si ya lo tienes habilitado, en algunos casos tienes q habilitarlo.

según lo que tengo entendido google esta o yá empezo o no se,  a penalizar sitios sin SSL  es por eso que chrome muestra cualquier sitio que no tenga SSL ,como no seguro.  más alla de si en realidad lo es o no.

esos son problemas muy ajenos a SMF (tienes que buscar información y leer al respecto si estas interesado)

pues si de alguna forma decides hacer uso de SSL en tu SMF

necesitas  hacer 2 cosas importantes

Paso 1:

usar herramientas que ofrece SMF  (repair_settings)

https://download.simplemachines.org/index.php?tools

este archivo te permite  cambiar el dominio de tu foro.

¿para que necesitas esto?

cuando estés haciendo uso de la herramienta

algunas rutas empezaran con  http://...........

tienes que cambiar todas a https a si  https://...........

listo ya está ahora cuando ingreses a tu foro con   https deveria cargar todo perfectamente


pero aun seguirá trabajando en http y seguiras con problemas ... para eso  necesitas hacer uso de tu .htaccess   donde escribiras un codigo que redirija cualquier entrada sobre http a https 

si algun usuario accede por http tu web tiene que tener la capacidad de redirigirlo automaticamente a https

esto lo puedes buscar en google es tambien ageno a smf 
buscalo como

Redirigir de http a https .ataccess

tendras  muchas respuestas  ademas es diferente si usas tu sitio con WWW o sin WWW 

SALUDOS

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #13 on: January 16, 2018, 01:32:58 PM »
Cómo lo de los estilos? Perdóname pero ahí me perdí

Y ese archivo,el repair_Settings dónde lo tengo que poner?

Lo del .htaccess ya lo miré y no me aparece en el Cpanel,no sé si es que es un archivo que tengo que crear yo pero por lo que he leído debería estar en public_html prto yo al emnos no lo encuentro

Yo no tenía o no sabía si lo tenía (el SSL) pero tampoco creo que si lo desinstalo se me acabe el problema porque hoy por hoy me sigue saliendo igual...no seguro,se ve mal y si no cargas los "scripts no seguros" no se ve como debería

Gracias y un saludo
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Dhayzon

  • Sophist Member
  • *****
  • Posts: 1,297
  • Gender: Male
  • DhayZone RevolutioN
    • Dhayzon on GitHub
    • @dhayzon on Twitter
    • http://dhayzon.com/
Re: No se ve como debería
« Reply #14 on: January 16, 2018, 05:08:33 PM »
los estilos son los archivos que le dan estilo a tu foro (scripts, imagenes , css)

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #15 on: January 16, 2018, 06:25:13 PM »
Ah no...pues eso no se ha solucionado
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Dhayzon

  • Sophist Member
  • *****
  • Posts: 1,297
  • Gender: Male
  • DhayZone RevolutioN
    • Dhayzon on GitHub
    • @dhayzon on Twitter
    • http://dhayzon.com/
Re: No se ve como debería
« Reply #16 on: January 17, 2018, 02:01:17 AM »
pues poco podemos hacer cuando nosotros entramos a tu sitio y encontramos que funciona bien. al menos yo veo tu sitio esta en privado y me cargaperfectamente todo

Offline vicram10

  • SMF Hero
  • ******
  • Posts: 5,971
  • Gender: Male
  • Founding Father of Ultimate Portal
    • vmrm10 on Facebook
    • vicram10 on GitHub
    • vicram10 on LinkedIn
    • @vicram_10 on Twitter
    • Noticias Tecnologicas, Tutoriales e Internet
Re: No se ve como debería
« Reply #17 on: January 17, 2018, 06:51:03 PM »
Ah no...pues eso no se ha solucionado

al entrar a tu sitio todos vemos que tenes el theme curve y se ve sin problemas

Offline Natalia66

  • Jr. Member
  • **
  • Posts: 217
    • El sitio de mi recreo
Re: No se ve como debería
« Reply #18 on: January 18, 2018, 09:42:57 AM »
Si...cuando lo ves de entrada parece que está bien,pero al entrar en los temas es cuando se descompone todo.Ahora ya no sale ni  lo de "los scripts no seguros"  ni se descompone porque desde la Administración/ servidor/ base de datos y rutas le hemos quitado la "s" pero claro...no sé hasta qué punto ésto es la solución porque si tiene el certificado y debería ser un sitio seguro y podría tener lo de la "s" de las narices ¿no?...no sé
"Nunca discutas con un imbécil, te hará descender a su nivel y allí te ganará por experiencia. "

Versión 2.0.15
www.elsitiodemirecreo.net

Offline Dhayzon

  • Sophist Member
  • *****
  • Posts: 1,297
  • Gender: Male
  • DhayZone RevolutioN
    • Dhayzon on GitHub
    • @dhayzon on Twitter
    • http://dhayzon.com/
Re: No se ve como debería
« Reply #19 on: January 18, 2018, 11:29:46 AM »
como te dije, poco podemos hacer nosotros con respecto a eso mientras no podamos visualizar el error por nuestra parte.
y como te explique arriba  lo que se tiene que hacer, es el procedimiento ideal.

y si no te carga fijate que arriba no estes entrando atra vez de HTTPS  borra tu historial carga de nuevo todo pero Sin HTTPS.

Como te das cuenta estamos adivinando. por que en si no tenemos pruebas  en que basar nuestras soluciones.. arriba te explique todo.