SMF Support > SMF 2.0.x Support

Connection Problems- Not GoDaddy

(1/1)

Torngate:
So I've seen this issue discussed a lot of times.

But my issues seem to be separate from the rest.

My website, as in the other cases, has stopped working. When I try and connect, I get the error.

"Connection Problems
Sorry, SMF was unable to connect to the database. This may be caused by the server being busy. Please try again later. "

After talking with their tech support, I pull the backups from the past three months (site and database) and try and fix the issue.

In Cpanel, I can see the Database. In PHPMyAdmin I see the database. All settings are correct. When I run Repair_settings.php, the repair tool is unable to connect to the database. As such, repair_settings isn't working.

PHP   5.6.32
MySQL   5.6.32-78.1
SMF version: 2.0.15

Host: Bluehost

Site: Shadowfleet.org/forum


I've been unable to run the installer to connect to the database in a separate subdirectory either.

Any help is appreciated.

Thanks in advance



EDIT 1: SO now my site is only serving 500 errors on anything that is related to the /forum subdirectory. No idea why.

Kindred:
500 errors might be because of the chmod settings of your files.
Your host should be able to tell you why you’re getting to 500 errors.

As for the database...  use repair_settings. Don’t worry about the database error message...   use the repair to actually set the database information correctly.

Torngate:
Hey Kindred

So I did a bit more digging. The host was not forthcoming on why the 500 errors took place, so I did what anyone probably shouldn't do in my case, and wiped everything clean and started from backups.

What I found was that if I made a new user for SMF to use with mySQL, and a user for me to use, it worked fine, but if I combined the two and used my default MySQL credentials, it didn't work at all. Did a fresh install, uploaded the rest of my files, and it seems to be working now. No idea why or how.

However, thanks for the ideas.

Navigation

[0] Message Index

Go to full version