Advertisement:

Author Topic: Gap in header (Whitebox theme)  (Read 487 times)

Offline Fat Rat

  • Semi-Newbie
  • *
  • Posts: 36
Gap in header (Whitebox theme)
« on: January 19, 2018, 08:07:41 AM »
My site at http://www.vanping.com/smf/ has a slight glitch, no matter what size I make the logo there is a gap between the header area and the menu bar.

I assume this is a value in a .css file? Could someone point me in the right direction please?

Offline Arantor

  • Resident Overthinker
  • SMF Friend
  • SMF Legend
  • *
  • Posts: 69,123
    • StoryBB/StoryBB on GitHub
Re: Gap in header (Whitebox theme)
« Reply #1 on: January 19, 2018, 08:11:27 AM »
It's not CSS related - the background image that makes up that corner (and the other corner) is only a certain height. You'd need to make the image itself bigger to solve that.

Themes/whitebox_202/images/id/header-l.png and Themes/whitebox_202/images/id/header-r.png are what would need to be changed, though you might have to handle some CSS afterwards.
Don’t try to tell me that some power can corrupt a person. You haven’t had enough to know what it’s like.

Nothing turns to hate so bitter as what once was love.

Offline Gwenwyfar

  • Pirate Valkyrie Neko-chan
  • Lead Customizer
  • Sophist Member
  • *
  • Posts: 1,359
  • Gender: Female
    • Gwenwyfar on GitHub
Re: Gap in header (Whitebox theme)
« Reply #2 on: January 19, 2018, 08:27:41 AM »
For the gap between the header and menu look up for

Code: [Select]
#header {
position: relative;
height: 230px;
overflow: hidden;
background: white url(../images/id/header-bg.png) 0 0 repeat-x;
}

The height defined there is different than your logo size, so there is an extra space below.

If you mean the gap on the left side that's under #logo a, the "left" value.

Though that entire setup is bound to have issues, so there's a few other ways you could remove the gap...
Do you live today a life you would like to have for eternity?

Offline Fat Rat

  • Semi-Newbie
  • *
  • Posts: 36
Re: Gap in header (Whitebox theme)
« Reply #3 on: January 19, 2018, 09:09:45 AM »
Thank you, changing the value in index.css fixed it nicely  :)