Advertisement:

Author Topic: Unable to upgrade from 2.0.15 to 2.1 Beta 3  (Read 687 times)

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Unable to upgrade from 2.0.15 to 2.1 Beta 3
« on: January 20, 2018, 09:26:23 PM »
Hello!

I'm attempting to upgrade my dev SMF (which is a clone of my production site, files and database) to 2.1 Beta 3. However, each time I try, I get stuck on Step 1.

One of two things happen - in a loop (both things happen, which one happens first, appears to be a vairable)

1. I get an error that my language files are out of date. It allows me to "Skip", "Try English", or "Click here to try again". 
   - I have verified that the language file is the most up-to-date. I've downloaded the 2.0.15 and 2.1B3 full package and tried both
   - I've Skipped
   - I've tried again.

All options lead to...

2. FTP Connect.  I cannot connect to my FTP. The connection information works if I go to an FTP client or use Windows to connect, so I know that is right.  I've clicked on "here" to see the list of tiles that should change, but the link appears to be broken.  In addition, after the paragraph about what to do, I see "\n'); content.close ();}" PHP code.
   - I've re-downloaded the 2.1 B3 large upgrade file.
   - I've verified my connection information.


Sometimes it will tell me it connected and then send me back to item 1 above.

Am I missing something obvious?  I'd prefer not to do a clean install as eventually, I'd like to upgrade my forum to 2.1 and I'd like to help identify any issues in an upgrade path if possible.

Thank you!

Offline albertlast

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 211
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #1 on: January 20, 2018, 11:46:37 PM »
Please use the github version,
beta 3 is very old.

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #2 on: January 21, 2018, 01:33:18 PM »
Thank you, I guess I assumed the GitHub version and the download versions were the same.

I've moved past the FTP connect, but it is still telling me I have an old language file. I've downloaded the full 2.0.15 package and overrode the whole language file and I'm still getting the Item 1 above.  Should I be using the 2.0.15 or the 2.1 B3 from here: https://download.simplemachines.org/index.php?languages;id=1

Offline albertlast

  • Development Contributor
  • Jr. Member
  • *
  • Posts: 211
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #3 on: January 21, 2018, 02:10:04 PM »
When you want to upgrade (i hope not for productive purpose),
than use the upgrade version from here: https://www.simplemachines.org/community/index.php?topic=558451.0

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 48,583
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #4 on: January 21, 2018, 02:14:14 PM »
use the language files for SMF 2.1 b3, they should work with the version on github.

Offline shawnb61

  • Support Specialist
  • Full Member
  • *
  • Posts: 607
    • sbulen on GitHub
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #5 on: January 21, 2018, 02:33:26 PM »
I thought we only had English for 2.1...  Are there other language files out there?   
Address the process rather than the outcome.  Then, the outcome becomes more likely.   - Fripp

Offline Gwenwyfar

  • Customizer
  • Sr. Member
  • *
  • Posts: 911
  • Gender: Female
    • Gwenwyfar on GitHub
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #6 on: January 21, 2018, 03:13:46 PM »
Yes. Though I think they're mostly synced to beta 3 right now. There's going to be differences to the current github version (not that it should matter much anyway).

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #7 on: January 22, 2018, 07:52:49 AM »
No luck - same thing.

I've deleted the test site and re-cloned it, downloaded a new nightly build this morning. I've uploaded that - still the bad language file.

Skipping it takes me to the page asking for admin creds. I enter those (they work, I was able to log into the admin console with them before uploading the 2.1 b4 package), back to the language page.

I was able to get around the loop by changing "$disable_security = false" to "true"

(again, I'm doing this to help find bugs, not for production purposes. I don't mind removing packages and such. )

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #8 on: January 22, 2018, 07:59:32 AM »
Update:   (Nightly Upgrade: last_commit_08f647)

After bypassing with "$disable_security = true", forum upgraded - YAY

Go to sign in: "You didn't enter your password." I've tried 2 browsers and a second machine -same thing. Tried a different account...same thing.

*headdesk*

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #9 on: January 22, 2018, 11:54:51 AM »
(Sorry, not sorry) - This is my on-going "what i tried list"

1. Put form back online from aintance mode - no change
2. Tried to register and unable to - Screenshot (blank.png)
3. Finally made it to the home page. Error "Unable to load the 'boardindex_outer_above' template." - Screenshot (maybe.png)

Offline thunderchld

  • Semi-Newbie
  • *
  • Posts: 52
Re: Unable to upgrade from 2.0.15 to 2.1 Beta 3
« Reply #10 on: January 27, 2018, 09:55:32 AM »
I waited a few days and came back to this. Downloaded a new nightly build - same problem with the "Unable to load the 'boardindex_outer_above' template."

I added repair_settings.php and tried to set the default theme back to the default - no luck. 

Still investigating.