Advertisement:

Author Topic: Where do I find "Choose File" and "no file selected"  (Read 286 times)

Offline Dwev

  • Jr. Member
  • **
  • Posts: 247
Where do I find "Choose File" and "no file selected"
« on: February 24, 2018, 04:05:23 AM »
Our forum uses a different language, no problem, we just translated everything that still needed translation.

But there's one thing that we can't find: after you choose for "Attachments and other options" in the Reply form under "Attach" you see the button "Choose File" with the text "no file selected".

Can anybody tell me where these can be found, so we can translate these as well.
Thanks in advance.

Offline Sir Osis of Liver

  • SMF Super Hero
  • *******
  • Posts: 10,516
  • We were all equal in the end.
Re: Where do I find "Choose File" and "no file selected"
« Reply #1 on: February 24, 2018, 04:05:46 PM »
Unfortunately, some of this is browser specific.  IE11 displays this -



FF57 displays this -



There are several ways to change the button label, which may not work in all browsers -

https://stackoverflow.com/questions/1944267/how-to-change-the-button-text-of-input-type-file

Simplest is to make an image, that should work everywhere.

The link following the input field is here -

Post.english.php

Code: [Select]

$txt['clean_attach'] = 'Clear Attachment';

“The best laid schemes o' mice an' men / Gang aft a-gley.” - Robert Burns

Offline Dwev

  • Jr. Member
  • **
  • Posts: 247
Re: Where do I find "Choose File" and "no file selected"
« Reply #2 on: February 25, 2018, 12:47:53 AM »
@ Sir Osis: thank you, your answer led me to the solution.

I use all of my devices in English, so my browsers as well. After your explanation of how this is all dependent on the browser I switched my devices to the language of the forum, and all was well.

This means that people with the language of their device set to another language will see this button and the following text accordingly. I assume that they'll be able to comprehend the language that their device is set to, so problem solved, as far as I'm concerned... ;)