SMF Support > SMF 2.0.x Support

Subs-Post.php server errors

(1/6) > >>

Sir Osis of Liver:
Server is logging these errors in bursts -


--- Code: ---
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: server in  /Sources/Subs-Post.php on line 627
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1262
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1264
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: server in  /Sources/Subs-Post.php on line 627
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1262
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1264
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: server in  /Sources/Subs-Post.php on line 627
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1262
[01-Mar-2018 16:00:35 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1264
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: server in  /Sources/Subs.php on line 820
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: server in  /Sources/Subs-Post.php on line 627
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: character_set in  /Sources/Subs-Post.php on line 1219
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: character_set in  /Sources/Subs-Post.php on line 1219
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: character_set in  /Sources/Subs-Post.php on line 1219
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1262
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: utf8 in  /Sources/Subs-Post.php on line 1264
[01-Mar-2018 16:02:05 US/Pacific] PHP Notice:  Undefined index: character_set in  /Sources/Subs-Post.php on line 1219


--- End code ---

As you can see, they all occurred in a minute and a half, no other errors for past 24 hours.  What can cause this?

Illori:
i dont believe we have ever figured this one out. you can search the forum for other topics related to this.

GigaWatt:
Based on the errors... maybe related to the database character set encoding options ???.... UTF-8 vs. ANSII ???.

Sir Osis of Liver:
I've seen some of these errors on another forum, they don't appear in forum error log, only server log.  Fudged them on the other forum, nothing bad happened -


--- Code: ---
/// Fix undefined index error
if (!isset ($context['utf8']))
$context['utf8'] = '';


/// Fix undefined index error
if (!isset ($context['server']['is_windows']))
$context['server']['is_windows'] = '';


--- End code ---

Think I'll do the same here.  I've downgraded php 7.0.27 -> 5.6.33, will let it run for a while before changing anything, see if errors are reduced.

richardwbb:
Where is that code put Sir Osis of Liver? Would that work within index.php all of SMF?

Navigation

[0] Message Index

[#] Next page

Go to full version