Advertisement:

Author Topic: Header Login not working  (Read 229 times)

Offline nc3man

  • Jr. Member
  • **
  • Posts: 111
Header Login not working
« on: March 12, 2018, 03:47:11 AM »
We are running SMF 2.0.15 Curve theme, minor css customizations only. Sometime in the past couple months (maybe even just post 2.0.15 upgrade last November), users on our forum have noticed that the login area in the header, upper left, has stopped working. However, if you press the main login button, you can login just fine as in the first screenshot. Also, if you press the small "Please login" just above the header login, that also brings up the dialog in the screenshot and authenticates just fine. Any ideas how this can happen?

To be specific, when trying to use the header login, upper left, we get "An Error Has Occurred! Your session timed out while posting. Please go back and try again."  See second screenshot.

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,129
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Header Login not working
« Reply #1 on: March 12, 2018, 03:52:29 AM »
You could install this, it should fix your problem, https://custom.simplemachines.org/mods/index.php?mod=4167

Or search for the error on here and you'll find various threads containing the solution.

Offline nc3man

  • Jr. Member
  • **
  • Posts: 111
Re: Header Login not working
« Reply #2 on: March 12, 2018, 04:05:48 AM »
Thanks - I will try that mod. It is also fixed by just selecting the stock Curve theme. When we migrated to 2.0 quite a while back, we created a copy of the Curve theme in a separate Themes directory and modified a few things, only cosmetic for appearance. Before I install the suggested mod, I'll check to see how to fix our customization, which really was only CSS mods.

Again - thanks for the quick reply. I should have just searched on that error and I wouldn't have had to post here.

Offline lurkalot

  • Sophist Member
  • *****
  • Posts: 1,129
  • Gender: Male
  • Tinyportal Support
    • guitaristguild on Facebook
    • Tinyportal on GitHub
    • @GuitaristGuild on Twitter
    • Guitarist Guild
Re: Header Login not working
« Reply #3 on: March 12, 2018, 04:29:39 AM »
Ok, thought it was the default.  But same applies.   ;)

If you want to do it manually to your custom theme, https://wiki.simplemachines.org/smf/Login_error_2.0.14

Offline nc3man

  • Jr. Member
  • **
  • Posts: 111
Re: Header Login not working
« Reply #4 on: March 12, 2018, 05:35:49 AM »
Thank you - I got all my customizations back. Per your reference, there was the one-line mod to index.template.php that did the trick.