Advertisement:

Author Topic: Add my logo  (Read 722 times)

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Add my logo
« on: March 13, 2018, 12:49:36 PM »
I haven't been on an SMF forum in a while, but I've installed a new one. I thought it'd be easier to add my logo. Where do I do that?

Thanks.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,089
Re: Add my logo
« Reply #1 on: March 13, 2018, 12:54:28 PM »
which version are you using? what theme are you using?

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #2 on: March 13, 2018, 01:14:13 PM »
SMF 2.0.13
Default

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,576
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Add my logo
« Reply #3 on: March 13, 2018, 01:28:34 PM »
In theme settings, there's a setting "Logo image URL". Could not be much simpler really.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #4 on: March 13, 2018, 01:41:39 PM »
I went there and do not see "Logo Image URL." I've attached a screenshot.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,576
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Add my logo
« Reply #5 on: March 13, 2018, 01:45:26 PM »
Admin -> Configuration -> Current Theme
or
Admin -> Configuration -> Themes and layout -> Theme Settings -> Curve

You will see all the theme specific options there.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #6 on: March 13, 2018, 01:54:49 PM »
Thank you. Also, do you see how next to "Main" the link that is there doesn't show? And to the far right of the link menu there is a broken image. That is happening everywhere. Any ideas on what that could be and how to fix it?

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,576
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Add my logo
« Reply #7 on: March 13, 2018, 02:15:00 PM »
What is repair_settings.php?

Make sure all paths and urls are correct, and all using the same format ( Either all http or all https, all with www or all without ).

A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #8 on: March 13, 2018, 03:16:00 PM »
Thank you. I did that and it didn't fix it. When I put my mouse over the links in the navigation, the links disappear (it still works when I click it but visually it disappears). And the drop down menu that comes out of the link is difficult to read. Like there's a background image not loading. And those other images are broken are still broken.

Offline Illori

  • Project Manager
  • SMF Legend
  • *
  • Posts: 50,089
Re: Add my logo
« Reply #9 on: March 13, 2018, 03:17:20 PM »
can you provide your URL?

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #10 on: March 13, 2018, 03:20:20 PM »

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,576
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Add my logo
« Reply #11 on: March 13, 2018, 03:31:59 PM »
That's odd - the pics are fine, and the addresses too.

If I access them directly, for example these
https://marriageradio.com/marriage-forum/Themes/default/images/off.png
https://marriageradio.com/marriage-forum/Themes/default/images/upshrink.png
both load just fine. They just refuse to show up on your forum.

Do you have access to your server's logs? Is there anything that could be related?

EDIT:
Also noticed, your logo is from a http address, so it is causing a mixed content warning.
You may want to fix that.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline alphacaveman2

  • Semi-Newbie
  • *
  • Posts: 49
Re: Add my logo
« Reply #12 on: March 13, 2018, 09:12:15 PM »
Thanks for looking Lex. I'll change the logo source to https.

There are no errors showing in the log. I guess I'll ask the host though.

Thanks for looking.

Offline Aleksi "Lex" Kilpinen

  • A Peculiar Finn
  • Lead Support Specialist
  • SMF Super Hero
  • *
  • Posts: 17,576
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
Re: Add my logo
« Reply #13 on: March 14, 2018, 02:05:26 AM »
Yeah, do ask your host, because I noticed the links I posted above give a 404 if I access them through the link - but direct access by copying the address to a browser works. Something is off on the hosts side.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

How you can help SMF

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline vmax1981

  • Newbie
  • *
  • Posts: 4
Re: Add my logo
« Reply #14 on: May 24, 2018, 03:53:02 AM »
hxxp:marriageradio.com/marriage-forum/ [nonactive]

Wow how did you do that ?what is the file format? the size?and how?

Offline Steve

  • Freak
  • Support Specialist
  • SMF Hero
  • *
  • Posts: 4,421
  • Gender: Male
  • I have not yet begun to procrastinate.
Re: Add my logo
« Reply #15 on: May 25, 2018, 08:01:37 AM »
Right-clicking on the image will give you the format and size. As for how: https://wiki.simplemachines.org/smf/How_to_change_the_logo

@ alphacaveman2 - has this matter been resolved?
Online Manual

Please do not PM me for support.