Advertisement:

Author Topic: SSL mixed content issue that has me stumped  (Read 1933 times)

Offline sprntrcr

  • Semi-Newbie
  • *
  • Posts: 17
SSL mixed content issue that has me stumped
« on: April 23, 2018, 06:37:52 PM »
So I moved the forum to a new server (old was using https:  and so is the new server)

I get: (using chrome)
Insecure content blocked
This page is trying to load scripts from unauthenticated sources.

If I click - Load unsafe scripts  everything then loads fine.

I went to whynopadlock.com and get a long list of mixed content errors like these: (full report [nofollow])

Code: [Select]
Hard Failure - A file with an insecure url of "http://worldwidebeekeeping.com/forum/Themes/Headline_2_0/css/index.css?fin20" was loaded on line: 4 of https://worldwidebeekeeping.com/forum/.
This URL will need to be updated to use a secure URL for your padlock to return.

Hard Failure - A style-sheet with an insecure url of "http://worldwidebeekeeping.com/forum/Themes/default/css/webkit.css" was loaded on line: 5 of https://worldwidebeekeeping.com/forum/.
This URL will need to be updated to use a secure URL for your padlock to return.

But when I look at the page source all are https://  and accessible.
Code: [Select]
<!DOCTYPE html PUBLIC "-//W3C//DTD XHTML 1.0 Transitional//EN" "http://www.w3.org/TR/xhtml1/DTD/xhtml1-transitional.dtd">
<html xmlns="http://www.w3.org/1999/xhtml">
<head> <link rel="shortcut icon" href="favicon.ico" />
<link rel="stylesheet" type="text/css" href="https://www.worldwidebeekeeping.com/forum/Themes/Headline_2_0/css/index.css?fin20" />
<link rel="stylesheet" type="text/css" href="https://www.worldwidebeekeeping.com/forum/Themes/default/css/webkit.css" />
<script type="text/javascript" src="https://www.worldwidebeekeeping.com/forum/Themes/default/scripts/script.js?fin20"></script>
<script type="text/javascript" src="https://www.worldwidebeekeeping.com/forum/Themes/Headline_2_0/scripts/theme.js?fin20"></script>

Any thought/ideas would be greatly appreciated

BTW I have another SMF instance running in another virtual host on this server and it is running https with no issues.

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,400
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: SSL mixed content issue that has me stumped
« Reply #1 on: April 23, 2018, 06:47:50 PM »
Your urls are wrong Seems like your .htaccess redirects https://www.worldwidebeekeeping.com/forum/ to https://worldwidebeekeeping.com/forum/  no www

Adjust all you urls to use https://worldwidebeekeeping.com/forum/
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro

Offline sprntrcr

  • Semi-Newbie
  • *
  • Posts: 17
Re: SSL mixed content issue that has me stumped
« Reply #2 on: April 23, 2018, 08:57:24 PM »
Darn, sometimes you can look right at it and not see it.  Guess I was too focused on http: & https:

Fixed the problem,  Thank you very much,  I was ready to pull out my hair in frustration.

Offline vbgamer45

  • SMF Friend
  • SMF Super Hero
  • *
  • Posts: 21,400
    • smfhacks on Facebook
    • VBGAMER45 on GitHub
    • @createaforum on Twitter
    • SMF For Free
Re: SSL mixed content issue that has me stumped
« Reply #3 on: April 23, 2018, 09:02:52 PM »
Glad to help.
Community Suite for SMF - Take your forum to the next level built for SMF, Gallery,Store,Classifieds,Downloads,more!

SMFHacks.com -  Paid Modifications for SMF

Mods:
EzPortal - Portal System for SMF
SMF Gallery Pro
SMF Store SMF Classifieds Ad Seller Pro