Advertisement:

Author Topic: Your installer for the latest version of smf_2-0-15 has a flaw, It doesn't use..  (Read 631 times)

Offline iconic420

  • Newbie
  • *
  • Posts: 1
It doesn't use the full domain. Instead it inserts 127.0.0.1 or localhost , it make a issues with the database population stage in the installer.


-David

Offline Sir Osis of Liver

  • SMF Hero
  • ******
  • Posts: 7,825
  • 'Tis the gift to be simple (duh)
The installer displays localhost as default setting.  If host uses actual server address, you have to put it in that field or SMF will not be able to connect to database.  If connection is successful, db should populate correctly.

Online Aleksi "Lex" Kilpinen

  • Support Specialist
  • SMF Super Hero
  • *
  • Posts: 16,873
  • Gender: Male
  • Don't worry, I'm n00b friendly
    • Aleksi.Kilpinen on Facebook
    • aleksi-kilpinen on LinkedIn
That is a known issue AFAIK, and not actually a bug in the installer, but an incompatibility with certain server setups. In these cases the installer fails to recognize the urls correctly, and they should be fixed manually.
A Finnish Support Specialist
 Happily running multiple SMF 2.0 installations.

"Before you allow people access to your forum, especially in an administrative position, you must be aware that that person can seriously damage your forum.
 Therefore, you should only allow people that you trust, implicitly, to have such access." -Douglas

Offline Illori

  • Project Manager
  • SMF Master
  • *
  • Posts: 49,268
That is a known issue AFAIK, and not actually a bug in the installer, but an incompatibility with certain server setups. In these cases the installer fails to recognize the urls correctly, and they should be fixed manually.

actually it is a bug that was attempted to be fixed years ago but never actually fixed the issue. i think they corrected it in SMF 2.1, but it has not been back ported as we cant always duplicate the issue to confirm the fix.

Offline Kindred

  • The Mean One
  • Support Specialist
  • SMF Legend
  • *
  • Posts: 56,273
  • Gender: Male
    • Kindred-999 on GitHub
however, there is a simple work-around/fix --- use repair_settings.php to correctly reset the domain and url settings
Please do not PM, IM or Email me with support questions.  You will get better and faster responses in the support boards.  Thank you.